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The purpose of this tutorial is to make a two-part mold that will let you produce a ring, or 
actually, half of the ring. Wax will be poured into the mold and the finished pieces will be 
used in lost wax technique production. 

Rhinoceros and VisualMill, the latest advanced computer modeling and manufacturing 
programs, make it easy to: 

• revise and change designs 

• create a line of pieces based on one model 

• reproduce fine detail 

• create a library of reusable parts 

This tutorial covers the basic steps for creating and milling a mold for prototyping or 
manufacturing. 

 

 Model the part 

 Create a model of a ring shape in Rhino. 

 

 Model the mold 

 Use the model of the ring shape to create the mold.  

 Create cutting instructions 

 Import the model of the mold into VisualMill to create cutting 
instructions for a milling machine. 

 Send the instructions to the machine to cut the part. This process 
varies according to the machine and is not covered in this 
tutorial.  

To use the tutorial 
1 If you do not have the VisualMill program installed, install the Evaluation version 

from the tutorial CD. 

2 Work through the tutorial steps. 

  Start by designing the curves that are needed to build the surfaces of the ring you 
are going to produce, and then you will work through the steps required for the 
construction of the two-part mold. 
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Product links 

 

Rhinoceros 
Start with sketches, drawings, physical models, or only an 
idea—Rhino provides the tools to accurately model your 
designs ready for rendering, animation, drafting, 
engineering, analysis, and manufacturing. 
www.rhino3d.com 

 

VisualMill 
VisualMill is a 3-axis solid/surface milling package, which 
seamlessly integrates fast, gouge-free tool path generation 
with cut material simulation in an easy and fun to use 
package running on standard Windows hardware. VisualMill
can drive a machine such as a CNC router or milling 
machine such as those manufactured by Techno-isel or 
Roland Digital Group of America. www.mecsoft.com 

 
Roland Digital Group of America 
Affordable desktop CNC scanning and milling machines 
such as the CAMM3, PNC 2500, and the new MDX 500 for 
use in the jewelry and educational markets. 
www.rolanddga.com 

 

Techno-isel 
CNC routers for the sign making, woodworking, prototyping 
and educational markets. www.techno-isel.com 

 

Start modeling with Rhino 
You can start with a blank file and create the model yourself or you can open the model 
provided and follow along with the parts that are already there. 

To start a new model 

  If you want to actually create this model yourself, you can start a blank Rhino file 
and draw all the parts as directed in this tutorial. 

 1 From the File menu, click New (File menu: New). 

 2 In the Template File dialog box, select Centimeters.3dm and click OK. 

To open the sample model 

  If you want to simply open the model provided, you can turn various layers on and 
off to see how the curves and surfaces were created. 

 1 From the File menu, click Open (File menu: Open). 

 2 In the Open dialog box, select Competed Mold.3dm, and click OK. 

  The initial curves are displayed on layers 01 Curves 1, 2, 3, 02 Curves 4, 5, 
and 03 Curve 6. 

  In addition, the Properties command for each curve lists the curve name, so you 
can follow along with the tutorial instructions. 

http://www.rhino3d.com/
http://www.mecsoft.com/
http://www.rolanddga.com/
http://www.techno-isel.com/
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To set the grid snap spacing 

 1 Open the Document Properties dialog box (File menu: Properties). 

 2 On the Grid page, set the Grid Snap Spacing to 0.5 and click OK. 

 3 On the Status bar, click Snap to turn snap on. 

Draw the first curves 
While constructing the curves, it is very important to check their symmetry and 
appearance as you go along. Spend some time changing them or shaping them. The shape 
of the surfaces depends on the construction of the original curves. 

There is never one single strategy in building a surface. You can use your imagination to 
create the shapes you want, but keep the limitations of the manufacturing processes you 
are going to use in mind. 

To draw curve 1 

  Curve 1 is the center circle of the ring. 

 1 Start the Circle command (Curve menu: Circle > Center, Radius). 

 2 At the Center of circle … prompt, type 0,0,0. 

  This sets the center of the circle at the origin point in space. 

 3 At the Radius … prompt, type 8 or drag the radius 8 units. 

 
Curve 1 is a circle. 

To draw curve 2 

Draw the left half of the outline of the ring. 

 1 Start the InterpCrv command (Curve menu: Free-form > Interpolate Points). 

 2 At the Start of curve … prompt, start the curve on a snap point on the centerline 
(y-axis). 

 3 At the Next point of curve … prompt, draw another point to define your curve 
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 4 At the Next point of curve … prompts, continue to draw points, ending on a grid 
snap point on the center line. 

 
Draw curve 2. 

Edit the second curve 
You are going to make a mirrored copy of curve 2 to create the other half of the outside 
ring profile. This brings up an important point about the point where the two mirrored 
curves will meet. There should be no dip or point when the curves meet. To accomplish 
this requires just a little point editing on the curve. 

To edit the control points for curve 2 

 1 Turn on the control points for curve 2 (Edit menu: Control Points > Control Points 
On (F10)). 

 2 Look at each end of the curve. 

The important factor is that the control point at the end of the curve and the next 
control point are perfectly aligned horizontally. 

  The important factor is that the control point at the end of the curve and the next 
control point are perfectly aligned horizontally. If they are not, move the second 
control point using grid snap, a construction line, Ortho, or the SetPt command 
(Transform menu: Set Points). This will ensure that after it is mirrored, the 
transition between the two halves of the mirrored curve will be tangent and 
horizontal. 

For more information about this, see the Rhino Help file topic on continuity. 

 
Line up the two control points at the top end of the curve.  
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Line up the two control points at the lower end of the curve. 

To mirror the curve 

  Mirror the curve across the y-axis (Transform menu: Mirror). 

  Use End object snap and Ortho so the ends of the curve touch each other exactly. 

  This creates curve 3. 

  
Mirror the curve in the Top viewport. 

Define the side profile 
Design curves 4 and 5. These curves define the shape of the ring seen from the right side. 

It is important to carefully place the start and end points of both curves with respect to 
the curves you have drawn so far. In the Perspective viewport you can see that the 
curves start at the endpoint of the mirrored curves.  

  
Curves 4 and 5 in the Perspective viewport. 
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In the Right viewport, you can see that they end directly over the inner circle. 

  
Curves 4 and 5 in the Right viewport, showing the relationship to the center circle. 

To draw curves 4 and 5 

 1 Select the inner circle so you can see it highlighted and use it as a guide. 

 2 Start the InterpCrv command (Curve menu: Free-form > Interpolate Points). 

Start drawing the curves in the Perspective or Top viewport. 

Use grid snap for the start of the curve to accurately place the beginning and end 
points. 

To design your curve more freely, you can turn off grid snap for the intermediate 
points. 

 3 Continue drawing the curve in the Right viewport. 

 4 Use grid snap or point filters (.x, .y, .z) to line the end of the curve up with the 
circle. 

   

Connect the curves 
To complete the side profile of the ring, draw a curve to connect curves 5 and 6 then 
mirror the side profile curves to examine the whole shape. 

To complete the side profile of the ring: 

 1 Use the InterpCrv command to draw curve 6 to connect curves 4 and 5 (Curve 
menu: Free-form > Interpolate Points). 

    
Curve 6 connects curves 4 and 5. 
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  You have defined the complete half of the outline of the ring viewed from the right 
side and from the top. 

  At this stage it is a good idea to check all the proportions and to see if some 
adjustment might be needed to give the ring a better shape. 

 2 For a better idea of how your design is developing, Mirror curves 4, 5, and 6 
across the world y-axis in the right viewport so that you can see the complete ring 
profile as seen from the right side (Transform menu: Mirror).  

  You will not be using this mirrored curve for constructing the model, so you can 
delete it when you are satisfied that the shape is what you want. 

   
Mirror the curves to study the design of the entire profile. 

Create the inner edge 
You are now going to create a curve that defines the inner edge of the ring. This curve is 
shaped the way curve 6 is in the right view and the way curve 1 is in the top view. It is a 
sort of bent circle. Rhino has a command that creates this curve based on these curves. 

To create curve 7 from curves 1 and 6 

 1 Select curves 1 and 6. 

  
Curves 1 and 6 are used to create curve 7. 
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 2 Use the Crv2View command to create curve 7 (Curve menu: From 2 Views). 

  
Curve 7, the top edge of the ring. 

 3 If curve 7 is not a single object, use the Join command to join the parts of the 
curve into one (Edit menu: Join). 

Refine the curve 
There may be too many control points in this curve. Curves with very high number of 
control point create dense surfaces. It is better to use only as many control points as are 
necessary to maintain the shape you want. 

The next step will be to reduce the number of control points in the curve. 

  
Curve 7 has too many control points. 

To rebuild the curve 

 1 Turn on the control points on curve 7 (Edit menu: Point Editing > Control 
Points On). 

 2 Press Esc to turn off the control points. 

 3 Use the Rebuild command to set the number of control points to 10 (Edit menu: 
Rebuild). 

Preview the curve to check whether the rebuilt curve is going to be too different 
from your original curve. 
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Use the Delete input option to remove the original curve. 

  
Rebuild the curve with 10 control points. 

Draw the side profiles 
Design the curves that define the profile of the ring when viewed in the Front viewport. 

It will be useful to draw the line (curve 8) that will be used for finding the point where a 
line drawn from the center of the original circle intersects curve 2. This is the point where  
the side profile curve starts. 

To draw the side profile curves 

 1 Use the Line command with Snap or Ortho to draw a horizontal line from the 
center of the original circle to out beyond curve 2 as shown (Curve menu: Line > 
Single Line). 

  
Construction line for drawing the side profile. 

 2 Use the Curve command and the Intersection object snap to draw a curve that 
starts at the intersection of curve 2 and your construction line (Curve menu: Free-
form > Control Points). 

Use the Front viewport for drawing the curve. It should end touching curve 7. 

Again, the control points should line up. In the example curve, there are only three 
control points, which form a right angle. 
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Draw the side profile curve. 

 3 Trim away the left half of the curve that forms the upper edge of the ring at the 
side profile curves (Edit menu: Trim). 

You now have all the curves you need for creating this model. 

   
Use these curves to create the ring surface. 

Create the first surface 
You are about to build your first surface from the curves. You will be using only the curves 
on the right half of the model. 

To create the first surface 

 1 Extrude with the Straight option the profile curve a short distance to the left 
(negative x-direction) as shown (Surface menu: Extrude > Straight).  

   
Extrude the profile curves at the bottom. 
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 2 Extrude the other profile curve and the outline curve as shown (Surface menu: 
Extrude > Straight). 

   
Extrude the profile curve at the top and the outline curve. 

  This creates a series of construction surfaces. The NetworkSrf command can use 
these surfaces to establish a direction for the surface. 

 3 Hide the curves so they do not interfere with selecting the surface edges (Edit 
menu: Visibility > Hide). 

   
Hide the selected curves you used to extrude the construction surfaces. 

 4 Start the NetworkSrf command (Surface menu: From Curve Network). 

  Select the edges of the dummy surfaces, the top curve, and the interior profile 
curve as shown. 

  Set the Edge matching to Curvature for the surface edges (B, C, and D in the 
illustration) and Position for the open curve at the top edge (A in the illustration). 
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Create a surface from curve network. 

  The surface may take a few minutes to generate. 

   
The surface from curve network. 

 5 Rebuild the surface with 8 points in the u-direction and 15 in the v-direction. (Edit 
menu: Rebuild) 

  The u and v-directions may be different for your surface. The direction depends on 
the order you selected the curves for the NetworkSrf command. 
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Rebuild the surface. 

  Be sure your picture looks like the image on the left, not the image on the right 
below. 

 
The surface should look like this. 

 
Not like this. 

 6 Mirror the ring half (Transform menu: Mirror). 

   
Mirror the rebuilt surface across the y-axis. 
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 7 Use the MatchSrf command to match the two surface edges for tangency with the 
settings shown (Surface menu: Surface Edit Tools > Match). 

   
Match the two surfaces with tangent matching. 

 8 Use the MergeSrf command to turn the two surfaces into one (Surface menu: 
Surface Edit Tools > Merge). 

  When selecting the surfaces, pick near the top of the ring in the Front viewport. 

 

Reshape the surface 
The surface is quite dense in spite of efforts at keeping the control point count low on the 
input curves. 

To make the surface easier to work with, rebuild the surface so that it has fewer control 
points. 

To reduce the control point count for the surface 

 1 Turn on the control points of the surface (Edit menu: Point Editing > Control Points 
On). 

  As you can see there are plenty to allow for modifications. 

   
Control points on the surface. 
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 2 Select one control point in the fourth row from the larger edge like the one shown 
below. 

   
Select one point in a row of points. 

 3 Use the SelV command to select all the control points in the same v-direction row 
(Edit menu: Control Points > Select Control Points > Select V). 

   
Select the row of points with the SelV command. 

  Note: The surface direction may be different from the example model. If this is 
the case, use the SelU command to select the row of points so it matches 
the image above. 

 4 Use the Scale2D command to move all the control points in this row toward the 
center of the ring (Transform menu: Scale > Scale 2-D). 

 5 For the origin point, type 0,0,0. 

  This is the center of the inner circle if you have not moved your model. 

 6 For the first reference point, in the Top viewport, drag the line out from the origin 
to near the row of points. 

   
 Scaling brings all the points toward the center. 
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 7 For the second reference point, drag the line down toward the center of the circle 
until the control points in your selected row are near the next inner row. 

  Watch the isocurves. Make sure the isocurve associated with the row of points you 
are scaling does not cross over the next row toward the center. This will cause an 
undercut in the ring surface. 

   
Use Scale2D to move the row of points in. 

Add interest 
The free-form modification of the surface is not over yet. You need to work on it a little bit 
more to make it more interesting. In the next step you are going to edit groups of control 
points to add some bulginess to the surface. 

To create bulges in the surface 

 1 Select the three groups of control points shown below: the three rows at the top 
center and matching groups on each side. 

   
Select rows of control points. 

 2 Use the Scale2D command to move all the control points in this row away from the 
center of the ring (Transform menu: Scale > Scale 2-D). 

 3 For the origin point, type 0,0,0. 
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 4 For the first reference point, in the Top viewport, drag the line out from the origin 
to the row of points.  

   
Use grid snap to maintain control over the location of your reference points. 

 5 For the second reference point, drag the line up to the grid snap point two units 
away from the original point. 

   
Scale the control points out from the center. 

  This creates three bulges in the ring surface. 
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 6 Use the EMap command to examine the ring with a gold texture map (Analyze 
menu: Surface > Environment Map). 

   
The EMap command displays the ring with a gold texture. 

You can see that the overall shape of the ring, especially from the top looking at the 
border, is changing considerably. Working with control points might be sometimes a bit 
time consuming, but it is a method for manipulating surfaces that is worth trying. 

Feel free to try any solution you may find interesting or useful to modify the control 
points. This is just one of many possibilities. 

Mirror the surface 
Mirror the ring half, match and merge the two ring halves into one surface. 

To create the other half of the ring 

 1 Use the Mirror command to create the other ring half (Transform menu: Mirror). 

  Use the Front or Right viewport. 

   
Mirror the ring half. 
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 2 Use the MatchSrf command to match the tangency of the surface edges (Surface 
menu: Edit Tools > Match).  

 3 Use the MergeSrf command to make the two surfaces into one (Surface menu: 
Edit Tools > Merge). 

 4 At the Select untrimmed surface to merge … prompt, set the Smooth option 
to No. 

  Since you already matched the surface edges so they are tangent, you do not need 
to smooth the surfaces together with the MergeSrf command.  

   
The merged ring halves. 

 5 Check the ring with the Zebra command (Analyze menu: Surface > Zebra). 

   
Check the surface with Zebra analysis. 
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Finish the interior 
You now only have the interior surface of the ring to finish. Use the Loft command to 
complete this surface. 

To create the interior surface 

 1 Start the Loft command and select the two edges of the surface as shown below 
(Surface menu: Loft). 

 
Loft the surface edge curves. 

 2 At the Adjust curve seams … prompt, press Enter if the curve seams line up as 
they do in the image below. 

   
Adjust curve seams. 

 3 Accept the default Loft Options. 

   
Default Loft options. 

 4 Join all the parts to create one object from the interior loft surface and the main 
ring surface (Edit menu: Join). 



Rhinoceros   Modeling and Mold Making for Jewelry Designers 

Copyright © 2003 Robert McNeel & Associates. All rights reserved. 21 

 5 As a clean-up of the finished product, use the FilletEdge command to create a fillet 
with a 0.5 mm radius at both of the interior edges of the ring so that there is a 
smooth transition between the two surfaces (Solid menu: Fillet Edge). 

Check model for unjoined edges 

  Use the ShowEdges command to check the joined ring model for unjoined (naked) 
edges (Analyze menu: Edge Tools > Show Edges). 

  Since the model will eventually be exported to a milling program, a closed model 
will be required. It is a good idea to check the model at intervals to catch modeling 
problems like this early. 

   
Check for unjoined edges. 

Examine the finished ring with environment mapping 

  Look at the ring in its entirety using the EMap command. 

 1 With the EMap command, try polished_gold.jpg to represent the material to be 
simulated (Analyze menu: Surface > Environment Map). 

   
Examine the finished ring with environment mapping. 

 2 Use the Turntable command to continuously rotate the view of the ring. 

  Any modification to the finished piece should be done now, because the next steps 
concentrate on making the mold. 
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Save a copy 
In the next sections you are going to cut up the ring to make mold parts, so make a copy 
of the completed ring surface and store it on a separate layer. 

To prepare the ring model for making the mold model 

 1 Use the Copy command with the InPlace option to create a copy of the ring (Edit 
menu: Copy). 

 2 Use the ChangeLayer command to place the ring copy on a new layer (Edit menu: 
Layers > Change Object Layer). 

 3 Turn the new layer off. 

Trim half the ring 
A surface is needed that will subtract an amount of volume from the thick part of the ring 
in order to make it hollow. 

One of the strategies used to accomplish this task is to create section curves of the ring 
surface. Since the upper and the lower part of the ring are evidently symmetrical, only the 
lower half is needed. 

You created the whole ring so you could complete the design, but you only need half the 
ring to make a mold, so before you start, trim away the top half the ring. 

To split the ring into two halves 

 1 In the Right viewport, use the CutPlane command to draw a cutting plane along 
the world y-axis that extends beyond the ring (Surface menu: Plane > Cutting 
Plane). 

   
Create a cutting plane through the ring. 



Rhinoceros   Modeling and Mold Making for Jewelry Designers 

Copyright © 2003 Robert McNeel & Associates. All rights reserved. 23 

   
The cutting plane. 

 2 Use the Trim command to trim away the top half of the ring with the cutting plane 
(Edit menu: Trim). 

 3 Delete the cutting plane surface. 

   
The trimmed ring half. 

Hollow the ring 
Create a box from which to subtract a part, leaving a hollow space that will be exactly 
shaped like half the ring. If you were to use the entire ring as it is now, it would make a 
heavy, solid lump of metal that require a lot of  time-consuming and expensive handwork 
to bring it to an acceptable weight.  

 
The finished mold parts. 

For the next part of this tutorial, you will create a hollow in the ring. You want to produce 
a mold that lets you control the thickness of the finished piece. To finish the piece, a 
goldsmith will weld the two parts and complete the finishing process. 
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Create curves on the surface 
First make curves that lie on the ring surface. Then offset these curves by 1 mm toward 
the inside. These inner curves will be used to create the hollowing surface. 

You might think to use the OffsetSrf command in this case, but it will create a surface 
that passes through itself. Unfortunately, the solution is not that easy. Offsetting surfaces 
that have complex curvatures may cause self-intersecting surfaces. This is unacceptable, 
so an alternative solution will have to be found an in order to build the surface. Offsetting 
curves does not create this problem, so you can offset curves based on the surface and 
use those curves to create the new interior surface. 

To create section curves 

 1 Use the Section command to create curves that radiate out from the origin point 
(Curve menu: From Objects > Section). 

 2 At the Select objects for sections prompt, select the ring half. 

 3 In the Top viewport at each Start of section prompt, type 0,0,0 and drag the 
section-defining line out beyond the ring as shown below. 

 4 Draw one section along the x-axis and one along the y-axis. 

   
Draw a section line through the ring along the y-axis. 

   
Draw a section line through the ring along the x-axis. 



Rhinoceros   Modeling and Mold Making for Jewelry Designers 

Copyright © 2003 Robert McNeel & Associates. All rights reserved. 25 

 5 Place two more sections more or less evenly spaced between the x- and y-axes as 
shown highlighted below. 

 
Draw two more section lines. 

 

Offset the curves 
Offset these sections to obtain smaller curves and from these build a surface inside 
the ring. 

The Offset command requires that the curve be parallel to the construction plane. Since 
the curves do not fit this requirement, set the construction plane to temporarily match a 
curve, offset the curve and then set the construction plane to match the next curve. 

To offset the section curves 

 1 Before you start, use the Lock command on the ring surface so you can see it, but 
not select it (Edit menu: Visibility > Lock). 

  This will help you keep track of where you are. 

 
Lock the ring surface. 
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 2 In the Perspective viewport, use the CPlane command with the Object option to 
align the construction plane with the first curve (View menu: Set CPlane > To 
Object). 

 
Set the construction plane to the section curve. 

 3 Use the Offset command to create the inside curve (Curve menu: Offset Curve). 

 4 Set the distance to 1. 

 5 At the Side to offset … prompt, click to the inside of the ring. 

    
Offset the curve toward the interior of the ring. 

   
The offset of the first section curve. 

 6 Use the CPlane Object command again to change the construction plane to the 
next section curve (View menu: Set CPlane > To Object). 
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 7 Use the Offset command to create the next inside curve (Curve menu: Offset 
Curve). 

 
Repeat the offset for each section curve. 

 8 Repeat steps 6 and 7 for the other two curves. 

 9 When you have offset all the curves, use the CPlane command World Top option 
to set the construction plane back to its normal position (View menu: Set CPlane > 
World Top). 

 
Reset the construction plane to World Top. 

10 Use the Mirror command in the Top viewport to mirror the new offset curves to 
the other side of the ring (Transform menu: Mirror). 

  Do not mirror the curve that lies on the y-axis. 

   
Mirror the offset curves across the y-axis. 

Create the hollow surface 
Once all the curves in the right position, offset the borders of the ring surface (internal and 
external borders shown in yellow), 1 mm to meet the end points of the offset curves. Use 
these curves to help define the surface. 
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To loft the inner surface 

 1 Unlock the ring polysurface (Edit menu: Visibility > Unlock). 

 2 Use the Offset command to create the edge curves for the inner surface (Curve 
menu: Offset Curve). 

  Start the Offset command before selecting the surface edges.  

  You cannot pre-select surface edges, but once you start the command, you will be 
able to do this. 

  

   
Offset the edge curves of the ring surface toward the interior. 

 3 Hide the ring surface (Edit menu: Visibility > Hide). 

 4 Use the two smallest offset curves at the x-axis to Trim the offset border curves 
since you will use only part of them (Edit menu: Trim). 

  Set the UseApparentIntersections option to On in the Top viewport. 

  You want the results to look like this: 

 
The curves defining the interior surface. 

 5 Select all these curves and use the NetworkSrf command to make the inner 
surface (Surface menu: From Curve Network). 

  Accept the default settings in the Surface From Curve Network dialog box. 
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The surface from curve network. 

 6 Rebuild the surface to reduce the complexity.  

  Use enough control points to keep the shape. In this case 33 points in the 
u-direction and 18 points in the v-direction were used. 

   
The rebuilt surface. 

Cap the surface ends 
A surface at the ends is needed. 

To create the end surfaces 

 1 Draw a Line to connect the ending points of the surface (Curve menu: Line > 
Single Line). 

Use the Endpoint object snap. 

 
A line defines the top edge of the end surface. 

 2 Use the PlanarSrf command selecting the line and the surface edge to create the 
end (Surface menu: Planar Curves). 
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Select the line and the edges of the surface to create the end surface. 

 
The end surface. 

 3 Repeat this for the other side. 

 4 Use the Join command to make these three surfaces into one (Edit menu: Join). 

 5 Use the Cap command to close the resulting polysurface. 

 6 Turn off the layer for the hollow. 

Create the first mold part 
The mold will be created in two parts: one half for the ring surface and one half for the 
hollow surface. You are now going to build the ring surface part of the mold. 

To create the mold part 

 1 Turn on the layer with the ring surface. 

 2 Use the Box command with the Center option to create a box with its top face 
lying on the construction plane (Solid menu: Box > Corner to Corner, Height). 

  The box has to be deep enough to enclose the ring surface.  

  Start the center of the box at 0,0,0.  
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  Make the Length and Width 50 mm and the Height -10 mm. This will center the 
box and make the top of the box line up with the construction plane. Remember 
that the lower half of the ring is below the construction plane. 

 
Create the mold box. 

 3 Use the BooleanDifference command to create the ring shape in the box (Solid 
menu: Difference). 

  Set the DeleteInput option to No. You may need the original ring surfaces later. 

   
Cut the ring shape into the mold box with a Boolean. 

 4 Use the Sphere command to create four registration keys (notches) at the corners 
of the mold half (Solid menu: Sphere > Center, Radius). 

  Use the Snap to draw the spheres with a diameter of 2 mm. 

  You can draw one sphere and then use the Mirror command to create the other 
three. 

 
Create the spherical registration keys. 
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 5 Use the BooleanDifference command to cut the registration keys into the mold 
(Solid menu: Difference). 

  Set the DeleteInput option to Yes. The spheres were easy to draw and you will 
not be needing them again. 

  Registration keys help get a perfect alignment between this part of the mold and 
the other half. The second half will have four protruding half spheres that fit into to 
the four notches. 

 
Cut the registration keys into the mold box with the spheres. 

A very little touch-up is needed to finish the mold: filleting where the four little 
hemispheres join the upper face of the mold. This is to allow easier coupling between the 
two parts of the mold. 

To round the corners 

 • Use the FilletEdge command to create the rounded edge of the notches (Solid 
menu: Fillet Edge). 

  The fillet radius is 0.5 mm. 

   
The rounded edges. 

  This part of the mold is complete. 

Create the gate 
There is one missing part: the gate. The gate is the spout where the wax will be injected 
into the mold. To build the gate, use three closed curves as shown below. 
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The curves that define the gate. 

Here is what the curves look like in the Front viewport.  

 
The gate curves in the Front viewport. 

To create the gate: 

 1 Use the Circle command to draw a circle at the edge of the mold box (Curve menu: 
Circle > Center, Radius). 

 2 Use the Rectangle command to draw two rectangles, one inside the edge of the 
ring surface and one about half way between the box edge and the ring edge 
(Curve menu: Rectangle > Center, Corner). 

  The rectangle closest to the ring is placed slightly below the other curves so that 
the wax will reach the part to be filled.  

  This is visible in the Right viewport. 

  The easiest way to do this is to create the circle and rectangles on the construction 
plane and then move them into place in the Right viewport. 

   
The gate curves in the Right viewport. 
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  Considering the geometry of the piece, the rectangular shape is used to eliminate 
undercuts.  

To create the gate 

 1 Use the Loft command to create a surface that connects the three closed curves 
(Surface menu: Loft). 

Use the Straight sections style option. 

   
The gate surface. 

 2 Use the Cap command to close off the ends of the gate surface and make it into a 
solid (Solid menu: Cap Planar Holes). 

   
The capped gate surface. 

This makes it easier to use the BooleanDifference command to cut the gate into 
the mold box. The Boolean commands work best when you use closed solids. 
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 3 Use the BooleanDifference command to subtract the gate surface from the mold 
box (Solid menu: Difference). 

  Set the DeleteInput option to No. You will use this part later to cut the gate into 
the upper part of the mold. 

 4 Hide the gate cutting solid (Edit menu: Visibility > Hide).  

   
The mold part. 

Create the second mold part 
The mold is made of two halves. You will create the second half the same way as the first. 

To create the second mold part 

 1 Use the Lock command on the mold part 1 you just created so you can work 
around it without accidentally selecting it (Edit menu: Visibility > Lock). 

 2 Use the Box command to create a new box right on top of the box used for mold 
part 1 (Solid menu: Box > Corner to Corner, Height). 

   
The second mold part. 
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 3 Use the Sphere command to draw four small spheres with a radius of 1.95 that 
will form the other half of the registration keys (Sphere menu: Center, Radius). 

  Use grid snap to center the spheres inside the notches you created in part 1. These 
new spheres will be slightly smaller than the ones used for the notches. This is to 
ensure some tolerance when the two pieces will be coupled. You can reasonably 
use a parting tolerance value of 0.05 mm; therefore, use a radius of 1.95. 

   
Draw the spheres for the registration keys. 

 4 Unlock mold part 1 and Hide it. 

Create the second part 
The second part of the mold is similar to the first; however, the model parts protrude from 
the box solid instead of being cut into it. 

To cut and join the mold parts 

 1 Make the hollowing surface visible. 

 2 Use the BooleanUnion command to join the spheres to the box to create the 
registration keys for this half of the mold (Solid menu: Union). 

 3 Use the BooleanUnion command to join the hollowing solid to the box. 

  If the Boolean fails, try moving the solid surface very slightly up toward the box. 

   



Rhinoceros   Modeling and Mold Making for Jewelry Designers 

Copyright © 2003 Robert McNeel & Associates. All rights reserved. 37 

 4 To create a gate in this part, use BooleanDifference command to subtract the 
gate solid you created earlier (Solid menu: Difference). 

   

  The model of the two-part mold looks complete at this point. Spend a few moments 
checking what you have just built. 

  The GhostedViewport mode has given an almost transparent appearance to the 
mold so you can see how things are looking where the wax will be poured. 

 

For illustration purposes only, the two parts of the mold are now placed side by side 
and opened up. 

 

Analyze the model 
Rhino lets you analyze a surface in several ways. You will first analyze the model to 
determine if there are unjoined edges. Most machining programs require that the model 
be a closed solid with no unjoined edges. 
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To check for unjoined edges 

  Use the ShowEdges command to check for unjoined edges (Analyze menu: Edge 
Tools > Show Edges).  

  Make sure your part is a closed polysurface (no naked edges).  

   
Mold top half with edge analysis. 

You should also examine the model for minimum radius of the curved surfaces. This will 
tell us what can be machined by tools of various radii. 

To analyze the surface for minimum radius 

 1 Select mold part 1. 

 2 Use the CurvatureAnalysis command to check the surface (Analyze menu: 
Surface > Curvature Analysis). 

Use the Min radius option. 

 3 Set the red upper limit to .4. 

 4 Set the blue lower limit to .5. 
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Curvature analysis with isocurves on (left) and off (right). The red areas are easier 
to see with the isocurves turned off. 

  The red areas of this piece have a radius smaller than the upper Min radius value. 
This means that a tool with a radius of 0.4 mm will leave a fraction of material 
uncut. 

  The curvature analysis is a representation of the tooling that will be used in the 
machining phase. In most extremely small radius situations, you will have to 
compromise between the uncut material and the reasonable size of the tool. As you 
will see in the VisualMill part of this tutorial, the smallest tool used is a 1-mm 
cutter. 

 5 Do the same analysis on mold part 2. 

 

At this point you have completed the modeling and analysis. 
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Using VisualMill 
The next step of the project will be to import the mold parts into VisualMill, and to develop 
a cutting strategy. Models are saved to use for this purpose, so you do not have to 
complete the model. 

VisualMill will read both Rhino NURBS model files and Rhino mesh files. Normally, you can 
simply read in the Rhino model into VisualMill, but sometimes it works best to create the 
mesh in Rhino. In either case, export only the mold parts or a mesh created from the mold 
parts to a separate model. 

The machining process 
Numerically controlled (NC) machines, use a variety of cutting tools similar to drills or 
router bits to cut a piece of stock material to a shape. Milling programs such as VisualMill 
generate a list of instructions (G-Code) for the milling machine from a 3-D model. The G-
Code instructions for the machine list which cutters (tools) to use, in what order, and 
where to cut (tool path). G-Code files are typically loaded by the NC controller and then 
“played” in order to move the cutter over the stock. 

In the first stages of machining, called roughing, the object is to quickly remove the bulk 
of the waste material. This leaves stair-stepped shapes in the material.  

In the final stages, called finishing, smaller, more refined tools are used to form the final 
profile, removing the stair-steps left behind in the roughing procedures.  

After final machining stage the piece normally still needs hand polishing and finishing work 
before the article is complete. 

Open the model 
There are several ways to import geometry produced in Rhino into VisualMill 4.0. You can 
export your model as an STL, VRML, or RAW mesh file, or you can export it as an IGES or 
Parasolid file. VisualMill can also open Rhino files directly and use either the surface data 
or mesh data in the Rhino file.  

The RhinoCAM plug-in for Rhino V3 is another option. If you have VisualMill 4 installed, 
with RhinoCAM you can be in a Rhino session and open the entire Rhino file or just 
selected objects in VisualMill. RhinoCAM eliminates the need to save your Rhino data to an 
intermediate file format before opening it in VisualMill. 

In the first half of this tutorial, you will open the Rhino file that contains the top half of the 
ring mold you created in the first part. You will be guided through all of the steps required 
to generate the machine G-Code required to actually cut the part.  

Each new operation will be shown in detail. If an operation is repeated in the tutorial, less 
detail will be provided, since you will have seen it before. For specific information on 
VisualMill options, see the VisualMill Help file. 

The second half of the tutorial will cover the bottom half of the ring mold. 

Warning: Operation of machine tools is a dangerous business. Cutters and material can 
break and fly around at high speed causing serious injury. Before actually 
milling a part with the G-Code generated in this tutorial, you should be well 
versed with all of the safety procedures required for safe operation of your 
equipment. 
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To export the part to VisualMill with the RhinoCAM plugin 

 1 Select the top half of the mold.  

 2 In Rhino, select the mold top half and from the RhinoCAM menu, select Export 
Selected to VisualMill (RhinoCAM menu: Export Selected to VisualMill).  

   

  VisualMill automatically preserves the location, orientation, and units from the 
Rhino file. 

   
Mold top half in VisualMill. 

Orientation the part 
Once the geometry has been successfully imported into VisualMill, you will orient the 
model for machining and set the machine zero position. The machine zero position is the 
reference point for all the machining operations (MOPs) and represents the initial physical 
position where the tip of the cutter will be positioned. For example, if the zero position will 
be the center-top based on the part’s bounding box, you will move the cutter tip to the 
upper center point of the stock material when it is loaded in the milling machine. 

The part is in the same orientation (upside-down) that it was in Rhino. It will need to be 
flipped so it can be cut. 

To set the part orientation 

 1 In the Machining toolbar, click the Set Cutting Direction button. 

Button Function 

 
Set Cutting 
Direction  

 2 In the Set Cutting Direction dialog box, change the direction to the bottom as 
shown in the image below.  
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  This will flip the part so the detail is positioned under the cutting tool. The cutter on 
a 3-axis mill cuts from the top of the part. 

   
Set cutting direction. 

To set the zero position 

 1 In the Machining toolbar, click the Set Machine Zero button. 

Button Function 

 Set Machine Zero 

 2 In the Set Machine Zero dialog box, set the machine zero position to the top 
center of the part box as shown in the image below. 
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Set machine zero. 

  The image below shows the part flipped and the machine zero position set. 

   
Part setup complete. 

Create a stock box 
The next step is to create a stock box. The stock box represents the ideal raw stock that 
will be loaded into the mill. Assume the highest point (z) on the part will be even with the 
stock. Leave a little offset space around the sides in the x- and y-directions to allow for 
easier loading of the stock into the mill. After you create the stock, hide it. 
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To create a stock box 

 1 From the Machining bar, click Create/Load Stock and from the menu, select 
Part Box Stock (Stock menu: Part Box Stock). 

Button Function 

 Create/Load Stock  

 2 In the Part Bounding Box Stock dialog box, set the X Offset and Y Offset values 
to 1 as shown in the image below. 

   
Part box stock. 

To locate the part within the stock 

 1 From the Machining bar, click Locate Part Within Stock. 

Button Function 

 Locate Part Within Stock  

 2 In the Locate Part Within Stock dialog box, set the Object to Move to Move 
Stock and the Z Alignment and XY Alignment to Center as shown in the 
image below. 

   
Move the part to the center of the stock. 
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To hide the stock 

  From the View toolbar, click the Hide Stock button (View menu: Hide Stock). 

Button Function 

 Hide Stock 

Create cutting tools 
You are now ready to create a set of virtual cutting tools that will be used to machine the 
mold half. Normally, you will have created a library of cutting tools that you maintain for 
your mill. No library has been created for this tutorial, so you will create the tools you 
need. The virtual cutting tools you create in your milling program must match the actual 
cutting tools that are used in your milling machine. There are many different mill 
manufacturers and cutting tool makers. Each cutting tool has its own dimensions (tool 
length, flute length, diameter). Each tool you create for your VisualMill library must match 
an actual tool you have for your milling machine. 

To create a cutting tool 

 1 From the Machining toolbar, click the Create/Select Tool button (Tool menu: 
Create/Select Tool). 

Button Function 

 Create/Select Tool  

 2 Using the Select/Create Tools dialog box, Ball End Mill and Flat End Mill pages, 
create three cutting tools with parameters as shown in the table below.  

  Label the tools descriptively so you can easily tell them apart. 

Name Tool Length Flute Length Diameter 

Ball 1 mm 90 10 1 

Ball 2 mm 90 10 2 

Flat 4 mm 90 60 4 
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Select create tool. 

Check speeds and feeds 
Typically, at this point, spindle speeds, and tool feed rates are established. These settings 
depend on the size of the cutting tool, the cutting tool composition, the stock being cut, 
the make, model, and condition of the milling machine, and the experience of the 
machinist. 

To check the feeds and speeds 

 1 Click the Set Feeds/Speeds button (Feeds/Speeds menu: Set Feeds/Speeds). 

Button Function 

 Set Feeds/Speeds  
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 2 Look at the current settings. 

   
Set Feeds/Speeds dialog box. 

  If the cutting tool you are going to use were very small or the cuts were deep, it 
would be necessary to slow the cutting speed and rate of movement of the stock 
part through the machine. You do not need to change these settings for this 
particular operation, but it is a good idea to be aware of this issue at all times.  

Note: A meaningful discussion of the topic of machine speed is beyond the scope of this 
tutorial. Consult the proper references for information on this subject. The 
information that comes with your milling machine will have some information on 
this subject. In addition, an industry standard work on the subject is Machinery's 
Handbook, by Erik Oberg, Franklin Day Jones, Henry H. Ryffel; Industrial Press; 
ISBN: 0831126256. 

Define a machine operation 
The first cutting strategy you will use is horizontal roughing. This operation uses a 
relatively large tool and is used for the majority of the stock removal. The horizontal 
roughing operation removes material in levels. The tool starts at the top of the stock and 
removes material moving only in the xy-plane. Once this level is completed, the tool 
moves to the next lower level and removes material in this xy-plane. With each successive 
operation you get closer to the finished part. 

The ability to determine which cut strategy works best for each situation comes from 
experience and training as a machinist.  

To define a horizontal roughing operation 

 1 To set the active tool, in the Select/Create Tools dialog box, select the Flat 4 
mm tool (Tool menu: Create/Select Tool).  

Button Function 

 Create/Select Tool  
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  Check the status bar to verify that this tool is active. 

   
Flat 4-mm tool. 

 2 From the Machining toolbar, click the 3-Axis Machining button, and then from 
the menu, select Horizontal Roughing (3 Axis Milling menu: Horizontal 
Roughing). 

Button Function 

 3-Axis Machining 

 3 In the Horizontal Roughing dialog box, on the Cut Parameters page, set the 
values as shown below. 

   
Set horizontal roughing parameters. 
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 4 In the Horizontal Roughing dialog box, on the Cut Levels page, set the values 
set the parameters as follows: 

  Stepdown Control Distance: 0.5 
Cut Levels Ordering: Level First 
Cut Levels Bottom: -8.5 

   
Horizontal roughing parameters. 

To generate the milling operation tool paths 

 1 In the Horizontal Roughing dialog box, click the Generate button to create the 
milling operation (MOP) tool paths. 

   
Horizontal roughing tool paths 

 2 Using the View toolbar, hide the part model, the grid, and the tool path, and show 
the stock.  
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 3 On the VCR toolbar, click the Simulate button.  

Button Function 

 Simulate 

  This will process the tool paths and display what your stock will look like after the 
initial roughing process. 

   
Horizontal roughing simulation. 

 4 In the browser pane, click the Mops page.  

 5 Double-click an option that defines the roughing operation to change its 
parameters.  

  You can also rename the operation to make it more descriptive. If you make a 
change, a red star appears on the Stock option in the browser to indicate the 
display is not current with the MOP definition.  

 6 In the VCR toolbar, click the Simulate button update the display. 

Remove material from flat areas 
You will use plateau machining to remove the remaining stock from the flat areas. In 
plateau machining the cutter is restricted to machine areas in the part that are shallower 
than a specified angle from the horizontal plane. Plateau machining is used to finish areas 
that were not machined completely by a roughing operation. 

To define a plateau machining operation 

 1 Be sure the Flat 4 mm tool is active. 

 2 From the 3-Axis Machining menu, select Plateau Machining (3 Axis Milling 
menu: Plateau Machining).  

Button Function 

 3-Axis Machining 
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 3 Set the parameters as shown below. 

   
Plateau machining parameters. 

  The Region Control Angle is defined in degrees from the horizontal. Any area 
within the flatness region will be machined. A value of 2 degrees will ensure that all 
of the flat parts will be cut down to a maximum of a 2-degree angle.  

 4 Click Generate to create the milling operation. 

 5 On the VCR toolbar, click Simulate to update the stock model display.  

Button Function 

 Simulate 
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Use analysis tools 
At this time, run the comparison of the part to the stock. This will show you the 
differences between the modeled part and the stock material remaining. 

To compare the stock to the part 

 1 In the VCR toolbar, click the Part/Stock comparison button. 

   
Part Stock comparison. 

 2 In the Part/Stock Comparison dialog box, set the Tolerance Band value to 0.3, 
and click the Apply button. 

   
Part/Stock comparison dialog. 

  In the roughing machine operation, a stock thickness of 0.3 mm was left. In the 
plateau machining operation, the additional stock thickness was eliminated so the 
flat areas of the mold were cut to final elevation. Setting the Tolerance Band to 
0.3 will accurately show the areas of the stock model that still have excess material 
to be machined away. The green areas indicate good finished surfaces. The dark 
blue areas indicate where more material still needs to be removed. The remaining 
machining operations you create will remove the remaining excess material. 

Note: VisualMill 4 has two different simulation methods for modeling the Part/Stock 
comparison display: 3 and 4-Axis simulation model. Depending on the geometry of 
your model, one method may create a more accurate display than the other. The 
trade-off is speed. The 3-axis method is faster while the 4-axis method is more 
accurate. For the images in this demonstration, the 4-axis method is used. The 
setting can be changed from the Preferences menu, Machining Preferences. 
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Part/Stock comparison. 

Remove stepover notches 
In the top view shown below, you can see excess stock around the four registration keys. 
This is left over from the relatively coarse step-over value used in the plateau machining 
operation. You will use a horizontal finishing strategy to remove this excess stock. 

 
Top view showing extra material at registration keys. 

To define a horizontal finishing operation 

 1 With the 4-mm flat-end mill active, from the 3-Axis Milling menu, select 
Horizontal Finishing (3 Axis Milling menu: Horizontal Finishing).  

Button Function 

 3-Axis Machining 

 2 On the Cut Levels page, under Cut Levels, set the top value to –4.5 and the 
bottom value to -5.12.  

  This will limit the machining to a horizontal finishing pass in a single level and 
single path. The distance from the top of the part to the flat surface is 5.131. There 
is no need to use a cut level any higher than –4.5 since the tool will cut nothing at 
that level. Try setting a higher level and generate the tool paths. You will observe 
that additional tool paths are created, but there is no material left to cut at that 
level.  

  The Stepdown Control moves the tool down 1 mm (25% of the tool diameter) with 
each pass. Experiment with the control to get as close as possible to -5.131. 
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 3 Click the Generate button the machine operation  

 4 On the VCR toolbar, click Simulate to update the display 

Button Function 

 Simulate 

 5 Turn on the tool paths to verify the route the tool will take. 

  If there is more than one tool path around the areas to be cut, the Top level is too 
high. If there is only one tool path around the whole piece, the Bottom level is too 
low. 

   
Horizontal finishing tool path. 

Define regions 
Now that the final machining for the flat areas is substantially completed, you are down to 
finish strategies for the four registration keys, ring-hollowing plug, and gate. It would be a 
waste of time to let the cutter go over the flat regions of the stock since they are 
complete. Restricting tool paths to regions is more efficient. First, create the six regions. 
Then make them active and generate tool paths within the active regions. 
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To set up the display 

 1 Set your display to the top view with the part model displayed.  

 2 Hide the stock and tool paths.  

 3 Set the display for the grid at your choice.  

 4 Make sure you do not have Hide Machining Regions turned on.  

  You will want to see your regions as you create them.  

  Your display should look something like this: 

   
Top view. 

To create machining regions 

 1 From the View menu and select Toolbars (View menu: Toolbars > Curves/Regions 
Bar).   

 2 Turn on the Curves/Regions toolbar.  

 3 Use the rectangle, circle, and polygon/polylines tools to create regions around the 
six regions that define the four registration keys, the gate, and the ring. 

  The region creation has a few basic pointing tools to assist you in creating the 
regions including object snap and grid snap. 

  It is not critical to precisely match the region boundaries to the part features. The 
regions should just completely surround the features with a minimum of extra 
space. These regions are only used to minimize unnecessary tool paths in areas 
that do not need to be machined. 

  After creating the six regions, your display should look something like this: 

   
Machining regions. 
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To activate the regions 

 1 In the Machining toolbar, from the Select Regions button menu, select the 
Single tool. 

   
Select regions. 

 2 Select the four regions that surround the four spherical registration keys.  

  They will turn yellow to indicate they have been selected.  

  Pres and hold the Ctrl key to add all four regions. 

   
Active regions highlight yellow. 

Finish the registration keys 
You will now use a ball-end tool and parallel finishing to finish the registration keys. 

To finish the registration keys 

 1 From Create/Select Tool button menu, select the 2 mm ball end mill (Tool 
menu: Create/Select Tool).  

Button Function 

 Create/Select Tool 

 2 Check the status line to verify this is the active tool. 
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 3 From the 3-Axis Milling menu, select Parallel Finishing (3 Axis Milling menu: 
Parallel Finishing).  

Button Function 

 3-Axis Machining 

 4 Set the parameters as shown below: 

   
Parallel finishing settings. 

 5 Click Generate to create the tool paths.  

 6 Show tool paths to see them.  

  They will only be created within the four active regions. 

   
Detail of parallel finishing on a registration key. 
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 7 Turn off the part model, turn on the stock, hide the tool paths, and run Simulate 
to see the results of the machining operation. 

   
Result of parallel finishing for the registration keys. 

Final finishing 
Use the same process and settings to create two more parallel finishing machine 
operations for the ring and gate regions using the 2 mm ball end mill. 

An additional option to consider when creating the machining operation for the gate is to 
rotate the angle of the tool paths. The default Angle of Cuts is zero (0). This orients the 
tool paths across the gate. Changing the Angle of Cuts to 90 degrees will align them 
with the gate. 

If you forget to activate the proper regions or tool before you generate the tool paths, you 
can select them later. Just right-mouse click on the appropriate parameter within the 
machining operation definition, make the correct selection, regenerate the tool paths, and 
run simulate to update the stock model. 

After these two parallel finishing machining operations, your stock model should look like 
this: 

 
Final parallel finishing. 

Finish the gate 
The only area where there is still an excess of stock is in the gate itself. This is because it 
transitions from a circular cross-section to a rectangular shape. The 2-mm ball end mill 
has left a some uncut stock. You will use a smaller tool and a new machining strategy to 
remove more of this excess material and complete the gate. 
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To finish the gate 

 1 Make the 1 mm ball end mill tool current and make the gate-machining region 
active (Tool menu: Create/Select Tool). 

Button Function 

 Create/Select Tool 

 2 From the 3-Axis Milling menu, select the Valley Re-Machining strategy (3 Axis 
Milling menu: Valley Re-Machining).  

Button Function 

 3-Axis Machining 

  Set the parameters as follows: 

   
Valley Re-machining settings. 

 3 Generate the tool paths and run Simulate to update the stock model. This half of 
the ring mold is now completed. 

   
Valley re-machining results. 



Rhinoceros   Modeling and Mold Making for Jewelry Designers 

Copyright © 2003 Robert McNeel & Associates. All rights reserved. 60 

Compare the part and stock 
Use the Part/Stock Comparison tool to see if the machine operations you created 
removed all of the excess material. The only excess material appears to be on the 
backside of the ring. This apparent excess is because the surface was modeled slightly 
undercut. Since a 3-axis machine cannot cut undercuts, this excess material can be 
ignored in this case. This situation is normal and does not adversely affect the purpose of 
this modeled feature. It is very rare when all of the excess material can be removed by 
machining due to the physical size limitations of the tools used and the modeling 
techniques employed in the original idealized model. 

 
Part to Stock comparison. 

Generate tool paths 
The last step is to post process your tool paths to produce G-Code for your particular NC 
controller. This post-processes the tool paths, tool changes, speeds and feeds, into the 
particular “flavor” of G-Code the NC controller on your mill requires.  

To produce machine G-Code 

 1 From the Post Process menu, select Post Process (Post Process menu: Post 
Process). 

Button Function 

 Post Process 

 2 Select the appropriate post processor for your controller, specify a file name and 
location for your file, and click OK.  

  Note: This feature is disabled in the demo version of VisualMill. 

  If your controller is not listed, contact technical support at MecSoft 
(support@mecsoft.com) for help is selecting or creating a post processor. 

mailto:support@mecsoft.com
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Select the appropriate post-processor. 

  VisualMill will process the information and create the specified file. When this is 
complete, the output file will be displayed in the Windows Notepad editor where it 
can be reviewed and modified (if needed) by an experienced CNC code writer. It is 
common to add descriptions and tool requirements to the file for archiving 
purposes. 

  It is beyond the scope of this tutorial to enter into a discussion of G-Code editing. 

   
Final G-Code. 
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Set up the second part 
The second part of the tutorial uses many of the same machining strategies as the first 
part. A few new strategies will be introduced and a new tool will be needed to efficiently 
machine this part. 

To export the second part to VisualMill 

  Select the lower half of the mold model in Rhino, and from the RhinoCAM menu, 
select Export Selected to VisualMill.  

Note: If VisualMill is not currently running, it will be launched and the geometry will be 
exported to VisualMill. If an instance of VisualMill is already running, the geometry 
in the current VisualMill session is overwritten with the geometry sent from Rhino. 
The machining operations are not overwritten. They can be used with the newly 
exported geometry if they are appropriate. In this case they are not. 

   
The second mold part in VisualMill. 

To set machine zero position 

  Use the Set Machine Zero tool to set the following: 

Locate Zero Set to Part Box 

Zero Face Highest Z 

Zero Position Center 

To create stock box definition 

  Use the Create/Load Stock tool to define a Part Box Stock model with the 
following settings (Stock menu: Part Box Stock): 

Offset Value 

Z Offset 0 

X Offset 1 

Y Offset 1 
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Stock box and part. 

To locate the part within the stock 

  Use the Locate Part Within Stock tool to set the location of the stock as follows: 

Action Setting 

Object to Move Move Stock 

Z Alignment Center 

XY Alignment Center 

Create cutting tools 
You will need three ball end cutting tools to machine this part. Create them with the 
following settings (Tool menu: Create/Select Tool): 

Name Tool Length Flute Length Diameter 

Ball 1 mm 90 10 1 

Ball 2 mm 90 10 2 

Ball 3 mm 90 10 3 

Create a machine operation 
The first milling operation for the second part is a horizontal roughing operation. This MOP 
will remove most of the excess material.  

To define the horizontal roughing operation 

 1 Make the 3 mm ball end mill the current tool (Tool menu: Create/Select Tool).  

  Verify the current tool in the status bar. 

 2 From the 3-Axis Milling menu, select Horizontal Roughing (3 Axis Milling menu: 
Horizontal Roughing). 
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 3 Set the cut parameters as follows: 

Name Value 

Global Parameters Intol: 0.03 

 Outol: 0.03 

 Stock: 0.3 

Cut Pattern Stock offset 

Cut Direction Climb 

Offset: Pocket Start Point Inside 

Stepover Control 25% of tool diameter 

 4 Set the cut levels as follows: 

Name Value 

Stepdown Control Distance: 0.5 

Cut Levels Ordering: Level first 

Cut Levels Bottom: –6.5 

 5 Generate the operation, hide the part, hide the tool paths, and Simulate the 
operation to update the stock model. 

   
Horizontal roughing. 

To check for excess stock 

  Use the Compare Part/Stock tool to see where the excess stock material is.  

  Use a Tolerance Band setting of 0.3, the amount of excess stock left over after 
the roughing MOP. The green areas are finished while the dark blue areas indicate 
excess material thicker than 0.3 mm when compared to the ideal stock model. 
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Part to stock comparison. 

Define regions 
Define machining regions to isolate the pockets of excess material for efficient removal in 
subsequent machining operations.  

To define and set machining regions 

 1 Using the Curves/Regions toolbar, create the regions around the registration 
keys, ring area and gate area as shown below (View menu: Toolbars > 
Curves/Regions Bar).  

  Use the top view using the part model as a reference. 

   
Create regions. 

Define parallel finishing 
The next step is to set the active machining regions and current cutting tool, and then 
define a parallel finishing operation for the four spherical registration keys. 

To define parallel finishing operations 

 1 Use the Select Regions tool to activate the regions around the registration keys as 
shown below. 

Button Function 

 Select Regions 

  The first parallel finishing operation will use these regions. 
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Select regions. 

 2 Use Create/Select Tool to make the 2-mm ball end tool current (Tool menu: 
Create/Select Tool). 

Button Function 

 Create/Select Tool 

  Verify the selection in the status bar. 

 3 From the 3 Axis Machining menu, select Parallel Finishing (3 Axis Milling menu: 
Parallel Finishing). 

Button Function 

 3-Axis Machining 

  Use the following parameters. 

Name Value 

Global Parameters Intol: 0.03 

 Outol: 0.03 

 Stock: 0 

Cut Direction Mixed 

Start Side Bottom 

Angle of Cuts 0 

Stepover Control Distance: 0.1 
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 4 Generate and Simulate the MOP to update the stock model. 

   
Parallel finishing for the registration key cavities. 

To machine the ring and gate cavities 

  Create another parallel finishing milling operation that uses the regions that 
surround the ring and gate cavities.  

  Use the 2-mm ball end tool and the same parameters and as the previous parallel 
finishing MOP. 

   
Parallel finishing of the ring and gate cavities. 

Define pencil tracing 
A new milling strategy called pencil trace machining can be used either as a pre-finishing 
or a re-finishing operation. Pencil trace operations typically use a ball end cutter restricted 
to follow a path where two or more contact points are maintained with the part. This path 
typically follows the valleys and the corners of the part. Pencil trace can clean up the 
scallops left after a parallel finishing operation, or it can be used to remove excess 
material from valleys and corners. 

Warning: For any cutting strategy you use, consider the shape and material you are 
working on. If the tool is forced to take deep cuts and work with a very large 
amount of material on its blades, it creates a very dangerous situation. Tools 
and stock can shatter, sending sharp metal projectiles in all directions. Never 
overload a tool. It is much safer to take several shallow cuts than a few overly 
deep ones. 
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A pencil trace operation with a stock value of zero will generate a tool path that drives the 
cutter along the valleys and corners of the part model, thereby eliminating all the excess 
stock where the ball end mill has a double tangency condition. Double tangency is where 
the side and the point of the tool are cutting at the same time. 

To define a pencil trace operation 

 1 Use the same 2-mm ball end tool for the pencil trace operation (Tool menu: 
Create/Select Tool).  

 2 From the 3-Axis Machining tool, select Pencil Tracing (3 Axis Milling menu: 
Pencil Tracing).  

  You will use it as a pre-finishing operation. Set the parameters as shown below, 
then generate the MOP. 

   
Pencil trace settings. 

Set speeds and feeds 
Before you update the stock model by simulating the MOP, change the speeds and feeds. 
This is not intended as a discussion on specific settings. In light of the hazards associated 
with the increased tool load from the dual contact point strategy used in pencil tracing, it 
is probably a good idea to reduce the feed rate. 

To set the feed rate 

  In the Set Feeds/Speeds dialog box, reduce the feed rates to the settings shown 
below, Generate the tool paths, and Simulate to update the stock model 
(Feeds/Speeds menu: Set Feeds/Speeds). 

Button Function 

 Set Feeds/Speeds  
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Speeds and feeds settings. 

   
Results of the pencil trace operation. 

Final finishing 
The final parallel finishing operations use the smallest cutter with a very small stepover. 
These operations will be confined to the ring cavity and gate regions. The only difference 
will be the Angle of Cuts setting. The two MOPS will be generated with the tool paths set 
90 degrees to each other. 

To define the final parallel finishing operations 

 1 Set Ball 1 mm as the active tool (Tool menu: Create/Select Tool). 

 2 From the 3-Axis Milling menu, select Parallel Finishing (3 Axis Milling menu: 
Parallel Finishing).  
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  Use the following settings to generate the two MOPs. 

Name Value 

Global Parameters Intol: 0.03 

 Outol: 0.03 

 Stock: 0 

Cut Direction Mixed 

Start Side Bottom 

Angle of Cuts 0 

Stepover Control Distance: 0.1 

 

Name Value 

Global Parameters Intol: 0.03 

 Outol: 0.03 

 Stock: 0 

Cut Direction Mixed 

Start Side Bottom 

Angle of Cuts 90 

Stepover Control Distance: 0.1 

 3 Generate the tool paths and Simulate the stock removal to update the stock 
model. 

   
Final finishing results. 
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 4 Check the part with the Part/Stock Comparison to see how well they match.  

  This looks like a good job, and will require very little, if any, hand finishing. 

   
Part stock final comparison. 

Generate the tool paths 
Use the Post Process tool to generate the G-Code instructions for your mill and save the 
file (Post Process menu: Post Process). (Note: This feature is disabled in the demo version 
of VisualMill.) 

Button Function 

 Post Process 

Congratulations! 
You now have completed everything required to machine both halves of the ring mold. 
Hook up your machine and go! 
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