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elcome to SolidWorks 2010 Bible. This book has been written as a desk reference for
Wbeginning and intermediate SolidWorks users. SolidWorks is such an immense soft-

ware program that trying to cover all its functions is an extremely ambitious undertak-
ing, which has resulted me leaving a few out. Because of the scope of the topic, I have limited the

book to covering the basic SolidWorks package with Office, Office professional, or Office Premium
add-ins, although I have devoted half of a chapter to toolbox.

About This Book

You will find enough information here that the book can grow with your SolidWorks needs. I have
written tutorials for most of the chapters with newer users in mind, because for them, it is most
helpful to see how things are done in SolidWorks step by step. The longer narrative examples give
more in-depth information about features and functions, as well as the results of various settings
and options.

This book includes many details that come from practical usage, and is focused on the needs of
professional users, not on student learners. My approach is to teach concepts rather than button
pushes.

How This Book Is Organized

This book is divided into eight parts.

Part I: SolidWorks Basics

This part explores basic concepts and terminology used in SolidWorks. You need to read this
section if you are new to the software and especially if you are new to 3D modeling or parametric
history-based design.
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Part I1: Building Intelligence into Your Parts

This part takes a deeper look at creating parametric relations to automate changes.

Part 1ll: Working with Assemblies

Part III delves into assembly modeling in it various aspects, from efficiency to in-context modeling.

Part IV: Creating and Using Libraries

Part IV helps you understand how to build and manage libraries of various types with an eye
toward upgrading versions, best practice, and reusing data when possible.

Part V: Creating Drawings

This part examines the functionality within the 2D drawing side of the software. Whether you are
creating views, making tables, or customizing annotations, these chapters have something for
everyone.

Part VI: Using Advanced Techniques

This part examines several types of advanced techniques, such as surface modeling and multi-body
modeling. This is information you won't find in other SolidWorks books, explained here by some-
one who uses the functionality daily.

Part VII: Working with Specialized Functionality

Specialized functionality such as sheet metal, weldments, plastics, and animation requires detailed
information. Part VII includes these topics because they are key to unlocking all the power avail-
able in SolidWorks.

Part VIII: Appendixes

The appendixes in this book contain information that was not appropriate in the main body of the
text, such as the contents of the CD-ROM and other sources of help.

Icons Used in This Book

This book uses a set of icons to point out certain details in the text. While they are relatively self-
explanatory, here is what each of these icons indicates:

Caution

Caution icons warn you of potential problems before you make a mistake.

x|
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Cross-Reference
Cross-Reference icons point out where you can find additional information about a topic elsewhere
in the book.

New Feature

The New Feature icon highlights features and functions that are new to SolidWorks 2009.

Note

Notes highlight useful information that you should take into consideration, or an important point that
requires special attention.

On the CD-ROM

This icon points you toward related material on the book’s CD.

Tip
Tips provide you with additional advice that makes the software quicker or easier to use.

The SolidWorks 2010 Bible is unique in its use of these two icons:

Best Practice
Best practice icons point out recommended settings or techniques that are safe in most situations.

Performance

Performance icons elaborate on how certain settings, features, or techniques affect rebuild speed or file size.

These icons point out and describe techniques and settings that are either recommended or not
recommended for specific reasons. Best Practice is usually considered to be very conservative
usage, where the stability of the parametrics and performance (a euphemism for rebuild speed) are
the ultimate goals. These two aspects of SolidWorks models are usually weighed against modeling
speed (how long it takes you to create the model).

You should take Best Practice and Performance recommendations seriously, but you should treat
them as guidelines rather than as rules. When it comes right down to it, the only hard and fast rule
about SolidWorks is that there are no hard and fast rules. In fact, I believe that the only reason to
have rules in the first place is so that you know when you can break them. Parametric stability and
modeling speed are not always the ultimate goals, and are often overridden when work-around
techniques are used simply to accomplish a geometric goal.

Because not everyone models with the same goals in mind, a single set of rules can never apply for
everyone. You must take the best practice suggestions and apply them to your situation using your
own judgment.
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My point of view while writing this book has been that of someone who is actually using the soft-
ware, not of someone trying to sell ideas, nor of someone trying to make the software look good,
or even that of an academic trying to make a beautiful argument. I try to approach the software
objectively as a tool, recognizing that complex tools are good at some things and not so good at
others. Both kinds of information (good and not-so-good) are useful to the reader. Pointing out
negatives in this context should not be construed as criticizing the SolidWorks software, but rather
as preparing the reader for real-world use of the software. Any tool this complex is going to have
imperfections. Hopefully some of my enthusiasm for the software also shows through and is to
some extent contagious.

Terminology

An important concept referred to frequently in SolidWorks is design intent. As a practical matter,
I use the phrase design for change to further distinguish design intent from other design goals.

The reader needs to be familiar with some special terminology before continuing. In many cases,

1 use a SolidWorks vernacular or slang when the official terminology is either not descriptive
enough or, as is sometimes the case, has multiple meanings. For example, the word shortcut has
multiple meanings in the SolidWorks interface. It is used to describe right mouse button menus as
well as hotkeys. As a result, I have chosen not to use the word shortcut and instead substitute the
words RMB and hotkey.

I frequently use RMB to refer to right mouse button menus, or other data that you access by click-
ing the right mouse button on an item. The word tree refers to the list of features in the
FeatureManager.

Differences are frequently found between the names of features on toolbars and the names in the
tooltips, menus or PropertyManager titles. In these cases, the differences are usually minor, and
either name may be used.

Most functions in SolidWorks can work with either the object-action or the action-object scenar-
ios. These are also called pre-select and select, respectively. The Fillet feature shows no difference
between using pre-selection and selection, although for some fillet options such as face fillet, pre-
select is not enabled. Most features allow pre-selection, and some functions, such as inserting a
design table, require pre-selection. Although you cannot identify a single rule that covers all situa-
tions, most functions accept both.

Frequently in this book, [ have suggested enhancement requests that the reader may want to make.
This is because SolidWorks development is driven to a large extent by customer requests, and if a
large number of users converge on a few issues, then those issues are more likely to be fixed or
changed. Again, the enhancement request suggestions are not made to criticize the software, but to
make it better. [ hope that several of you will join me in submitting enhancement requests.
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SolidWorks is an extremely powerful modeling tool, very likely with the best combination of
power and accessibility on the MCAD market today. This book is meant to help you take advan-
tage of its power in your work and even hobbyist applications. If I could impart only a single
thought to all readers of this book, it would be that with a little curiosity and some imagination,
you can begin to access the power of SolidWorks for geometry creation and virtual product proto-
typing. You should start with the assumption that there is a way to do what you are imagining, and
that you should be open to using different techniques.

Whoever you are, I hope that you find insight deeper than simply “what does this button do?” in
this book. I hope that you will find an intuition for thinking like the software. Jeff Ray, CEO of the
SolidWorks Corporation, has said that the goal is to make the software as “intuitive as a light
switch.” While most people will agree that they have some work left to achieve that particular goal,
I believe that approaching the interface intuitively, rather than attempting to remember it all by
rote, is the best method. Good luck to you all.

Contacting the Author

You might want to contact me for some reason. Maybe you found an error in the book, or you
have a suggestion about something that you think would improve it. It is always good to hear what
real users think about the material, whether you like it or think it could be improved.

The best way to contact me is either through e-mail or through my blog. My e-mail address is
matt@dezignstuff.com. You will find my blog at http://dezignstuff.com/blog.
On the blog you can leave comments and read other things I have written about the SolidWorks
software, CAD, and engineering or computer topics in general. If you want to contact me for
commercial help with a modeling project, the previous e-mail address is the best place to start
that type of conversation.

Thank you very much for buying and reading this book. I hope the ideas and information within
its pages help you accomplish your professional goals.
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are essential. I recommend reading these chapters in
order because the material in each chapter builds on
the material of the previous chapter.

If you are a new SolidWorks user, the chapters of Part I

If you are an existing SolidWorks user, I strongly recom-
mend Chapters 2 and 5 because the interface has changed
significantly since 2007. Even if you are a very experienced
user, I recommend Chapter 5. The visualization techniques
are things we all use on a constant basis in the software,
and picking up even a small tip can add to your productiv-
ity dramatically.

IN THIS PART

Chapter 1
Introducing SolidWorks

Chapter 2
Navigating the SolidWorks
Interface

Chapter 3
Working with Sketches

Chapter 4
Creating Simple Parts,
Assemblies, and Drawings

Chapter 5
Using Visualization Techniques







Introducing
SolidWorks

3D CAD program. That seems like many words, but they all have a

specific meaning. In SolidWorks, you build 3D parts from a series of
simple 2D sketches and features such as extrude, revolve, fillets, and holes,
among others. You can then create 2D drawings from the 3D parts and
assemblies.

S olidWorks is a feature-based, history-based, associative, parametric

This chapter will familiarize you with some of the tools available to make the
transition to SolidWorks, and with some of the basic facts and concepts that
you need to know to get the most out of the software.

If you want to start using the software without learning about how or why it
works, you can skip directly to Chapter 4 for sketches or Chapter 5 to start
making parts, assemblies, and drawings. Of course, I recommend you get a
bit of background and some foundation first.

Installing SolidWorks
for the First Time

I'm assuming you are installing SolidWorks for the first time on your com-
puter. Detailed instructions for more involved types of installation and unin-
stallation are beyond the scope of this book.

Some of you will have SolidWorks installed for you by people in your
company or by SolidWorks reseller experts, and some of you will do the
installation on your own. Regardless, it is best to make sure that your

CHAPTER

IN THIS CHAPTER

Installing SolidWorks

Getting started with
SolidWorks

Identifying different types of
SolidWorks documents

Grasping feature-based
Modeling

Grasping history-based
Modeling

Sketching in parametric
software

Controlling changes with
Design Intent

Modifying Design Intent

Working with links between
documents

Creating a part template
tutorial

Using parametrics in a
sketch tutorial
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FIGURE 1.1

hardware and software are compatible with the SolidWorks system requirements, available
on the SolidWorks Web site at www.solidworks.com/sw/support/System
Requirements.html.

In addition, whether you are installing SolidWorks or someone else is installing it for you, you
should consider purchasing a copy of the SolidWorks Administration Bible (Wiley, 2010), which
contains all the information you need on installing, configuring, and troubleshooting SolidWorks.

Alternatively, you might not want to get that involved at first. You can install the software with all
defaults just to get started, using it as a practice installation, especially if you intend to learn as
much as you can about it, and then come back and do a more thorough job of implementing it. If
this is the case, just put the DVD in the drive and accept all the defaults. In the Summary page,
shown in Figure 1.1, you can choose to change the disk installation location and choose which
products are installed.

Changing installation settings on the Summary install page

o] 2010 o P44 Edition]
Welcome Summary
This is & new installstion of 2010

Serial Number
system Check . Products CHANGE
Summary % 5, SolidWnorks Taalhox, Rauting, Sali
= utilities, ScanTodd, 30 Instant Website, TolAnalyst, Circuitorks, Design Checker, Examgle Files,
Download Manunls, DWGFartnes, Help Files

SalidWarks elirawings E
Install vwieditor

FhotoView 160
Finish SolidWorks Explorer/Workgroup PDM: SolidWorks Explorer, SohdWorks Workgrowp POM Chent

Add-in, SubdWorks Workgroup POM x64 Chent Add-m
idWorks

i/ Download Options cHange o
L Installation Lacation cHange
Installatsun locatian: d:'\Program Files\SohdWorks Corp &
Install from: CillUsers\matt\D...ownleads\SolidWorks 2010 Betal X564 Edition

4

' Toolbox Oplivns

Lstimated installation size: 5.9 GU

When installing any software, it is best practice to exit out of all other software first, make sure you
have enough hard drive space and otherwise meet the system requirements outlined on the
SolidWorks System Requirements Web page, and reboot when the installation is complete.
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Starting SolidWorks for the First Time

SolidWorks has many tools for beginning users that are available when the software is installed.
A default installation presents you with several options when the software is started the first time.
Following is a description of these options, and how you can most benefit from them.

If you plan to go to formal SolidWorks reseller-based training classes, it is a very good idea to go
through some of the tutorials mentioned in this section first; this way you are prepared to ask edu-
cated questions and have a leg up on the rest of the class. You will get more out of the training
with the instructor if you have seen the material once before.

SolidWorks License Agreement

It is useful to be familiar with what this document says, but the agreement does not have any bear-
ing on learning how to use the software other than the fact that it allows for a Home Use License.
Many users find this part of the license agreement helpful. The primary user of the license at work
is also allowed to use the license at home or on a portable computer. This is often a good option
for learning techniques, doing additional practice, or completing the design of that deck or soap-
box derby car. If your employer uses floating licenses, the rules are somewhat different. Contact
your reseller for details.

Welcome to SolidWorks

The Welcome to SolidWorks screen, shown in Figure 1.2, is the next thing to greet you. This helps
you establish what type of tools you would like to see in the interface and gives you some help
options. You may not get the chance to see this dialog box if someone else, such as an IT person,
has installed and done an initial test on your software for you.

FIGURE 1.2

The Welcome to SolidWorks screen

to SolidWorks ]

‘Welcome to Sobdwiorks. This is the first time you have iun Solidworks on this machine. 'We
would e bo grvee pou an ba customize: pour SoldiWores installati

Help customization
(01 e & new wzer, Show Quick Tigs o el me gel staled

()1 am new to this version of Solidworks. Show me Interacive What's New help.
) Do ot show me any dynamic help.

Wtk Hove customization

“f'ou can cushonize default visibility of tookbars and menus by your aea of expertize, Selact
any. all, or none of the tollowing categones.

|| Congumer product design
[ IMactine design
[ gl design

Mote: rou can change these options at any time in the Solidw/orks application.

o J [ hew ]
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Quick Tips
Quick Tips enables balloons with tips to help you get started with several tasks. For example, the

first Quick Tip you see may be the one shown in Figure 1.3. When you begin to create your first
document in SolidWorks, a Quick Tip helps guide you on your way.

FIGURE 1.3

The SolidWorks Document Quick Tip

New users typically start by

creating a part document.
Select Part and click OK.

New Sull furks Ducument
4
% a 30 representation of a single design component
Part

As you continue working, Quick Tips displays a box, shown in Figure 1.4, at the lower-right cor-
ner of the Graphics Window that offers context-sensitive help messages. As you work with the
software, these messages change to remain relevant to what you are doing.

FIGURE 1.4

The main Quick Tip window

What would you like to do?

B Coeale o solid part

\GD Create a 20 skeich

ﬁ Create a sheet metal pan

AN B
\hHuw do | close this window? iy

You can turn Quick Tips on or off by clicking the small square on the Status Bar in the lower-right
corner, as shown in Figure 1.5. You can turn the Status Bar on or off in the View menu; however,
the Status Bar serves many useful purposes for all users, so I recommend you leave it selected. You
can also turn Quick Tips off in the Help menu by deselecting Quick Tips. The on/off setting is
document-type sensitive, so if you deselected Quick Tips off in part mode, you will need to do it
again for assemblies and drawings, as well. Quick Tips are a great way to get going or to get a little
refresher if it has been a while since you last saw the software.
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FIGURE 1.5

Turning Quick Tips on or off

Ouick Tips
Use this icon, or click elp, @«
Quick Tips', tn apen and close

the Quick Tips window.

Editing Mart »

B

FIGURE 1.6

To start a new SolidWorks document, click the New icon in the title bar of the SolidWorks appli-
cation. With standard functions such as creating a new document, SolidWorks works just like a
Microsoft Office application, and the icons even look the same.

The first time you create a document, SolidWorks prompts you to select units for your default
templates, as shown in Figure 1.6. This is an important step, although you can make changes later
if needed. SolidWorks stores most of the document-specific settings in document templates, which
you can set up with different settings for each type of document — parts, assemblies, and draw-
ings. More information on part and assembly templates can be found later in this chapter. Drawing
Templates are described in detail in Chapter 20.

The default template units selection

Units and Di

Clandard *]

Units;

ANSI

Properties,

Select the inkial settings for the defauk bemplates:
s (_rth, pound, spcond) v|

Dimension standard:

NOTE: These sellinus can be dhanged Nor swdividusl
templates or documents in Tools, Cptions, Document

w

ook

3 i Cancel ] l Help. j

One of the most common questions new users ask is how they can change the default so that new
documents come up with a certain type of units every time. Units in new documents are set by
templates. To create a part with inch units, use a template with inch units. You can have as many
templates as you want, and can have a different template for each type of units you might use.

ISO (International Organization for Standardization) and ANSI (American National Standards
Institute) standards use different methods of projecting views, and these standards are controlled
by templates. ISO is typically a European standard and uses First angle projection, while ANSI is
an American standard and uses Third angle projection. The standard projection used throughout
this book is Third angle.
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FIGURE 1.7

The difference between Third and First angle projections can cause parts to be manufactured
incorrectly if those reading the prints (or making the prints) do not catch the difference or see that
there is some discrepancy. Figure 1.7 demonstrates the difference between the two projection
types. Make sure to get the option correct. If someone else, such a computer specialist who is not
familiar with mechanical drafting standards, initially sets up SolidWorks on your computer, you
will want to verify that the default templates are correct.

Differences between First (left) and Third (right) angle projections

% Projections SLOPRT BEiX] |9 Projeciions SLOPRT e

©
©

0 & [T

X Tolkd [T

First angle projection Third angle projection

Another setting affecting projections that you will want to check can be accessed by choosing
Toolsw Options &> Display/Selection & Projection type for four view viewport. This does not follow
the dimensioning standard selected for the default templates or the country in which the software
is installed.

SolidWorks documentation

Several types of documentation are available to help SolidWorks learners along their path. A great
place to start is the SolidWorks Resources tab in the Task Pane (on the right side of the screen).
This is the first tab in the list and has the Home icon. The Getting Started option in the SolidWorks
Resources tab is shown in Figure 1.8.
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FIGURE 1.8

The Getting Started option on the SolidWorks Resources tab of the Task Manager

SolidWorks Resources 19

Getting Started - 0 Al

D'Nm Dorument
,_.t' Open a Document ‘m
@ Making My First Part

A3 Making My First Draswing

& Online Tutorisls ?

The terminology SolidWorks has used over the past several releases has changed and may seem
confusing to some of you. In 2007, SolidWorks changed the name Online User’s Guide to
SolidWorks Help. This is a help file on the local computer; it is not online in that it is not on the
Internet. For several years after software companies eliminated hard copy documentation, it was
popular to call electronic documentation “online” even though the documentation was only on the
local computer. In 2010, the SolidWorks Web Help option was added to the Help menu. This
option is online in that it is on the Internet.

Tutorials

When you select the Online Tutorials option in the Help menu, you get a list of tutorials on sub-
jects from sheet metal to macros in parts, assemblies, and drawings. These tutorials are certainly
worth your time, and will build your skills and knowledge of basic functionality. This SolidWorks
Bible distinguishes itself from the tutorials by going into far more detail and depth about each func-
tion, adding information such as best practices, performance considerations, and cautionary data,
acting as a thorough desk reference. The purpose of this book is not to duplicate all the resources
for beginners, but to take the information into far more depth and detail, and answer the “why”
questions instead of just the “how” questions.

What's New

With every release, SolidWorks publishes a What's New document to help you keep up to speed
with the changes. This is typically a PDF file with accompanying example files. If you have missed
a version or two, reading through the What's New files can help get you back on track. (You can
find every What's New document from SolidWorks 98+ through SolidWorks 2010 on Ricky
Jordan’s blog, at http: //rickyjordan.com.) Again, don’t expect many detail or interface
screen shots; it introduces you to the basic changes.

Moving from AutoCAD

In the Help menu is a selection called Moving from AutoCAD. You may also see it referred to as
Moving from 2D to 3D in various places in the SolidWorks interface. It is intended to help transi-
tioning users acclimate to their new surroundings. Terminology is a big part of the equation when
making this switch, and figures prominently in the Moving from AutoCAD help file.
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TABLE 1.1

Likely, the most helpful sections in Moving from AutoCAD are Approach to Modeling and
Imported AutoCAD Data. The information in these categories is useful whether you are coming to
SolidWorks from AutoCAD or from another CAD package.

SolidWorks Help

SolidWorks Help (formerly The Online User’s Guide) is the new Help file. There are two formats:
the traditional Help format and a Web-based help file. You can use Search capabilities to find what
you are looking for. The SolidWorks Help has tutorials and a separate API (application program-
ming interface) help file. Frankly, it lacks detail, and often skips over important facts such as what
you might use a certain function for, what the interface looks like, or where you might find the
command in the first place. This SolidWorks Bible fills in most of the gaps in information about the
standard version of the software.

Tip of the Day

The SolidWorks Tip of the Day is displayed at the bottom of the SolidWorks Resources tab in the
Task Pane. Cycling through a few of the tips or using them to quiz co-workers can be a useful
skills-building exercise.

Hardcopy documentation

Unfortunately, hardcopy documentation has dwindled from all software companies. Software sup-
pliers often claim that keeping up with the changes in print is too much work and inefficient. This
is the same reason that SolidWorks gives for changing from help files that are on your local com-
puter to help files that are only available across the Internet. Still many users prefer to have a phys-
ical book in their hands, one they can spread out on the desk next to them; earmark, highlight,
and mark with Post-its; and take notes in, as evidenced by you holding this book at this moment.
Hardcopy documentation has an important role in the dissemination of information.

Identifying SolidWorks Documents

SolidWorks has three main data type files: parts, assemblies, and drawings; however, there are
additional supporting types that you may want to be familiar with if you are concerned with cus-
tomization and creating implementation standards. Table 1.1 outlines the document types.

Document Types
Design Documents Description
.sldasm SolidWorks assembly file type
.slddrw SolidWorks drawing file type
sldprt SolidWorks part file type

10
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Templates and Formats

Description

.asmdot Assembly template

.asmprp Assembly custom properties tab template
.drwdot Drawing template

.drwprp Drawing custom properties tab template
journal.doc Design journal template

.prtdot Part template

.prtprp Part custom properties tab template
.sldbombt BOM template (table-based)

.sldtbt General table template

slddrt Drawing sheet format

.sldholtbt Hole table template

.sldrevtbt Revision table template

.sldwldtbt Weldment cutlist template

xls BOM template (Excel-based)

Library Files Description

.sldblk Blocks

sldlfp Library part file

Styles Description

.sldgtolfvt Geometric tolerance style

sldsffvt Surface finish style

.sldweldfvt Weld style

Symbol Files Description

gtol.sym A symbol file that enables you to create custom symbols
swlines.lin A Line style definition file that enables you to create new line styles
Others Description

bl Sheet metal bend table

calloutformat.txt Hole callout format file

.sldclr Color palette file

.sldreg SolidWorks settings file

.sldmat Material database

.sldstd Drafting standard

.swb, swp Macros, macro features

.txt Custom property file, sheet metal bend line note file
Xls Sheet metal gauge table

11
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Saving your setup

If you have taken time to set up a computer and then need to reinstall SolidWorks, move to
another computer, or duplicate the setup for another user, you need to copy out the files you have
used or customized. By default, all these files are located in different folders within the SolidWorks
installation directory. Chapter 2 deals with interface settings and creating a registry settings file to
copy to other computers or use as a backup.

Best Practice

It is especially important to have copies of these files in a location other than the default installation folder
when you are doing complex implementations that include templates for various types of tables or customized
symbol files. Uninstalling SolidWorks or installing a new version will wipe out all your hard work. Choose
Tools=> Options=> File Location to save these files in separate library folders on the local hard drive or on a net-
work location. m

Tip

Using templates

I have included some of my part and assembly templates on this book’s CD-ROM for you. Copy
these files to the location specified at Tools=> Options = File Locations = Document Templates.

When you begin to create a new document, and the New SolidWorks Document dialog box gives
you the option to select one of several files to start from, those files are templates. Think of tem-
plates as “start parts” that contain all the document-specific settings for a part (Tools= Options &>
Document Properties). The same concept applies to assemblies and drawings. Templates generally
do not have any geometry in them (although it is possible).

The Novice interface for the New SolidWorks Document dialog box (File=> New SolidWorks Document) only
enables you to select default templates. The Advanced interface enables you to select any available template. m
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As shown in Figure 1.9, several tabs can be displayed on the advanced interface. Each of these
tabs is created by creating a folder in the template directory specified in the Options dialog box
(Tool= Options).

Having multiple document templates available
Using multiple templates enables you to start working from multiple starting points, which is an
advantage in many situations, such as:

e Standardization for a large number of users

® Working in various units

® Preset materials

® Preset custom properties

® Parts with special requirements, such as sheet metal or weldments

® Drawings of various sizes with formats (borders) already applied

® Drawings with special notes already on the sheet
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FIGURE 1.9

The Novice and Advanced interfaces for the New SolidWorks Document dialog
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Cross-Reference

Drawing templates and formats are complex enough that | cover them in a separate chapter. Chapter 20 dis-
cusses the differences between templates and formats, and how to use them to your advantage. This chapter
addresses part and assembly templates. m

Depending on your needs, it might be reasonable to have templates for metric and inch part and
assembly, templates for steel and aluminum, and templates for sheet metal parts and for weldments,
if you design these types of parts. If your firm has different customers with different requirements,
you might consider using separate templates for each customer. Over time, you will discover the
types of templates you need, because you will find yourself making the same changes repeatedly.

13
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To create a template, open a document of the appropriate type (part or assembly), and make the
settings you want the template to have; for example, units are one of the most common reasons to
make a separate template, though any Document Property setting is fair game for a template, from
the dimensioning standard used to the image quality settings.

Some document specific settings do not appear in the Document Properties dialog box. Still, these
settings are saved with the template. Settings that fall into this category are the View menu entity
type visibility option and the Tools Sketch Settings menu option.

Custom Properties are another piece of the template puzzle. If you use or plan to use BOMs (Bills
of Materials), PDM (Product Data Management), or linked notes on drawings, you need to take
advantage of the automation options available with custom properties. Setting up custom proper-
ties is covered in detail in Chapter 20.

In addition, the names of the standard planes are template specific. For example, the standard
planes may be named Front, Top, and Side; or XY, XZ, and ZY; or Planel, Plane2, and Plane3; or
North, Plan, and East; or Elevation, Plan, and Side for different uses.

Locating templates

You can set the location of the templates folder at Tools= Options= File Locations % Document
Templates. The folder location may be a local folder or a shared network folder. Multiple folders
may be specified in the list box, each corresponding to a tab in the New Document’s Advanced
interface.

After all the Document Properties, custom properties, and other settings are set to your liking and
you are ready to save the file as a template, choose Filew> Save As and select Part Templates in Files
of Type. SolidWorks prompts you to save the template in the first folder listed in the File Locations
list. You can create assembly templates the same way, except you change the settings for an assem-
bly document.

You can also create additional tabs on the New SolidWorks Document dialog box by making sub-
folders in the main folder in the File Locations area. For example, if your File Locations list for
Document Templates looks like Figure 1.10, your New SolidWorks Document dialog box will look
like Figure 1.11.

FIGURE 1.10

The Tools= Options = File Locations list
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The New SolidWorks Document dialog box

New SolidWorks Document

Cushnm Templares

Part Assombly Drawing

Adding subfolders to either of the locations listed in File Locations results in additional tabs in the
New SolidWorks Document dialog box, as shown in Figures 1.12 and 1.13.

FIGURE 1.12

Additional subfolders added to a File Locations path
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FIGURE 1.13

The tabs associated with the subfolders in New SolidWorks Document dialog box
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Default templates

Default templates are established at Tools® Options = Default Templates. The default templates
must be in one of the paths specified in File Locations. Figure 1.14 shows the Default Templates
settings.

15
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The Tools= Options=> Default Templates settings
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There are two Default Template options: Always use these default document templates and Prompt
user to select document template. The Default Template options apply to situations when a tem-
plate is required by an automatic feature in the software such as an imported part or a mirrored
part. In this situation, depending on the option selected, the system automatically uses the default
template or the user is prompted to select a template.

Performance

Allowing the software to apply the default template automatically can have a great impact on speed. This is
especially true in the case of imported assemblies, which would require you to select templates manually for
each imported part in the assembly if the Prompt user to select document template option is selected. m

Sharing templates

If you are administering an installation of a large number of users, or even if there are just a couple
of users working on similar designs, shared templates are necessary. If every user does what she
thinks best, you may get an interesting combination of conflicting ideas, and the consistency of the
company’s documentation may suffer. Standardized templates cannot make users model, assemble,
and detail in exactly the same way, but they do start off users on the same foot.

To share templates among several users, create a folder for templates on a commonly accessible
network location, preferably with read-only access for users and read-write permissions for admin-
istrators. Then point each user’s File Locations and Default templates to that location. Access prob-
lems due to multiple users accessing the same files do not arise in this situation because users copy
templates to create new documents, and do not use them directly.

Caution

One of the downfalls of this arrangement is that if the network goes down, users no longer have access to their
templates. This can be averted by also putting copies of the templates on the local computers; however, it has
the tendency to undermine the goal of consistent documentation. Users may tend to use and customize the
local templates rather than use the standardized network copies.

16
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CAD administration and organizing any group of people on some level always comes down to trusting employees
to do the right thing. There is no way to completely secure any system against all people trying to work around
the system, so you must rely on hiring people you can train and trust. m

Understanding Feature-Based Modeling

You need to be familiar with some terminology before diving into building models with
SolidWorks. Notice that I talk about “modeling” rather than “drawing,” or even “design.” This is
because SolidWorks is virtual prototyping software. Whether you are building an assembly line for
automotive parts or designing decorative perfume bottles, SolidWorks can help you visualize your
geometrical production data in the most realistic way possible without actually having it in your
hand. This is more akin to making a physical model in the shop than drawing on paper.

“Feature-based” modeling means that you build the model by incrementally identifying functional
shapes and applying processes to create the shapes. For example, you can create a simple box by
using the Extrude process, and you can create a sphere using the Revolve process. However, you
can make a cylinder using either process, by revolving a rectangle or extruding a circle. You start
by visualizing the 3D shape, and then apply a 3D process to a 2D sketch to create that shape. This
concept on its own is half of what you need to know to create models with SolidWorks.

Figure 1.15 shows images of simple feature types along with the 2D sketches from which they
were created.

Simple extruded and revolved features
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Many different feature types in SolidWorks enable you to create everything from the simplest
geometry shown in Figure 1.15 to more complex artistic or organic shapes. In general, when I talk
about modeling in this book, I am talking about solid modeling, although SolidWorks also has a
complete complement of surfacing tools. I discuss the distinction between solid and surface model-
ing in Chapter 27.

Table 1.2 lists some of the most common features that you find in SolidWorks, and classifies them
according to whether they always require a sketch, a sketch is optional, or they never require a sketch.

TABLE 1.2

Feature Types
Sketch Required Sketch Optional No Sketch (Applied Features)
Extrude Loft Fillet
Revolve Sweep Chamfer
Rib Dome Draft
Hole Wizard Boundary Shell
Wrap Deform Flex

In addition to these features, other types of features create reference geometry, such as curves,
planes, axes, surface features (Chapter 27); specialty features for techniques like weldments
(Chapter 31); plastics/mold tools (Chapter 32); and sheet metal (Chapter 29).

Understanding History-Based Modeling

In addition to being feature-based, SolidWorks is also history based. To show the process history,
there is a panel to the left side of the SolidWorks window called the FeatureManager. The
FeatureManager keeps a list of the features in the order in which you have added them. It also
enables you to reorder items in the tree (in effect, to change history). Because of this, the order in
which you perform operations is important. For example, consider Figure 1.16. This model was
created by the following process, left to right starting with the top row:

Create a sketch.
Extrude the sketch.
Create a second sketch.

Extrude the second sketch.

ok W=

Create a third sketch.

18
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6. Extrude Cut the third sketch.
7. Apply fillets.
8. Shell the model.

FIGURE 1.16

Features used to create a simple part
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If the order of operations used in the previous part were slightly reordered (by putting the shell
and fillet features before Step 6), the resulting part would also look slightly different, as shown in
Figure 1.17.

FIGURE 1.17

Using a different order of features for the same part

Figure 1.18 shows a comparison of the FeatureManager design trees for the two different feature
orders. You can reorder features by dragging them up or down the tree. Relationships between fea-
tures can prevent reordering; for example, the fillets are dependent on the second extruded feature
and cannot be reordered before it. This is referred to as a Parent/Child relationship.

Cross-Reference

Reordering and Parent/Child relationships are discussed in more detail in Chapter 11. m

FIGURE 1.18

Compare the FeatureManager design trees for the parts shown in Figure 1.16 and Figure 1.17.
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On the CD-ROM

The part used for this example is available in the material on the CD-ROM, named Chapter 1 — Features.
SLDPRT. m

The order of operations, or history, is important to the final state of the part. For example, if you
change the order so that the shell comes before the extruded cut, the geometry of the model
changes, removing the sleeve inside instead of the hole on top. You can try this for yourself by
opening the part indicated previously, dragging the Shelll feature in the FeatureManager, and
dropping it just above the Cut-Extrudel feature.

Note

You can only drag one item at a time in the FeatureManager. Therefore, you may drag the shell, and then drag
each of two fillets, or you could just drag the cut feature down the tree. Alternatively, you can put the shell
and fillets in a folder and drag the folder to a new location. Reordering is limited by parent-child relationships
between dependent features. m

Cross-Reference

You can read more about reordering folders in Chapter 11. m

In some cases, reordering the features in the FeatureManager may result in geometry that might not
make any sense; for example, if the fillets are applied after the shell, they might break through to the
inside of the part. In these cases, SolidWorks gives an error that helps you to fix the problem.

In 2D CAD programs where you are just drawing lines, the order in which you draw the lines does
not matter. This is one of the fundamental differences between history-based modeling and drawing.

Features are really just like steps in building a part; the steps can either add material or remove it.
However, when you make a part on a mill or lathe, you are only removing material. The
FeatureManager is like an instruction sheet to build the part. When you reorder and revise history,
you change the order of operations and thus the final result.

Sketching with Parametrics

Sketching is the foundation that underlies the most common feature types. You will find that
sketching in parametric software is vastly different from drawing lines in 2D CAD.

Dictionary.com defines the word parameter as “one of a set of measurable factors . . . that define a
system and determine its behavior and [that] are varied in an experiment.” SolidWorks sketches
are parametric. What this means is that you can create sketches that change according to certain
rules, and maintain relationships through those changes. This is the basis of parametric design. It
extends beyond sketching to all the types of geometry you can create in SolidWorks. Creating
sketches and features with intelligence is the basis of the concept of Design Intent, which I cover in
more detail later in this chapter.
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In addition to 2D sketching, SolidWorks also makes 3D sketching possible. Of the two methods,
2D sketches are by far more widely used. You create 2D sketches on a selected plane, planar solid,
or surface face and then use them to establish shapes for features such as Extrude, Revolve, and
others. Relations in 2D sketches are often created between sketch entities and other entities that
may or may not be in the sketch plane. In situations where other entities are not in the sketch
plane, the out-of-plane entity is projected into the sketch plane in a direction that is normal to the
sketch plane. This does not happen for 3D sketches.

You can use 3D sketches for the Hole Wizard, routing, weldments, and complex shape creation,
among other applications.

Cross-Reference

For more information on 3D sketching, please refer to Chapter 31. m

For a simple example of working with sketch relations in a 2D sketch, consider the sketch shown
in Figure 1.19. The only relationships between the four lines are that they form a closed loop that
is touching end to end, and one of the corners is coincident to the part origin. The small square
icon near the origin shows the symbol for a coincident sketch relation. These sketch relations are
persistent through changes, and enable you to dynamically move sketch elements with the cursor
on the screen. The setting to enable or disable displaying the sketch relation symbols is found at
View = Sketch Relations.

A sketch of four lines

22

If you drag any of the unconstrained corners (except for the corner that is coincident to the ori-
gin), the two neighboring lines will follow the dragged endpoint, as shown in Figure 1.20.
Notice the ghosted image left by the original position of the sketch. This is helpful when experi-
menting with changes to the sketch because you can see both the new and the old states of the
sketch. The setting to enable or disable this ghosted position is found at Tools = Options &>
Sketch=> Ghost Image on Drag.

If you add a parallel relation between opposing lines, they now act differently, as shown in Figure
1.21. You add a parallel relation by selecting the two lines to make parallel and selecting Parallel
from the PropertyManager panel. You can also select the Parallel relation from the context bar that
pops up in the graphics window when you have both lines selected.
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FIGURE 1.20

Dragging an endpoint

Q"

Cross-Reference

You can read more about the PropertyManager in Chapter 2. m

FIGURE 1.21

Dragging an endpoint where lines have relations

"

Next, add a second parallel and a horizontal relation, as shown in Figure 1.22. If you are following
along by re-creating the sketch on your computer, you will notice that one line has turned from
blue to black.

FIGURE 1.22

Horizontal and parallel relations are added.
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FIGURE 1.23

The colors represent sketch states. It may be impossible to see this in the black and white printing
of this book, but if you are following along on your own computer, you can now see one black line
and three blue lines. Sketch states include Underdefined, Overdefined, Fully Defined, Unsolvable,
Zero Length, and Dangling, and are described as follows:

® Blue: Underdefined. The sketch entity is not completely defined. You can drag a portion
of it to change size, position, or orientation.

e Black: Fully Defined. The sketch entity is fully defined by a combination of sketch rela-
tions and dimensions. A sketch cannot be fully defined without being connected in some
way to something external to the sketch, such as the part origin or an edge. (The excep-
tion to this rule is the use of the Fix constraint, which, although effective, is not a recom-
mended practice.)

® Red: Overdefined — Not Solved. When a sketch entity has two or more relations and one
of them cannot be satisfied, the unsatisfied will be red. For example, if a line has both
Horizontal and Vertical relations, and the line is actually vertical, the Vertical relation will
be yellow (because it is conflicting but satisfied), and the Horizontal will be red (because it
is conflicting and not satisfied).

® Yellow: Overdefined - Conflicts. Solving the sketch relations would result in a zero-
length entity; for example, this can occur where an arc is tangent to a line, and the center-
point of the arc is also coincident to the line.

® Brown: Dangling. The relation has lost track of the entity to which it was connected.

e Pink. The pink sketch status is no longer used.

There can be entities with different states within a single sketch. In addition, endpoints of lines can
have a different state than the rest of the sketched entity. For example, a line that is sketched hori-
zontally from the origin has a coincident at one endpoint to the origin, and the line itself is horizon-
tal. As a result, the line and first endpoint are black, but the other endpoint is underdefined
because the length of the line is not defined. Sketch states are indicated in the lower-right corner of
the graphics window and in the status bar. You can see that dragging one corner allows only the
lines to move in certain ways, as shown in Figure 1.23.

Sketch motion is becoming more constrained.
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In addition to sketch relations, dimensions applied using the Smart Dimension tool are also part of
the parametric scheme. If you apply an angle dimension (by clicking the two angled lines with the
Smart Dimension tool) about the origin and try dragging again, as shown in Figure 1.24, you see
that the only aspect that is not locked down is the length of the sides. Notice also that when the
angle dimension is added, another line turns black.

FIGURE 1.24

Open degrees of freedom can be dragged.

Finally, adding length dimensions for the unequal sides completes the definition of the sketch, as
shown in Figure 1.25. At this point, all lines have turned black. This state is called “fully defined.”
Between the dimensions and sketch relations, there is enough information to re-create this sketch
exactly.

Best Practice

It is considered best practice to fully define all sketches. However, there are times when this is not practical.
When you create freeform shapes, generally by using splines, these shapes cannot easily be fully defined, and
even if they are fully defined, the extra dimensions are usually meaningless, because it is impractical to dimen-
sion splines on manufacturing drawings. m

The fully defined sketch cannot be dragged, and there are no degrees of freedom.
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Parametric relations within a sketch control how the sketch reacts to changes from dimensions or
relations within the sketch or by some other factor from outside the sketch. Other factors can also
drive the sketch, such as equations, other model geometry that is external to the sketch, and even
geometry from another part in an assembly, as you shall see later.

Understanding Design Intent

Design Intent is a phrase that you will hear often among SolidWorks users. I like to think of it as
“design for change.” Design Intent means that when you put the parametric sketch relations
together with the feature intelligence, you can build models that react to change in predictable
ways. This gives you a great deal of control over changes.

An example of Design Intent could be a written statement that describes general aspects that help
define the design of a part, such as “This part is symmetrical, with holes that line up with Part A
and thick enough to be flush with Part B.” From this description, and the surrounding parts, it is
possible to re-create the part in such a way that if Part A or Part B changes, the part being
described updates to match.

Some types of changes can cause features to fail or sketch relations to conflict. In most situations,
SolidWorks has ample tools for troubleshooting and editing that you can use to repair or change
the model. In these situations, it is often the Design Intent itself that is changing.

Best Practice

When editing or repairing relations, it is considered best practice to edit rather than delete. Deleting often
causes additional problems further down the tree. Many users find it tempting to delete anything that has an
error on it. m
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Editing Design Intent

Design Intent is sometimes thought of as a static concept that controls changing geometry.
However, this is not always the way things are. Design Intent itself often changes, thus requiring
the way in which the model reacts to geometric changes to also change. Fortunately, SolidWorks
has many tools to help you deal with situations like this.

Choosing Sketch Relations

Seeing the sketch relation symbols is the best tool for visualizing Design Intent. You can show or
hide icons that represent the relations by choosing View &> Sketch Relations. When shown, these
relations appear as an icon in a small colored box in the graphics area next to the sketch entity.
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Clicking the icon highlights the sketch elements involved in that relation. Refer to Figures 1.19
through 1.25 for examples of these relations.

Tip

The Sketch Relations option is an excellent candidate for use with a hotkey, thus enabling you to toggle the
display easily on and off. m

Cross-Reference

For more information on creating and managing hotkeys, see Chapter 2. m

You can use the sketch relation icons on the screen to delete relations by selecting the icon and
pressing Delete on the keyboard. You can also use them to determine the status quickly of sketch
relations by referring to the colors defined earlier.

Selecting Display/Delete Relations

ﬁ{i You can find the Display/Delete Relations tool on the Sketch toolbar or by clicking a sketch entity
in an open sketch. The sketch status colors defined earlier also apply here, with the relations
appearing in the appropriate color. (Relations are not shown in blue or black, only the colors that
show errors, such as red, yellow, and brown.) This tool also enables you to group relations by sev-
eral categories:

All in This Sketch
Dangling
Overdefining/Not Solved
External

Defined in Context
Locked

Broken

Selected Entities

In the lower Entities panel of the Display/Delete Relations PropertyManager, shown in Figure 1.26,
you can also replace one entity with another, or repair dangling relations.

Cross-Reference

You can read more about repairing dangling entities in Chapter 11. m
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FIGURE 1.26

The Display/Delete Relations PropertyManager enables you to repair broken relations
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Using Suppressed sketch relations

Suppressing a sketch relation means that the relation is turned off and not used to compute the posi-
tion of sketch entities. Suppressed relations are generally used in conjunction with configurations.

Cross-Reference

Configurations are discussed in detail in Chapter 10. m

Working with Associativity

In SolidWorks, associativity refers to links between documents, such as a part that has an associa-
tive link to a drawing. If the part changes, the drawing updates as well. Bi-directional associativity
means that the part can be changed from the part or the drawing document window. One of the
implications of this is that you do not edit a SolidWorks drawing by simply moving lines on the
drawing; you must change the model, which causes all drawing views of the part or assembly to
update correctly.
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Other associative links include using inserted parts (also called base or derived parts), where one part
is inserted as the first feature in another part. This might be the case when you build a casting. If the
part is designed in its “as cast” state, it is then inserted into another part where machining opera-
tions are performed by cut features and the part is transformed into its “as machined” state. This
technique is also used for plastic parts where a single shape spans multiple plastic pieces. A “master
part” is created and split into multiple parts. An example would be a mouse cover and buttons.

One of the most important aspects of associativity is file management. Associated files stay con-
nected by filenames. If a document name is changed, and one of the associated files is not updated
appropriately, the association between the files can become broken. For this reason, you should
use SolidWorks Explorer to change names of associated files. Other techniques will work, but
there are some techniques you should avoid. I discuss these techniques in Chapter 28 with master
model techniques.

Best Practice

It is considered poor practice to change filenames, locations, or the name of a folder in the path of documents
that are referenced by other documents with Windows Explorer. Links between parts, assemblies, and drawings
can be broken in this way. Using SolidWorks Explorer or a PDM application is the preferred method for chang-
ing filenames. m

Tutorial: Creating a Part Template

This simple tutorial steps you through making a few standard part templates for use with inch and
millimeter parts, as well as making some templates for a couple of materials.

1. Choose Tools= Options = System Options = File Locations and then select
Document Templates from the Show folder for list.

2. Click the Add button to add a new path to a location outside of the SolidWorks
installation directory; for example, D:\Library\Templates.

Click OK to dismiss the dialog box and accept the settings.

Choose File=> New from the menu.

Select any part template.

Choose Tools=> Options = Document Properties &> Drafting Standard.
Make sure the ANSI standard is selected.

Click the Units page.

° RN E W

Change the unit system to IPS, inches with 3 decimal places, using millimeters as the
dual units with 2 decimal places. Set angular units to Degrees with 1 decimal place.

10. Change to the Grid/Snap page.
11. Turn off Display grid.
12. Change to the Image Quality page.
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/¥

13.

14.

15.

16.
17.

18.

19.
20.

21.

22,
23.
24.
25.

26.

27.

Move two-thirds of the way to the right, so it is closer to High. Make sure the Save
tessellation with part document option is selected.

Click OK to save the settings and exit the Tools=> Options dialog box.

Click the right mouse button (RMB) on the Materials entry in the FeatureManager,
and select 1060 Alloy from the list. If it is not there, click Edit Material and find it from
the larger list.

Choose File= Properties, and click the Custom tab.

Add a property called Material of type Text. In the Value/Text Expression column,
click the down arrow and select Material from the list. Notice that the Evaluated Value
shows 1060 Alloy.

Add another property called description and give it a default value of Description.
At this point, the window should look like Figure 1.27.

FIGURE 1.27

Setting up Custom Properties
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Click OK to close the Summary Information window.

Change the names of the standard planes by clicking them twice slowly or clicking
once and pressing F2. Rename them Front, Top, and Side, respectively.

Ctrl+select the three planes from the FeatureManager, click the RMB, and select
Show (the eyeglasses icon).

From the View menu, make sure that Planes is selected.
Click the RMB on the Front plane and select Sketch.
Select the Line tool and click and drag anywhere to draw a line.

Select the Smart Dimension tool and click the line, then click in the space in the
Graphics Window to place the dimension. If you are prompted for a dimension
value, press 1 and click the check mark, as shown in Figure 1.28.

Press Esc to exit the Dimension tool and click the RMB on the displayed dimension
and select Link Value.

Type thickness in the Name box, and click OK.
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Drawing a line and applying a dimension

Madify
[L.00in]

TN

v X 8 2 2(F

28. Press Ctrl+B (rebuild) to exit the sketch, select the sketch from the
FeatureManager, and press Delete on the keyboard.

Note

You do the exercise of creating the sketch and deleting it only to get the link value “thickness” entered into the
template. Once you’ve done it, every part made from this template that uses an Extrude feature will have an
option box for Link to Thickness, which enables you to establish a thickness variable automatically for each
part you create. This is typically a sheet metal part feature, but you can use it in all types of parts. m

29. Choose File= Save As and then select Part Template from the drop-down list.
Ensure it is going into your template folder by giving it an appropriate name reflecting
the inch units and 1060 material, and then click Save.

30. Edit the material applied to change it from 1060 Alloy to Plain Carbon Steel, and
save it as another template with a different name.

31. Change the primary units to millimeters with 2 places, and save as a third
template file.

32. Ecxit the file.

Tutorial: Using Parametrics in Sketches

What separates parametric CAD tools from simple 2D drawing programs is the intelligence that
you can build in to a parametric sketch. In this tutorial, you learn some of the power that paramet-
rics can provide in both structured (using actual dimensions) and unstructured (just dragging the
geometry with the mouse) changes.

1. Open a new SolidWorks document by clicking the New toolbar button or by
choosing File= New.

2. From the list of templates, select a new part template, either inch or millimeter.
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Press the Spacebar on the keyboard to open the View Orientation dialog box, and
double-click the Front view.

Right-click the Front plane in the FeatureManager, or whatever the first plane listed
is, and select Sketch.

Click the View menu, and make sure the Sketch Relations item is depressed.
This shows small icons on the screen to indicate when parametric relations are created
between sketch entities.

Click the Circle from the Sketch toolbar (choose Tools= Sketch Entities= Circle).

Sketch a circle centered on the Origin. With the Circle tool activated, click the cursor
at the Origin in the graphics area. The Origin is the asterisk at the intersection of the long
vertical red arrow and the short horizontal red arrow. After clicking the first point, which
represents the center of the circle, move the cursor away from the Origin, and click again,
which will establish the radius of the circle. (You can also click and drag between the cir-
cle center and the radius if you prefer). Figure 1.29 shows the result.

Deactivate the circle by clicking its toolbar icon or pressing the Esc key on the key-
board. Now click and hold the cursor on the circle, then drag it to change the size of the
circle. The center of the circle is locked to the Origin as the Coincident icon near the
Origin appears. The radius is undefined, so it can be dragged by the cursor. If the center-
point were not defined, the location of the center of the circle could also be dragged.

Sketching a circle
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9.

10.

11.

12.

Activate the 3 pt Corner Rectangle. To find it through a menu, choose Tools=> Sketch
Entities= 3pt Corner Rectangle.

Click the first point inside the circle, click the second point outside the circle,

and click the third point such that one end of the rectangle is completely inside the
circle. Use Figure 1.30 as a reference. Avoid making any two points vertical or horizontal
from one another. You will learn in Chapter 3 about how to control automatic relations
in more detail.

FIGURE 1.30

Sketching a three-point rectangle
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Activate the Centerline tool by choosing Tools=> Sketch Entities > Centerline. Click
and hold the left mouse button first at the Origin, then at the midpoint of the far end of
the rectangle release the mouse button, as shown in Figure 1.31. When the cursor gets
close to the midpoint of the end of the rectangle, it snaps into place. Press Esc to turn off
the Centerline tool.

Select the centerline and Ctrl+select the line with which it shares the midpoint rela-
tion. After making the second selection, do not move the cursor, and you will see a set of
options in a pop-up context toolbar. Click the Make Perpendicular icon, as shown in
Figure 1.32, and the rectangle becomes symmetric about the centerline.

33



Part I: SolidWorks Basics

34

13.

FIGURE 1.31

Creating a midpoint relation between a centerline and a line

FIGURE 1.32

Making the rectangle symmetric about the centerline

2 3

Drag one of the corners of the rectangle from inside the circle and drop it on the
circumference of the circle itself. The point here is that you want the corner of the cir-
cle to be right on the circle always. A coincident relation is created by the drag-and-drop
action. Now when you move either the circle or the rectangle, the other may change in
size. Try dragging the circle itself, a corner point of the rectangle, or a line of the rectan-
gle. Try dragging the centerline and the free endpoint of the centerline. Notice that the
result of moving each different sketch entity is different from any of the others.
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0 14.

15.

16.

17.

Click the Smart Dimension tool in the Sketch toolbar or choose Tools=> Dimensions >
Smart. Click the outside end line of the rectangle, and move the cursor away from the line.
You can align the dimension one of three ways: measuring the horizontal dimension of the
line, the vertical dimension, or the dimension aligned with the angle of the line. When the
dimension is aligned with the angle, as shown in Figure 1.33, click the RMB. This locks in
that orientation, and enables you to select a location for the dimension without affecting its
orientation. Click to place the dimension. If the dimension does not automatically give you
the opportunity to change the dimension, double-click the dimension and change it to 0.5
inch or 12 mm. If this is larger than the diameter of the circle, notice that the circle changes
to accommodate the new width.

FIGURE 1.33

Placing a dimension on an angled line

Drag the endpoint of the centerline around the center of the circle to see how the
sketch reacts. Notice that the dimension added to the rectangle keeps it a constant width
and makes it react more predictably.

Put a dimension on the circle. Click the circumference of the circle with the Smart
Dimension tool, and then place the dimension anywhere on the screen without
clicking any other geometry. Notice that diameter values of less than the dimension cre-
ated in Step 14 cause errors. This makes geometrical sense. Change the diameter value to
1 inch or 25 mm.

Drag the endpoint of the centerline again. Notice that as you define more sizes and
relationships between sketch entities, the motion of the sketch as you drag becomes more
constrained and predictable.
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18. Activate the Smart Dimension tool again. Click the Top plane from the
FeatureManager and then click the centerline. This creates an angle dimension. Position
the angle dimension and change its value to 60 degrees, as shown in Figure 1.34.

FIGURE 1.34

Creating an angle dimension

19. Double-click any dimension and use either the up and down arrows to the right of it
or the scroll wheel below it to change the value, as shown in Figure 1.35. Notice that
not all values of all dimensions produce valid results. Also, notice that the entire sketch is
black except for the outer end of the rectangle, which is now blue. This is the only thing
you can now drag.

FIGURE 1.35

Using arrows or scroll wheel to change dimension values
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Summary

While product development is about design, it is even more about change. You design something
once, but you may modify it endlessly (or it may seem that way sometimes). Similarly, SolidWorks
is about design, but it really enables change. Think of SolidWorks as virtual prototyping software
that enables you to change your prototype rather than having to make a new one. Virtual proto-
types will never completely replace physical models, but they may reduce your dependence on
them to some extent.

SolidWorks is also about reusing data. Associativity enables you to model a part once and use it for
Finite Element Analysis (FEA), creating 2D drawings, building assemblies, creating photorealistic
renderings, and so on. When you make changes to the model, your drawing is automatically
updated, and you don’t have to reapply FEA materials and conditions or redo the rendering setup.
Associativity saves you time by reusing your data. Associativity and change driven by feature-based
and history-based modeling can take some getting used to if you have had limited exposure to it,
but with some practice, it becomes intuitive and you will see the many benefits for enabling
change. Parametric sketching and feature creation help you to maintain Design Intent as well as
adjust it as necessary.
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SolidWorks Interface

find more than one way to do almost everything. There is no one best
way to use the interface; and each method has strengths and weak-
nesses depending on the task.

The SolidWorks interface offers a wide range of tools. You will often

Once you have mastered the various interface elements and customized your
SolidWorks installation, working with the software becomes much more effi-
cient and satisfying. You may find your mastery of the interface comes with
practice and experience. The interface is complex and can be daunting.
Many existing users may discover features in this book of which they were
not aware, even though they have been trained and have used the software
for years.

I explain each interface element identified in Figure 2.1 in detail within this
chapter.
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FIGURE 2.1

Elements of the SolidWorks interface
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Identifying Elements of the
SolidWorks Interface

The major elements of the SolidWorks interface are the graphics window, where all the action
takes place, the FeatureManager, which is the list of all the features in the part, the
PropertyManager, where most of the data input happens, and the CommandManager and toolbars,

where you access most of the commands in the software. Of these, I cover the CommandManager
and toolbars first.

Using the CommandManager and toolbars

In some respects, the CommandManager resembles the Microsoft (MS) Ribbon interface found in
Office 2007 applications. SolidWorks did not do a strict implementation of the MS Ribbon,
because it wanted to add more customizability. A far more complete array of interface configura-
tion possibilities awaits you with SolidWorks 2010. In this section of the chapter, I show you how

to make the 2010 CommandManager work for you, and how to use regular or flyout toolbars to
replace it effectively.
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Note

CommandManager

The CommandManager is an area of the interface that you can use to save space traditionally used
by toolbars. The main mission of the CommandManager is to enable you to have easy access to all

toolbars, and even access to customized groups of icons not available on a single default toolbar,
without cluttering the entire screen with toolbars.

The CommandManager accomplishes this by providing small tabs under the left end of the toolbar
area to enable you to switch the toolbar that appears. Figure 2.2 shows the CommandManager in
customize mode, showing all the tabs available in a default setup. To get the CommandManager
into customize mode, right-click one of the CommandManager tabs and select Customize
CommandManager. Alternatively, you can choose Tools= Customize.

To access the pull-down menus in a default setup, place the cursor over the SolidWorks logo or the small flyout
triangle to the right of it in the upper-left corner of the SolidWorks window. Figure 2.2 shows the flyout for pull-
down menus. To keep the menu in that position, click the pushpin on the right end of the flyout menu bar. m

FIGURE 2.2

Customizing the CommandManager
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Customizing the CommandManager

Notice the last tab along the bottom of the CommandManager on the right. If you want to add a
custom tab, you can right-click this tab and select the tab you want to add. You can also select to

add a blank tab and populate it with individual buttons. Figure 2.3 shows a detail of the Add Tab
menu options after you right-click the tab.

FIGURE 2.3

Adding tabs to the CommandManager
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FIGURE 2.4

You can also left-click the special tab on the right and skip the Add Tab menu. To add individ-
ual buttons, first find the button you want to add in the Customize dialog box by choosing
Tools= Customize. Click the Commands tab in the Customize dialog box, and then switch
the CommandManager to the tab you want to add the button to, and drag the button from the
Customize dialog box to the CommandManager. You can remove buttons from the Command-
Manager by dragging them into the blank graphics window area.

Docking the CommandManager

In SolidWorks, you can undock the CommandManager and leave it undocked, pull it to a second
monitor, or dock it vertically to the left or right. To undock it, click and drag on any non-toolbar
button area of the CommandManager, such as around the border. To re-dock an undocked
CommandManager or to change its docking location, drag it onto one of the docking stations
around the screen. Figure 2.4 shows the CommandManager undocked.

The undocked CommandManager

CommmandManager

rﬁ Extruded Boss/Base

648 Revolved Boss/Base

Seelch | Features |

Eveluale
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Using Auto Collapse

The small box with the arrows in it in the upper right-hand corner of the undocked
CommandManager and the undocked PropertyManager is the Auto Collapse option. Early versions
of SolidWorks 2010 seem to have some inconsistencies in the way this option works with
PropertyManagers. You may have to resize detached PropertyManagers manually for various fea-
tures. When the option is active, the PropertyManager expands and collapses automatically, and
should not require scroll arrows unless the PropertyManager is larger than your monitor’s height.
In the condition it is shown in Figure 2.4, the undocked CommandManager will not collapse, but
if you click Auto Collapse, the arrows go away, and the entire CommandManager acts like a big
fly-out toolbar. This can be very handy because it saves a lot of space on the screen, but at the
same time, it requires additional mouse movement to open it up. This is the common trade-off in
this interface —you can trade screen space for additional mouse movement or clicks.

Mixing CommandManager with toolbars

To put a toolbar inline with the CommandManager, drag the toolbar close to the
CommandManager. A space on that row or column will open up. The amount of space that opens
up depends on the tab with the longest set of icons, even if that tab is not showing. To increase the
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amount of space available for a toolbar on the same row as a CommandManager, enter Customize
CommandManager mode by right-clicking a tab and selecting Customize CommandManager. Then
cycle through the available tabs, looking to see which one has the most icons. Remove icons from
the tab with the most. This makes more room for toolbars to the right of the CommandManager.

Tabs and document types

SolidWorks remembers which tabs to show on a per document type basis. This means that when
you are working on a part document, you will have one set of tabs. When you switch to an assem-
bly document, you will see a different set of tabs. The same goes for drawings. Notice that in
Figure 2.3, in the right mouse button (RMB) menu, the options Copy Tab to Assemblies and Copy
Tab to Drawings appear. These options make it easier to set up customizations that apply for all
document types.

Changing the appearance of the CommandManager

For an element of the interface that is supposed to save space, the default settings for the
CommandManager sure take up a lot of it! When many users see the CommandManager for the
first time, they ask how to deselect the text.

You can deselect the text in one of two ways. The easiest way is to right-click in the
CommandManager and deselect the Use Large Buttons with Text option, as shown in Figure 2.5.

FIGURE 2.5

Adding or removing text from the CommandManager buttons
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Another way to remove text from the CommandManager is to remove it only from selected icons.
To do this, first enter the customize mode by choosing Tools= Customize or right-click a
CommandManager tab and select Customize CommandManager, and then right-click a button in
the CommandManager and change the Show Text setting, as shown in Figure 2.6. The Show Text
option is only available when Use large buttons with text is enabled.

Notice also that the text by default goes to the right side of the icon, but using the RMB menu, you
can put the text beneath the icon. With these options and some patience to go through the entire
interface, you can almost totally customize the appearance and function of your
CommandManager.
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FIGURE 2.6

Changing the text setting for individual buttons in the CommandManager
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The most streamlined and space-efficient way to set up the CommandManager is to deselect the
text. This arrangement is shown in Figure 2.5, in the lower image. Notice that the
CommandManager without text takes up the same amount of height as a normal toolbar, with the
added room for the tabs at the bottom. The text can be useful for new users or features that you do
not commonly use. Also, notice that with the text turned off, you have room for more toolbar
space at the end of the CommandManager.

The final setting for the CommandManager appearance is the size of the icons. You have control
over the size of the icon images in the CommandManager. You can find this setting in the
Customize dialog box (Tools= Customize), and it is shown in the upper-right side of Figure 2.7.
The difference between large and small icons is shown in the lower part of the figure.

FIGURE 2.7

Setting large icons
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This setting applies to all the toolbar icons except the Menu Bar, RMB menu, and Context Bar
icons. The setting does apply to the S shortcut toolbar and the Heads-up View toolbar, which I dis-
cuss later in this section. Large icons can be useful on displays with very high resolution, in partic-
ular on laptops where the screen itself may be small but the resolution is very high. All the screen
shots in this book are taken with the Large Icons option selected for improved visibility. There is
often a small difference between the appearance of the large and small icons.

Limitations

If you undock the CommandManager, you cannot reorient the tabs horizontally. They remain
vertical. In addition, you cannot place multiple rows of toolbars on the same row as a Command-
Manager using large buttons with text. In addition, you cannot dock the CommandManager to the
bottom of the SolidWorks window. Another minor limitation is that although SolidWorks enables
you to place toolbars at the right end of the CommandManager, it does not allow you to place
them to the left of the CommandManager.

Using toolbars

The point of the CommandManager is to enable you have many toolbars available to you in a single
click, with the main goal being space savings. SolidWorks is a complex program, with a sprawling
interface. The CommandManager does a good job of making most of it available to you quickly
without taking up a lot of space. Unfortunately, when you save one thing, you usually wind up giv-
ing up something else. Interface set up is frequently about compromise or balancing conflicting con-
cerns. In the case of the CommandManager, the compromise is between mouse travels and clicks.
You may find yourself clicking frequently back and forth between the Sketch and Features tabs. For
this reason, in my interface setup, I put the Sketch toolbar vertically on the right, and remove it
from the CommandManager. This enables me to see the Sketch and Features toolbars at the same
time, and greatly reduces the times I have to click back and forth between the tabs.

You can enable and disable toolbars in several ways. To enable a toolbar, right-click in a toolbar
area and you will be presented with a list of toolbars in SolidWorks. You can enable and disable
this list from here. Another way to do this is to use the Customize dialog box by choosing
Tools= Customize, or the Customize option near the bottom of the RMB toolbar list. Yet another
way is to choose View=> Toolbars.

Heads-up View toolbar

The Heads-up View toolbar appears along the middle of the top edge of the graphics window.
Figure 2.8 shows the default arrangement of the Heads-up View toolbar, and it is shown in relation
to the rest of the interface in Figure 2.1.

The Heads-up View toolbar

R T )
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You can customize the Heads-up View toolbar by using the Toolbars dialog box (Tools=>
Customize = Toolbars).Customization includes turning the Heads-up View toolbar on or off and
adding or removing buttons. This is new in SolidWorks 2010. Previously, you could not turn it
off, and it had a special way of for adding and removing toolbar buttons. If you have multiple doc-
ument windows or multiple view ports showing, the Heads-up View toolbar only shows in the
active window or view port. This toolbar often overlaps with other interface elements when several
windows are tiled or if the active window is not maximized. It can run into the PropertyManager if
it is pulled out of the FeatureManager, as well as the ConfirmationCorner or the Task Pane.

Cross-Reference

Chapter 3 covers the Confirmation Corner in more detail. m

Note

Menu Bar toolbar and menu

The Menu Bar toolbar is found just to the right of the SolidWorks logo on the title bar in the top
left corner of the SolidWorks window. By default, it contains most of the elements of the Standard
toolbar, and it is available even when no documents are open. It uses mostly flyout toolbar icons,
so again it follows the trend of saving space at the expense of an extra click. This toolbar can be
customized in the same way as normal toolbars in the Customize dialog box in the Commands tab.
This toolbar cannot be turned off, but you can remove all the icons from it.

You could run the SolidWorks interface from just the CommandManager without any additional toolbars; you
could do the same with just the Menu Bar toolbar, customizing it with all flyout toolbars. The main advantages
of this toolbar are that it is visible when no documents are open, and that it makes use of otherwise wasted
space in the title bar. You might set up the interface for a 12-inch normal aspect display laptop very differently
from that of a desktop unit with a 24-inch wide screen. m

FIGURE 2.9

There is also a Menu Bar Menu, which is hidden by default. The SolidWorks logo in the upper left
of the SolidWorks window or the small triangle next to the logo serve as a flyout to expand the
main SolidWorks menus. You can pin the menus in place using the pushpin shown at the right
end of the menus in Figure 2.9. When the menu is pinned, the toolbar moves to the right to
accommodate it.

The Menu Bar toolbar and menu
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Note

The 3Dcontrol menu entry is not part of base SolidWorks; it is part of the 3Dconnexion (spaceball) driver. m

Notice that on low resolution or non-maximized SolidWorks windows, you can run into some
space problems if the Menu Bar Menu is pinned open. The SolidWorks window in Figure 2.9 is
the SolidWorks 2010 interface with all default settings displayed at 1024 X 768 resolution, which
is a common resolution when using digital LCD projectors or small notebook computers. You need
to examine the changes in the SolidWorks interface with display size in mind. You might consider
having different sets of settings for using a laptop at a docking station with a large monitor, using
the laptop with a small monitor, or using the computer with a low-resolution digital projector.

Flyout toolbar buttons

SolidWorks has implemented flyout toolbars that save space by putting several related icons on a
flyout. For example, the Rectangle tool has several different ways to make a rectangle, with a tool
for each, and they are all on the rectangle flyout.

You can see all the available flyouts in the Customize menu (Tools &> Customize), under the
Commands tab, in the first listing in the window, Flyouts.

The purpose for flyouts is primarily to save toolbar space when several tools are closely related.
SolidWorks has set up flyouts in two configurations: fly-outs that always maintain the same image
for the front button (such as the Smart Dimension fly-out) and fly-outs that use the last used button.

Toolbar flyouts are listed in Tools= Customize= Commands and are listed from 2D to 3D through
the Weldments toolbar. After Weldments in the list, the fly-outs are Similar Function fly-outs. You
can change the order of the items in the flyouts by changing the order of the items in the toolbars.
Just display the original toolbar and choose Tools=> Customize to reorder it to your liking. These
toolbars will always have the same icon on the top. For example, if you use the Reference Geometry
flyout to access the Axis command, the image for the Plane icon will remain on top. The image on
top is considered the most commonly used function of that group of tools, and so remains on top.

Add-in flyouts, such as the FeatureWorks flyout, are controlled by that specific add-in and again
keep the same icon always on top.

The flyouts used for tools of similar function are split between using the most recently used tool
icon on top and keeping a consistent icon on top. The only tools that appear to follow the latest icon
method are the Sketch Entities tools. Sketch tools and other flyouts use a hard-coded top image.

Context toolbars

Context toolbars are toolbars that appear in the graphics window when you right-click or left-
click something. When you right-click, a context toolbar appears at the top of the RMB menu,
and shows the functions that SolidWorks deems the most commonly used functions. This is a
static list, and does not change as you use the buttons. These functions are removed from the
RMB menu and replaced with the Toolbar icon in a toolbar above the abbreviated RMB menu, as
Figure 2.10 shows.
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FIGURE 2.10

The right-click context toolbar
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An identical toolbar appears when you click an item on screen. When this toolbar appears with a
left-click, the rest of the RMB menu does not appear. Tool tips are available if you do not recognize
the icons on the toolbar.

For reference, the icons in the context toolbar atop the RMB menu (the icons without text) shown
in Figure 2.10 are in order from the upper-left: Edit Feature, Edit Sketch, Suppress, Rollback,
Select Other, Sketch, Hide Body, Zoom To Selection, Normal To, and Appearance Callout. Notice
that these selections do not reappear in the main RMB menu.

These context toolbars are not editable, but you can turn them off, and put the RMB menus back
to a familiar configuration. To deselect, click the context toolbar and choose Tools=> Customize.
Use the options on the right side of the main Toolbars tab, as shown in Figure 2.11.

I find that the RMB context toolbars are distracting because they force you to read a two-dimen-
sional list of icons and a one-dimensional list of text. To me, this is just too confusing. I turn these
off so that the RMB menus look like they always did.

However, I do find left-click context toolbars useful for things like Hide Sketch, Edit Feature, Edit
Sketch, Appearance Callout, sketch relations, and so on. When I use the RMB menus, I'm looking
for a more general function. When using the left-click context bars, I'm looking for something spe-
cific that T know is there. In Figure 2.11, the Show on selection check box option simply refers to
the left click toolbar, and Show in shortcut menu check box option refers to the RMB menu.
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FIGURE 2.1

Context toolbar settings

FIGURE 2.12
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The purpose of the context toolbars is to save space by condensing some commands into a toolbar
without text instead of a menu with icons and text. The left- and right-click toolbars are the same,
but they work differently. The left-click context toolbar fades as you move the cursor away from it
and becomes darker as you move the cursor toward it. Once it fades past a certain point, you can-
not get it back, except if you have Ctrl+selected multiple entities. The context toolbar does not
appear until you release the Ctrl key. To get a context menu to show up again after it has faded,
you can just move the cursor back to approximately where the toolbar would have been and press
Ctrl again. This works only for multiple selection menus where Ctrl was used to multi-select. The
functionality is probably a bug, or unintentional in any case, or else it would also work somehow
for single selections.

Shortcut “S” toolbar

The Shortcut toolbar is also known as the “S” toolbar because by default you access it by pressing
the S key. You can customize this toolbar for each document type and another for sketches, so it can
have different content for sketches, parts, assemblies, and drawings. To customize the “S” toolbar,
right-click it when it is active and click Customize from the RMB menu, as shown in Figure 2.12.

Right-click on the Shortcut “S” toolbar to customize it

B E 0 & |

L\r Customize... r

Many people claim to have customized the “S” toolbar to such an extent that they have been able
to remove the CommandManager and all other toolbars from their interface. This is possibly true if
you use a limited number of sketch entities, sketch relations, and feature types, or make extensive
use of flyouts on the “S” toolbar. However, if you work with a wide range of tools (say, surfacing,
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sheet metal, and plastic parts), you may need some additional toolbar space. It is completely
believable to have access to most of the software’s function with the “S” toolbar and either the
Menu Bar toolbar or the CommandManager. CommandManager by far gives you the most flexibil-
ity, but it also requires the most space.

The S key shortcut may conflict with another keyboard customization you have done, depending
on how your software was installed. To change the “S” toolbar key to another character or to reas-
sign it, follow the directions for creating and maintaining hotkeys later in this chapter in the section
on customization. It is referenced as the Shortcut Bar in the Keyboard list (Tools= Customize &
Keyboard).

Tool tips

Tool tips come in two varieties: large and small. Large tool tips show the name of the tool, along
with a brief description of what it does. Small tool tips show only the tool’s name. To change the
tool tip display from large to small, or to deselect the tool tip display altogether, choose Tools=>
Customize. The options for using large tool tips and showing tool tips appear in the upper-right
corner, as shown in Figure 2.11. In addition to the tool tip balloons, tips also appear in the status
bar at the bottom of the screen when the cursor is over an icon. Figure 2.13 shows a comparison
between large and small tool tips.

FIGURE 2.13

SolidWorks uses large tool tips by default.
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Note

The Customize option (Tools=> Customize) is inactive unless a SolidWorks document is open. To access the
Customize dialog box, first open a SolidWorks part, assembly, or drawing and then choose Tools~> Customize
from the menu. Customize is different from the Customize Menu option found in all SolidWorks menus. The
Customize Menu option is discussed later in this chapter. m

Managing toolbars

After all that, if you still feel you need to work with standard toolbars, it is easy to move, select and
deselect, and add icons to toolbars. It is important to remember that different document types
retain different toolbar settings; for example, the toolbars that you see with a part open are differ-
ent from the toolbars that you see for drawings.

When you are working on parts, it is important to have both the Sketch and the Features toolbars
active. When you are working on a drawing, you will never use the Features toolbar, but you will
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frequently use the Sketch toolbar. Likewise, for assemblies, you may want to display some addi-
tional toolbars and eliminate others. For this reason, when you change from a part document to a
drawing document, you may see your display adjust because the changing toolbars increase or
decrease the amount of space that is required.

Best Practice

It is best practice to set up the toolbars for each document type so that they take up the same amount of
space — for example, two rows on top and one column to the right. This way, changing between document
types is not so jarring, and the graphics area does not need to resize for each change. m

Moving toolbars

To move a toolbar, you can click with the cursor at the dotted bar on the left end of the toolbar, as
shown in Figure 2.14. The cursor changes to a four-way arrow and you can then drag the toolbar
where you want it. Toolbars dock either vertically or horizontally. You can resize undocked tool-
bars so that they have rows and columns. This arrangement is typically used with the Selection
Filter toolbar, which is often left undocked and compressed into a block that is three or four col-
umns wide.

FIGURE 2.14

Dotted bars enable you to move toolbars.
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If the SolidWorks window is not wide enough for the toolbar to fit entirely in the screen, double
arrows like those shown in Figure 2.15 appear at the end of the truncated toolbar. When you click
the double arrows, a flyout toolbar appears with the missing icons, as shown in Figure 2.16.

FIGURE 2.15

A truncated toolbar showing double arrows

FIGURE 2.16

You can display all of a truncated toolbar by clicking the double arrows.
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Flyout toolbars

You can use any toolbar as a flyout toolbar. Figure 2.17 shows the list of all flyout toolbars, which
is the same as the list of all toolbars. Flyout toolbars are a nice space-saving feature for tools that
you use infrequently, but frequently enough to want to avoid going through the menus. To use a
toolbar as a flyout, select it from the Flyout toolbars list and drag it onto an existing toolbar. It dis-
plays with an arrow to the right. Clicking the arrow causes all the tools to scroll out temporarily
until you click a toolbar icon or anything else.

FIGURE 2.17

The Flyout toolbars are on the Commands tab in the Customize dialog box.
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To add icons to a flyout toolbar, temporarily show the regular toolbar that corresponds to the fly-
out toolbar and add icons to the regular toolbar. When you are done adding or removing icons,
deselect the regular toolbar; the changes are applied to the flyout.
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Tip

If you want to create a separate toolbar, you can commandeer an existing one for your own purposes. For
example, because I do not use the Tools toolbar, | have removed all the regular icons from it and replaced
them with relevant flyout toolbars, which I do use extensively. This enables me to consolidate space, and not
have unused icons on my toolbars. Alternatively, creating a custom CommandManager tab and putting on it
what you like is much easier. m

Full Screen mode
Full Screen mode enables you to toggle quickly to the display so that only the graphics window
and the Task pane appear; the FeatureManager, menus, toolbars, and status bar are all hidden.

Alternatively, you can hide just the FeatureManager or the toolbars.

In Full Screen mode, you can still access the menus by clicking the cursor along the top border of
the window, as shown in Figure 2.18.

® To toggle to Full Screen mode, press the F11 key.

® To toggle the toolbar display, press the F10 key (see Figure 2.18).

® To toggle the FeatureManager display, press the FO key.

FIGURE 2.18

The SolidWorks window with all toolbars hidden using the F10 key
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Workflow customization

When you first install and run the SolidWorks software, the SolidWorks Welcome screen shown in
Figure 2.19 offers you the option to customize the interface using one of three preset option pack-
ages. Special menu and toolbar settings are made for Consumer product design, Machine design,
or Mold design. After the software is initially installed, you only see this screen once, but you can
change all the options in other places, including the Options tab in the Customize dialog box.

FIGURE 2.19

The Welcome to SolidWorks screen
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The three-workflow customizations affect the interface as follows:

e Consumer product design adds the Surfaces toolbar to the CommandManager.
® Machine design adds Sheet Metal and Weldments toolbars to the CommandManager.
® Mold design adds Surfaces and Mold Tools toolbars to the CommandManager.

Similar changes are made to the menus to hide or show menu selections as appropriate. You can
find more information about hiding and showing menu items later in this chapter.

If you want to select a different option after the initial setup, choose Tools&> Customize and click
the Options tab, where you can specify a different choice. Figure 2.20 shows the Options tab of the
Customize dialog box.
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FIGURE 2.20

The Options tab of the Customize dialog box, where you can select a different workflow customization
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Controlling menus

Everyone has his own style of working. For example, some people like to use menus and others do
not. Some like to use hotkeys and others like the mouse. Modify Section View is an example of a
tool that you cannot access via toolbars. It can only be accessed via the menus.

The most frequently used menu items are in the View, Insert, and Tools menus. All the menus shown
in this section have all the possible options selected. As a result, the View menu in Figure 2.21 may
contain options that are not available on your computer. Customizing menus is covered later in this
chapter. Figure 2.21 also shows the Insert and Tools menus, along with an image of a menu with the
Customize Menu mode activated.

You use the View menu primarily for turning on or off the visibility of entity types such as planes,
sketches, or temporary axes. You can also do this by using hotkeys or by putting extra items on the
View toolbar.

The Insert menu is used mostly for creating feature types for which you do not have a toolbar icon
on the screen. For example, although the Move Face tool is on the Mold Tools toolbar, it has many
uses aside from mold design. You can find the Move Face tool by choosing Insert = Face.

The Tools menu is used primarily for sketch entities or tools for which you have no icon on the
screen. Several other commonly used tools, such as Measure, Equations, Customize, and Options,
are also available in this menu.
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FIGURE 2.21

Popular menus
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Customize Menu

You can customize menus by adding or omitting items. By using the Customize Menu option at
the bottom of any menu — including shortcut (RMB) menus — you can remove items from any
menu by clearing the check boxes next to tools that you do not use. To bring back the removed
items, you can either go back to the Customize Menu or choose Tools &> Customize &> Options and
click the Reset to Defaults buttons for menu and shortcut customization.
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Interpreting SolidWorks use of
the word “shortcut”

Between the SolidWorks and Microsoft interfaces, the word shortcut is used in several overlapping and
confusing ways. Users replace most of the SolidWorks occurrences with words they use every day. The
following list describes where SolidWorks and Microsoft users might encounter the word shortcut as a
formal name for interface functionality, and how they might translate it.

® The Windows Shortcut link to another file or folder. Most users still refer to this link as a
shortcut or desktop shortcut.

o Shortcuts (as identified in the Help Index under Shortcut=>Keys) are either accelerator keys or
keyboard shortcuts. Users refer to accelerator keys as Alt-keys, and to keyboard shortcuts as
hotkeys.

® SolidWorks shortcut menus are commonly called the right mouse button (RMB) menus, and
have detached toolbars called context bars for both right- and left-click options. These are
commonly known as the RMB bar and the LMB bar.

® Shortcut Tabs (found as the “shortcut” entry in the SolidWorks Help Index). This presumably
refers to DriveWorksXpress functionality, although there is no direct mention of that in the
Help entry. DriveWorksXpress is beyond the scope of this book.

® Shortcut Bars are commonly known as the S key toolbar.

If you use the alternate terminology offered here, it will be clear to all users what you are talking about.

Note

Be careful not to confuse this Customize Menu selection with the Customize menu selection on the Tools
menu. Figure 2.21 shows the Tools menu being customized. In addition, | do not recommend removing items
from the menus. It doesn’t take much for someone to need one of those items and no one remembers that it
was supposed to be there or how to get it back.

The Options dialog box (Tools=> Customize &> Options), shown in Figure 2.20, contains the
Shortcut (RMB) menu and Menu customization options. These options enable you to show all the
menu items for both types of menus in a single stroke. By default, some items are hidden in vari-
ous menus. Keyboard customization is discussed later in this chapter. Keyboard shortcuts are gen-
erally referred to as hotkeys.

Changing cursors

SolidWorks cursors are context sensitive, and change their appearance and function depending
on the situation. Sketching cursors display a pencil and the type of sketch entity that you are
presently sketching. Sketch cursors also display some dimensional information about the entity
that you are sketching, such as its length or radius. Sketch cursor feedback is necessary for

fast and accurate sketching.
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Cross-Reference

To learn more about sketch cursor feedback, see Chapter 3. m

The Select cursor changes depending on the item over which you have positioned it. Cursor sym-

bols also help remind you when selection filters are active. The cursor is frequently available as an
OK button. For example, after selecting edges for a Fillet feature, the RMB functions as an OK but-
ton. Figure 2.22 shows various cursors and their significance.

FIGURE 2.22

Various SolidWorks cursors
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Working with models in the FeatureManager and
PropertyManager windows

The FeatureManager window is the panel to the left of the screen, which shows an ordered list of
features describing how the part was built. SolidWorks users spend a fair amount of time using the
FeatureManager to edit or inspect models. Figure 2.23 shows the FeatureManager for a simple
model.

Using the FeatureManager

There is a splitter bar at the top of the FeatureManager that enables you to split the
FeatureManager window into two windows, enabling you to display the FeatureManager and
another window, such as the PropertyManager (see Figure 2.24). Small arrows in the middle of the
right separator can collapse the FeatureManager to increase screen space. The F9 key also collapses
or opens the FeatureManager (refer to Figure 2.23.)

i

Display pane

You can open the Display pane flyout from the FeatureManager by using the double arrows at the
top-right corner of the FeatureManager. The Display pane helps you to visualize where appear-
ances, display styles, or hidden bodies have been applied in a part document and additional func-
tions in an assembly document. The display pane is helpful when you’re looking for colors that are
applied to the model at some level other than the part level.

i)
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Cross-Reference

Appearances are covered in more detail in Chapter 5. m

Rollback bar

The Rollback bar at the bottom of the FeatureManager enables you to see the part in various states
of history. Features can be added while the rollback bar is at any location. The model can also be
saved while rolled back.

FIGURE 2.23

The FeatureManager for a simple model
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FeatureManager filter

One of the most useful elements of the FeatureManager is the FeatureManager filter. The filter
resides at the top of the FeatureManager. If you type text in the filter, SolidWorks searches feature
names, descriptions, comments, tags, and dimension names for text matching the string, and only
shows matching features in the window. This also works in assemblies, where you can filter for
part names or document properties. The filter is very useful for quickly finding parts, features,
mates, or anything else that shows up in the part or assembly FeatureManager.

Using the PropertyManager

The PropertyManager is where you go to set most of the feature parameters, and where you edit
the properties of selected items such as sketch elements. You can manually switch to the Property-
Manager using the tabs on the top of the Display panel, or allow it to pop up automatically when
your input is needed. The leftmost tab in the row of icons is the FeatureManager tab, the second
from the left is the PropertyManager tab, the second from the right is the ConfigurationManager
tab, and the rightmost tab is the ToolAnalyst (available only in SolidWorks Premium). Other icons
may also appear in this area for drawings, or if you have add-ins such as PhotoWorks or
SolidWorks Simulation (formerly COSMOS) turned on. The ConfigurationManager tab appears
with more detail in Chapter 10.

One of the benefits of putting dialog boxes in the PropertyManager is that it saves a lot of space on
the screen. On the other hand, you will often need to make a selection from the FeatureManager at
the same time that the PropertyManager pops up and takes its place. You can disable this auto-
matic pop-up behavior by choosing Tools = Options &> System Options=> General and selecting the
Auto-show PropertyManager setting.

My favorite option for dealing with the PropertyManager is to detach it from the FeatureManager
so that you can see the two side by side instead of one or the other. To detach the
PropertyManager, drag its icon from the tabs out into the graphics area and release. Once the
PropertyManager is detached, you can move it to a second monitor, float it within the SolidWorks
window, or dock or reattach it. To put it back in its place under the FeatureManager, just drag it
back on top of the FeatureManager using one of the docking station symbols on the screen, allow
it to snap into place, and release it.

If you do not like the detachable PropertyManager, you can use the splitter bars either to put the
FeatureManager on top and the PropertyManager beneath, or use the flyout FeatureManager.
When creating or editing a feature, you can access the flyout FeatureManager by double-clicking
the name of the feature at the top of the PropertyManager. The flyout FeatureManager is displayed
just to the right of the regular FeatureManager, in the main graphics window, and is transparent to
enable you to see the model through it. The various ways of combining the FeatureManager and
PropertyManager are shown in Figure 2.24.
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FIGURE 2.24

The detached PropertyManager, the split FeatureManager, and the flyout FeatureManager.
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Getting around the Task pane

By default, the Task pane sits to the right of the SolidWorks screen, although you can undock it
entirely. If you want to keep it open, click the pushpin in the upper-right corner of the pane. The
Task pane is shown in Figure 2.25.

The Task pane is the home for several panels:
® SolidWorks Resources. These are useful links for templates, tutorials, tech support,

news, GlobalSpec search, Tip-of-the-Day, and other resources.

® Design Library. This includes locally stored libraries, Toolbox, and 3D Content Central.
This tab also contains “SolidWorks Content,” which consists of additional library
resources that can be downloaded directly from the Task Pane.

e File Explorer. This is a Windows Explorer interface that you can use to browse for files.

® SolidWorks Search. If you have installed the Windows Desktop Search with SolidWorks
2010 and indexed your files, you can perform searches that include filename and custom
properties.
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FIGURE 2.25

The Task pane
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® View Palette. This palette enables you to visually select views and drag them onto a draw-
ing sheet.

® RealView. This panel enables you to select appearances and scenes for your SolidWorks
documents.

e Custom Properties. The custom property tab in Task pane enables you to create a cus-
tom interface that goes inside this Task Pane tab that will help you enter custom property
data quickly, easily, and accurately.

® Recovered Documents. After a crash, auto recovered documents are listed in this special
purpose Task Pane tab.
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Getting familiar with the Status bar

The status bar is a non-intrusive way in which SolidWorks communicates information back to the
user. It is located at the bottom of the screen, and you can enable it from the View menu. Figure
2.26 shows the status bar in action.

The status bar showing a tool tip for the Sketch Circle tool
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The status bar can display the following information, indicators, and icons:

® Progress as parts, assemblies, or drawings load

® Tool tips for commands

® Measurements

® The sketch status for an active sketch

® In-context editing

® Suspend automatic rebuilds

® Icons that enable you to turn Quick Tips off or on
® The sheet scale for drawings

® The cursor position for drawings and sketches

® Whether you are editing the sheet, sheet format, or view of a drawing

Assigning tags

Tags work like document properties, except that they do not need a property name; they just use a
value. A tag could be considered simply a keyword that you can associate with a part in an assembly
or even a feature in a part. Tags can be searched by SolidWorks Explorer or by the FeatureManager
Filter. You can assign tags by clicking the yellow tag icon on the status bar in the lower-right corner
of the SolidWorks window. Figure 2.27 shows a tag being added to a feature.

Making use of Quick Tips

Quick Tips appear in the pop-up window in the lower-right corner of the graphics window. They
can change as you work so that they are sensitive to the context in which you are working. They
are a great way for new users or infrequent users to learn or be reminded of the next steps available
to them. You can activate and deactivate Quick Tips by clicking the question mark icon in the
lower-right corner of the SolidWorks window on the status bar. Figure 2.28 shows the Quick Tips
window in action.
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FIGURE 2.27
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FIGURE 2.28

Quick Tips in action
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Using the 2D Command Line Emulator

This is a tool specifically for people who are coming to SolidWorks from AutoCAD. As the name
suggests, it adds a command line to the bottom of the SolidWorks window that works like the
AutoCAD command line in most respects. The available commands are somewhat limited com-
pared to those that are available in AutoCAD. This tool only functions in the 2D sketch mode, on a
drawing sheet, or in a drawing view; it does not work in a 3D sketch. The 2D Command Line
Emulator is shown in Figure 2.29.
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FIGURE 2.29

The 2D Command Line Emulator in action
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Available sketch tools in the 2D Command Line Emulator include Align, Arc, Array, 'Cal, Chamfer,
Chprop, Circle, 'Color, Copy, DDcolor, Dim, Dist, Ellipse, Erase, Exit, Extrude, Fillet, 'Grid, Line,
List, Massprop, Mirror, Move, Offset, ’Ortho, 'Osnap, "Pan, Plot, Point, Polygon, Qsave, Rectangle,
"Redraw, 'Redrawall, Revolve, Rotate, Save, Saveas, Snap, Spline, Trim, U (undo), 'Units, "View,
and "Zoom. You can use commands preceded by an apostrophe () as transparent commands with-
out exiting an active command. Notice that even the cursor changes to crosshairs.

Best Practice

The best way to learn a new software package is to embrace the new way, not to cling to the old way.
Although AutoCAD users may find the 2D Command Line Emulator more comfortable to work with, you will
not achieve the same results, as you will with the SolidWorks default-sketching mode. For example, the result-
ing sketch entities created using the 2D Command Line Emulator are not constrained in any way, and the end-
points do not even merge. You can deselect the 2D Command Line Emulator by going to Tools=> Add-ins. m

Note

The 2D Command Line Emulator is not available on 64-bit computers. m

Making the Interface Work for You

As engineers and designers, we all like to tinker with things to optimize efficiency and to apply our
personal stamp. When the SolidWorks software is installed, the interface is functional, but not
optimal. In the previous pages, I have discussed managing and customizing toolbars and menus. In
the remainder of this chapter, I focus more on customizing the interface, and suggest some strate-
gies that you might use to help customize your work environment.

65



Part I: SolidWorks Basics

FIGURE 2.30

Customizing colors

You need to be aware of a few things before you change the standard colors in the SolidWorks
interface. The first is that SolidWorks does not automatically alter text color to contrast with your
background. As a result, if you set the background to black, and the text is black, you won’t be
able to see the text. This may seem obvious to some people, but AutoCAD automatically changes
text color to contrast with the viewport background, and so AutoCAD users may take this func-
tionality for granted.

Exploring default selection colors

All the interface colors are controlled in the Systems Options Colors dialog box. You can access the
dialog box by choosing Tools= Options= Colors. The selection color in particular is set at
Selected Item 1, as shown in Figure 2.30.
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Notice that you can set a color scheme. I recommend that if you want to change the colors used in
the interface, you save the settings as a color scheme so that the scheme can be re-created easily
later or handed off to another computer. Color schemes are stored in the Windows registry, not as
separate files. To transfer color settings to another computer, you will need to either use the Copy
Settings Wizard or manually copy data from the Windows registry.



Chapter 2: Navigating the SolidWorks Interface

Before making changes, you might consider saving your initial settings as a separate scheme so you
can get back to them if you need to.

Caution

Making changes to the Windows registry can adversely affect software installation and hardware performance.
You should not attempt changes to the registry unless you know exactly what you are doing. m

Selecting Background options wisely

You should avoid some colors for the background, or you should make some changes if you
choose these colors. Black is used with fully defined sketches, dimensions, FeatureManager text,
and annotations. Blue can mask the underdefined sketch color. Bright green (or blue, depending
on the version you are using) can cause problems with seeing selected items. Bright red, aside from
being a terrible color to stare at all day, also does not contrast well with some of the red highlights
and error colors.

You might think that no matter which color background you select, aside from the default, the
items or features are difficult to see. For this reason, many users choose a gradient background,
which enables them to pick colors where items are always visible on one-half of the screen or the
other. Staring at a white screen all day can be uncomfortable for your eyes, so pick colors that
enable you to see everything with “reasonable” contrast, yet are not glaringly bright. Very high con-
trast is hard on the eyes, and low contrast may make it difficult to distinguish items on the screen.

You have to consider what the purpose of the background is. Some people doing presentations
may want the background to be attractive while otherwise staying out of the way. Others may only
need the background to contrast with whatever is in front of it in a way that does not strain any-
one’s eyes. For writing a book, the background generally needs to be white to match the page. No
one scheme will suit all needs.

In addition to colors and gradients, you can use an image as the graphics window background.
This gives you a wider range of customization capabilities, and several sample images are already
available in the default settings. Also, be aware that document scene backgrounds are document
specific and override system options.

RealView also adds some capabilities with scenes. Scenes can be applied from the RealView tab on
the Task Pane. RealView offers three different types of scenes: Basic, Studio, and Presentation. Of
these, I find the Studio scenes to be the best when I need something with a reflective floor with
shadows, otherwise I stick with the Basic scenes. I describe RealView, along with scenes, in more
detail in Chapter 5.

Customizing strategies

You can easily customize many aspects of the SolidWorks interface, including:

® Toolbars
® Menus

® Background colors or images
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® PropertyManager skins
® Task pane location

® Hotkeys

® Macros

e Custom application programming

Whether or not you should customize each of the previous items depends partially on how much
time and energy you have to spend, as well as how much money you are ready to dedicate in the
case of custom programming.

Considering hotkey approaches

Some of us old-timers prefer to use the keyboard instead of the mouse. If your hand-eye coordination
is as bad as mine is, you may also choose this approach. I can type without looking at the keyboard,
but when I use the mouse, it takes me a few seconds to aim at an icon and hit it accurately. This
means that [ customize SolidWorks to use as many hotkeys as possible, and remove icons from the
interface if I have them on hotkeys. Unfortunately, my memory is as bad as my eyesight, and so
remembering 75 hotkey commands is a bit of a problem. I admit to having a printed list of hotkeys
taped to the side of my monitor. While I know that needing to read the list to find a particular hotkey
defeats most of the purpose of using them in the first place, I just accept it as a learning aid. This is a
self-solving problem, because the hotkeys that I use the most are the ones that I learn most quickly.

I generally do not advocate trying to standardize a hotkey scheme across multiple users, unless the
users all agree to it. The underlying reason for writing this section is that everyone remembers
things differently in the first place.

Any command that [ use more than a few times an hour is worth assigning to a hotkey. I like to
use alliteration when assigning keys to help with my faulty memory. The most frequently used
commands are assigned single-letter hotkeys, and the less frequently used commands are assigned
combinations. Thus, Tools Options is linked to O, Measure to M, Select Vertex to Shift+V, and
Curve Projected to Ctrl+] (Ctrl+P is the Windows standard for the Print command). Other people
like to group keys into easy-to-reach combinations; this is why the Q, W, A, S, Z, and X keys are
often assigned first for right-handed mouse users.

Organizing hotkeys

Hotkeys are assigned and organized in the Keyboard dialog box (Tools=> Customize &> Keyboard),
as shown in Figure 2.31. This interface enables you to see all the hotkeys (called shortcuts in the
list) easily. If you try to enter an existing hotkey, SolidWorks issues a prompt, telling you that the
key is assigned to another command and its name. The prompt asks you whether you want to clear
the other instance of the hotkey and make the new one active. You can also print out or copy to
the Clipboard a list of only commands that use hotkeys.

Because the list of commands is so long, a Search function is available, and a drop-down arrow
makes only the commands from a selected menu visible. The list of commands is organized by
menu name, and the menus are listed as they occur in the interface. Fortunately, on the Keyboard
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tab, SolidWorks enables you to sort, using the column headers to list the menus, commands, or
hotkeys in alphabetical order, simply by clicking the column header. This is a highly usable inter-
face, one of my favorite interface changes in the last several releases.

FIGURE 2.31

The Keyboard dialog box (Tools=> Customize => Keyboard) and the mouse gesture donut
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Using mouse gestures

Starting in SolidWorks 2010, you can now customize and use a mouse gesture interface, shown in
the second image of Figure 2.31. To make the interface appear, just drag the RMB slightly, about
14 inch. Once you get used to the interface, a drag of about 34 inch in a single motion will activate
the commands.

Note

I have found that this interface works best when you have memorized the commands available at various posi-
tions around the donut. m

You can establish the donut in four or eight segments; it comes set to four by default. You can also
do the customization in the Customize dialog box (Tools= Customize) using the Mouse Gestures
tab. The advantage of this interface is that it is very easy to invoke. I like the way you can use the
default setup to control views. The mouse moving in a particular direction is easily associated with
a view direction, so should be easy to remember.
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FIGURE 2.32

Mouse gestures will probably not replace hotkeys or the “S” toolbar, but they do add effective
quick access for a few functions.

Using the keyboard

Moving between the mouse and the keyboard can be bothersome and time-consuming. In addition
to the hotkey approach, you can use another keyboard method to save time. Many users become
adept at using the Alt-key combinations to invoke menu items. Most menu items in Windows
applications contain a single underlined letter.

To access a top-level menu, you can hold down the Alt key and press the underlined letter for that
menu, and then just press an underlined letter in the menu to access specific commands. This
technique enables you to navigate most of the interface without using the mouse. For example, to
exit SolidWorks, instead of using the mouse to click the red X in the upper-right corner, you could
press Alt+F, X. In Figure 2.32, you can see that the F in File is underlined, as is the X in Exit.

You may potentially run into conflicts when using Alt-keys. A combination of Alt + another key-
board key is a valid use of a hotkey combination. If you use any Alt hotkey combinations, it is
likely that you have seen a conflict like this. In cases of conflict, the hotkey combination seems to

gain priority over the Alt-key accelerator.
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Minimizing icons

In order to maximize valuable space on the monitor, many SolidWorks users strive to minimize
the number of toolbar icons on the screen, or confine them to two rows of toolbars. You can do
this by using the CommandManager, flyout toolbars, the “S” toolbar, right-click toolbars, and hot-
keys, and removing unused icons, as well as the other techniques discussed here.

Having an uncluttered workspace is definitely a plus, but having easy access to commands is the
real purpose of an interface in the first place. You need to strike a balance between too much
and not enough. The more kinds of work you do in SolidWorks, the more tools you will need to
have available. If you only create relatively simple machined parts and drawings, you will need
fewer tools available than someone who creates complex plastic part assemblies with rendering
and animation.

Contemplating device approaches

If you have never used a Spaceball or equivalent view-manipulation device, you should consider it.
They are wonderful devices and do far more than just spin the view. Most of the devices also have
several programmable buttons that you can link to menu items. They can move drawing views,
parts within assemblies, and even manipulate selected objects in other Office applications and Web
browsers.

Using touch and multi-touch support

I have written portions of this book on a Tablet PC. A tablet might not be ideal for long periods of
SolidWorks usage. However, I use it regularly for presentations and even modeling when I really
want to get the feel of drawing a line by hand. The stylus is not quite as intuitive as a pencil, but it
is less of an impediment to the tactile feel of actual drawings than a clunky mouse. Tablets are a
great option when used in combination with the new touch functions in SolidWorks, such as
mouse gestures.

The mouse gestures functionality is considered a tool well suited to a tablet interface, where flick-
ing the stylus is easier than mouse clicking. This is a single touch technique, since the stylus typi-
cally adds only a single point of contact with the screen.

Multi-touch devices are still rare, especially in the CAD-enabled office, but they are becoming more
widely available. In preparation for this future functionality that seems ideally suited to visual
applications such as CAD and 3D, SolidWorks has added functionality to take advantage of these
tools. Multi-touch Action Mappings, as the SolidWorks Help refers to them, are intuitive two fin-
ger motions that enable you to control the view for actions like:

® Zoom in or out

® Rotate

® Pan

e Roll

® Zoom to fit

® Right click

71



Part I: SolidWorks Basics

SolidWorks gave these special actions a new page in the Options dialog, shown in Figure 2.33.

FIGURE 2.33

SolidWorks special settings for multi-touch controls
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Accessing macros

Macros are short snippets of programming code that have a particular function. Most macros are
small and intended for simple tasks that are repeated many times, such as changing selected
dimensions to four decimal places or zooming the screen so that it is sized 1:1 (actual size). Macros
may be recorded, written from scratch, or a combination where you record a particular action for
use as a starting point and then embellish it manually from there. Recorded macros may not always
record the parts of the action that you want to make into a macro, but you can edit them manually
to include anything that you can program with VBA (Visual Basic for Applications), which is
included with the base SolidWorks package at no extra cost.

To access macros by using hotkeys, follow these steps:

. Make a folder in your SolidWorks installation directory called “macros.”

Copy macros into this folder.

Start (or restart) SolidWorks.

Choose Tools= Customize=> Keyboard.

g1 B W N =

Scroll to the bottom of the list under the Macros category and then assign hotkeys
as you would for standard SolidWorks commands.

Whether you are skilled at writing or recording macros, or you are just using macros collected
from other people, they can be huge time-savers and offer functionality that you would not other-
wise be able to access.
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Note

Saving custom interface settings

Once you have set up your menus and toolbars, worked out all of custom colors, figured out your
hotkey usage, and connected your macros, you don’t want to lose these settings when you reinstall
the software or move to a different computer. Another user may want to share your settings, or you
may want to transfer them to your home computer (for modeling the new deck or the doghouse,
of course). Fortunately, these settings are very portable.

You can use the Copy Settings Wizard to save these settings out to a file. Access the wizard by
choosing Start= Programs = SolidWorks 2010 = SolidWorks Tools= Copy Settings Wizard. This
creates a file with an * sldreg file extension. You can restore settings by double-clicking this file on
a computer that has SolidWorks installed on it.

You may need to have administrator access to your computer to apply a SolidWorks registry file. m

FIGURE 2.34

The SolidWorks settings are actually Windows registry settings. The file that is saved by the wizard
is just a registry file that has a different extension to prevent it from being applied too easily.
Saved-out Windows registry files have a *.reg file extension, and you can integrate them into the
registry by simply double-clicking them. If you are not familiar with the Windows registry, you
should not make direct changes, because even small changes can cause serious problems with your
operating system, installed software, or even hardware. The settings that are saved out by the Copy
Settings Wizard are safe to transfer between computers. In order for the Copy Settings Wizard to
work, you need to have Administrator-level access to your computer. The Copy Settings Wizard is
shown in Figure 2.34.

The Copy Settings Wizard

& SolidWorks Copy Settings Wizard

‘Walcoma to the Sclidwodks Copy Settings ‘Wizard

Thiz wizaed abows pou to save o restore customzation sattings for Sobdw/orks
tookbars, shortcuks, menus, and siclem preferences.

Choose which task vyou would ke to perfiom;

~ % Save Seitings -
i# J Save the Solidwiorks 2007 settings for matt to a file.

” oy Restore Settings -
J Restare Solidworks scttings fom a fle.
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Working with multiple document windows

You may sometimes have the luxury of working on a single part at a time, but more often, you will
find yourself with several documents open at once. This is a common situation for most users.
Fortunately, SolidWorks has several methods for dealing with “information overload,” to help you
sort through it all.

Managing windows
Like most Windows applications, SolidWorks can arrange the open document windows in one of
several ways that are available through the Window menu (see Figure 2.35):

® Cascade. Most useful for accessing documents that are to be edited one by one.
e Tile Horizontally. Most useful for wide and short parts.

e Tile Vertically. Most useful for tall, narrow parts, or documents where you want to com-
pare items in the FeatureManager.

® Arrange Icons. When windows are minimized to icons, this menu selection arranges the
icons neatly, starting in the lower-left corner of the window.

FIGURE 2.35

The Window menu
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Customize Menu

The images in Figure 2.36 are meant to show the arrangement of the windows, not the content of
the windows. Also, remember that you can use the F9 key to close the FeatureManager, the F10
key to remove the toolbars to create extra interface space when arranging several windows in the
graphics window, and the F11 key to remove portions of the interface and enable you to work full
screen.
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FIGURE 2.36

Window Arrangements: Cascade, Tile Horizontally,

and Tile Vertically
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Changing windows

You can use several techniques to change from one SolidWorks window to another. By clicking on
the Window menu, you can view a list of open document windows (refer to Figure 2.35). You can
then select the desired window directly from this menu. If more than a few windows are open, a
More Windows option appears at the end of the list, as shown in Figure 2.37. Clicking this option
brings up a separate window that enables you to select from the complete list. Press Ctrl+Tab to
open the Open Documents dialog box (see Figure 2.37). This enables you to select the document
visually that you want to open.

Additionally, by default the R hotkey opens the Recent Documents dialog box, similar to the
Recent Documents list in the File menu. This can also be accessed via the File menu if necessary.
The Recent Documents dialog box is shown in Figure 2.38.

FIGURE 2.37

The Open Documents dialog box
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The Recent Documents dialog box
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FIGURE 2.39

Getting to Know the Interface

By this point, you have learned quite a bit about all the tools involved in using the SolidWorks
interface. In this tutorial, you get some hands-on practice at manipulating the interface. This tuto-
rial is intended to reinforce the following skills:

Adding and removing toolbars

Adding and removing toolbar buttons

Adding and removing items from drop-down and RMB menus
Setting up the CommandManager

Setting up hotkeys

Linking a hotkey to a macro

Changing interface colors

Copying the existing settings
Regardless of what your initial settings are, you do not want to lose them. Before you start to make

changes to your system, you should save out the existing settings to a file from which they can be
recovered. You can do this using the Copy Settings Wizard, as shown in Figure 2.39.

The Copy Settings Wizard

7 SolidWork

Copy Settings Wizard

‘Walcoma to the Sclidwodks Copy Settings ‘Wizard

Thiz wizaed abows pou to save o restore customzation sattings for Sobdw/orks
tookbars, shortcuks, menus, and siclem preferences.

Choose which task vyou would ke to perfiom;

~ % Save Settings -
i# i J Save the Solidwiorks 2007 settings for matt to a file.
” oy Restore Settings -
J Restare Solidworks scttings fom a fle.

To use the Copy Settings Wizard, follow these steps:

1.

Close SolidWorks.

77



Part I: SolidWorks Basics

Choose Start= Programs=> SolidWorks 2010 = SolidWorks 2010 Tools=> Copy
Settings Wizard.

Select Save Settings, and click Next.
Enter a location and a name for the file.

Select the items that you would like to save. For the purposes of this tutorial, make
sure that the following options are selected: Keyboard Shortcuts, Menu Customization,
Toolbar Layout, and All Toolbars.

Click Finish. Browse to the location where you saved the file and make sure that it
is there.

Setting interface items to their default settings

You can set the interface back to the default settings using one of two methods. The first method,
editing the Windows registry, may not be available to all users. It requires Administrator access to
your computer and a good familiarity with Windows.

Caution
Editing the Windows registry can be dangerous if you make a mistake. Do not attempt this method is you have
any doubts about what you are doing. m
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To set SolidWorks back to its default settings by editing the Windows registry, follow these steps:

Ll A

Close SolidWorks.
Choose Start= Run.
Type regedit, and click OK.

Browse to HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2010 or
the appropriate folder for the version that you are using.

To return all settings in SolidWorks to default, rename the entire SolidWorks 2010
folder to include “(old)” at the end of the filename.

Close the Registry Editor.

The folder is re-created when SolidWorks starts up again, and is populated with
default values. If you need to get the previous folder back, you can delete the new one
and rename the old one to remove the “(old)” from the name.

The second method, which is less risky but less complete, is to go to the main settings locations
and use the tools provided to return settings to their defaults. Restart SolidWorks and create a
new blank document (you cannot display the Customize dialog box without a document open).
To access the resets for the interface, do the following:

1.

Choose Tools=> Options = General = Reset, and go to the bottom-left area of the
dialog box.
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Note

The menu reset is known to work improperly in version 2009 and prior. It is not clear if this will be fixed in the
2010 version. Fortunately, customizing menus is not a task you will frequently do, so resetting them to default
is something you will do even less frequently. m

FIGURE 2.40

4.

Choose Tools=> Customize = Toolbars = Reset, and go to the bottom-left area of the
dialog box.

Choose Tools > Customize ©> Menus = Reset All, and go to the right side of the
dialog box.

Choose Tools= Customize = Keyboard => Reset to Defaults, and go to the upper-
right area of the dialog box.

Choose Tools=> Customize = Options; there are three Reset to Defaults buttons
along the left side of the dialog box.

Customizing the CommandManager

Now that you have restored the default settings, you can begin customizing the interface with the
CommandManager. To do this, open a part document or create a new one, then click the RMB
anywhere on the CommandManager, and deselect the Use Large Buttons with Text option, as
shown in Figure 2.40. When you have done this, the check mark should no longer appear in front
of the option.

Deselect the Use Large Buttons with Text option

Ence
petry

Mobon | Matenals
Shudv

| # || CommandManager

. |F@I Use Large Buttons with Text ’ )

B ow>D

P | ape

——r———yr
e Bill of Ewploded Incta.

Next, add some toolbars to CommandManager, as follows:

RMB-click the CommandManager tabs and select Customize CommandManager.

Click (left-click) the New Tab icon at the right end of the CommandManager tabs
and select Surfaces, Sheet Metal, and Annotations. Deselect the Sketch tab by right-
clicking it and selecting Hide Tab. The new tab icon is shown in Figure 2.41.
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FIGURE 2.41

Adding tabs to the CommandManager
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In the Customize dialog box, select the Large Icons option.

Turn the Sketch toolbar on, but not inside the CommandManager; use the
Toolbars tab of the Customize dialog box. Dock the Sketch toolbar to the right side
of the window.

Select the Standard Views toolbar and drag it to the right end of the Command-
Manager. Now drag a couple of buttons off it, such as the bottom, or left, or back views.

On the Commands tab of the Customize dialog box, select the Flyout toolbars
entry, and drag any Flyout toolbars from the Customize dialog box to the Menu Bar
toolbar. Figure 2.42 shows this step in action.

FIGURE 2.42

Adding flyouts to the Menu Bar toolbar
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With the Commands tab of the Customize dialog box still active, click on the View
Category.

Add or remove tools until this toolbar has the tools you want to use on it. If you
want to deselect the Heads-UP View toolbar, activate the Toolbars tab in
Customize, and de-select the View (Heads-Up) option.
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9.

10.

11.

12.

Run your cursor over the main menu flyout and use the pushpin to pin the menu
open.

Choose Tools=> Customize &> Options and select both Show All buttons for Shortcut
customization and Menu customizations. This removes the double arrows at the bot-
toms of RMB menus. This setting is shown in Figure 2.43.

FIGURE 2.43

Removing truncated menus
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While still in the Customize dialog box, change to the Toolbars tab and deselect the
Context Toolbar Settings = Show In Shortcut Menu option to disable the right click
context toolbar to put the RMB menus back to their pre-2008 state (all entries in
menu use text).

Click and drag the PropertyManager tab (second tab from the left) from the
FeatureManager, and dock it just to the right of the FeatureManager under the
CommandManager tabs. The display should now look like Figure 2.44.

The small flyout in the lower-right corner of Figure 2.44 is the remainder of the Sketch toolbar
that does not fit on the screen. This screen shot was taken on a 12-inch monitor with large icons
at 1024 x 768 resolution. At such a low resolution, long toolbars do not fit on the screen, and
the remaining icons are activated by the two small arrows at the end of the toolbar.
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The customized SolidWorks interface
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Customizing menus

If you always do the same types of work, or more importantly, never do certain types of work, you
might consider customizing some menus to remove items that you never use. Customization
applies to both the main drop-down menus and the context-sensitive RMB menus. To customize a
menu, follow these steps:

1. Choose Insert= Customize Menu. Note that Customize Menu is different from
Customize.

2. Deselect the menu items Sketch from Drawing, DXF/DWG, Object, Hyperlink, and
Picture (see Figure 2.45). Click anywhere outside the list to close it.

Click on the Insert menu to ensure that the deselected items have been removed.

RMB-click the Right plane in the FeatureManager.
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Customizing the Insert menu
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5. Select Customize Menu.
6. Deselect Section View. Click anywhere outside the list to close it.

7. RMB-click the Right plane to verify that Section View has been removed.

Changing interface colors

This tutorial does not depend on RealView capabilities, but later work will. To find out whether
your computer is RealView capable, check your video card and driver version against the list on
the SolidWorks Web site. On the main page of the site, follow the link for Video Cards.

Before starting this tutorial, make sure the RealView icon is disabled. You can deselect RealView by
choosing View = Display &> RealView Graphics.

Cross-Reference

For more information on RealView graphics, see Chapter 5. m
Edit the colors used in the interface:

1. Choose Tools=> System Options=> Colors. Make sure the “Plain (Viewport Background
color above)” option is selected.
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Change the Viewport Background color, first in the Color Scheme Settings list, to a
light gray color, then click OK and make sure the setting was applied.

Return to the Colors dialog box by choosing Tools = System Options = Colors, click
the Save As Scheme button, and save the color scheme as Plain Gray.

Now select the Gradient option, and select the top and bottom gradient colors
(second and third in the top list). Click OK and see how you like the gradient display.
Adjust the colors until you are happy with them.

Return to the Colors dialog box by choosing Tools &> System Options = Colors, click
the Save As Scheme button, and save the color scheme as Gradient. Figure 2.46
shows the Colors dialog box.

Use the Current color scheme drop-down list at the top to change the color schemes
between the newly saved schemes.

FIGURE 2.46
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Adding hotkeys

For many users, hotkeys are an integral part of the everyday experience of using SolidWorks. You
can easily assign hotkeys and manage the assignments by following these steps:

gl Rk W=

° 2N

Choose Tools= Customize ©> Keyboard.

In the Search For text box, type Options.

Click in the Shortcut column, and type O.

Click again in the Search For text box, and type Customize.

Click in the text box next to the Tools=> Customize entry and press Ctrl+C. Click
No to the question of whether you want to reassign the hotkey. Press Ctrl+T instead.

Click OK to exit the Customize dialog box.

Press the O key to open the Options tab. Click OK to exit.

Press Ctrl+T to open the Customize dialog box. Click OK to exit.
Press Alt+F, and then click the Close button to exit SolidWorks.

Combining macros with hotkeys

The following steps show you how to link a macro to a hotkey:

On the CD-ROM

You can use the macro called rectangle.swp, located on the CD-ROM. m

1.

S NS R

Find your SolidWorks installation directory. By default, this directory is C: \Program
Files\SolidWorks.

Create a folder called Macros in the SolidWorks directory and put the rectangle.
SWp macro in it.

Open SolidWorks.

Create a new blank part document.

Press Ctrl+T to access the Customize dialog box.
Click the Keyboard tab.

In the Search For text box, type rectangle.

Click in the Shortcut column next to the listing with the Category of Macros, and
press R.

Click OK to exit the Customize dialog box.
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10. Press R. The rectangle macro runs and draws a sketch rectangle on the Front plane, cen-
tered on the origin.

11. Press Ctrl+S to access the Windows standard hotkey for the Save command. Name
the part rectangle.sldprt and save it to a workspace directory.

12. Press Alt+F and then click Close to exit SolidWorks.

The use of Alt-keys and hotkeys is somewhat exaggerated in this tutorial, but it is intended to get
you used to working with them.

Summary

The SolidWorks interface has many elements because SolidWorks has so much functionality. You
can access most elements multiple ways, which can be liberating because it offers options, but it
also can add to the confusion because there is so much to know. You do not need to know every
way to do everything; you only need to know the best way for you. After using this book to find
the various ways of using the interface, you can develop the way that is most comfortable for you
and stick with it.

Be aware that every couple of releases, SolidWorks changes the interface, and often, they use the
most radical options available as the new defaults. Keep a copy of your settings file with you, so
you can restore settings or take your settings to another computer quickly if you need to re-set up.



Working with
Sketches

setup, which is necessary but mundane business. In this chapter, you

begin to learn how to control parametric relationships in sketches.
Then in later chapters, you begin to build models, simple at first, but gaining
in complexity and always demonstrating new techniques and features that
build your modeling vocabulary. Beyond this, you will move into putting the
parts together into assemblies. Finally, you use the parts and assemblies to
create drawings.

S o far, in this book, you have looked mainly at concepts, settings, and

This chapter deals mainly with sketches in parts. However, you will be able
to apply many of the topics I cover here to assemblies. Some related topics,
such as layout sketches, have functionality that is exclusive to assemblies and
are covered in the assemblies’ chapter.

Cross-Reference
I discuss 3D sketches in detail in Chapter 31. m

When you open a sketch, several tools become available, specifically all the
sketch entities and tools. Conversely, you cannot do several things until you
open a sketch. For example, you cannot apply a Fillet feature while a sketch
is open. Open sketches and selection filters are two very common sources of
frustration for new users. Several indicators exist to let you know when you
are in Sketch mode:

® The title bar of the SolidWorks window displays the text Sketch X
of Part Y.

® The lower-right corner of the status bar displays the text Editing
Sketch X.

® The Confirmation Corner displays a sketch icon in the upper-right
corner of the graphics window.
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® The Sketch toolbar button displays the text Exit Sketch.
® The red sketch Origin displays.
e Ifyou are using the grid, it displays only in Sketch mode.
While most users find the sketch grid annoying or distracting, when teaching, I've always used the

grid to remind students when they are in Sketch mode. If you forget or would like a visual cue, the
sketch grid is a useful option.

Opening a Sketch

Sketches must be either open or closed, and you can only have one sketch open at a time.
SolidWorks uses many indicators to show the state of a sketch, including the Confirmation Corner
and the Task Bar.

Several methods exist to open new sketches in SolidWorks:
e (lick a sketch entity toolbar button {rom the Sketch toolbar; SolidWorks prompts you to
select a sketch plane. When you select the plane, the sketch opens.

® Preselect a plane or planar face and then click either a sketch entity button or the Sketch
button.

® Use the left mouse button to click context toolbar — click a face or plane and select the
Sketch icon.

® Use the right mouse button (RMB) to click a plane or planar face and select Insert Sketch.
Planes can be selected from either the graphics window or the FeatureManager.

You can open existing sketches several ways:

e Right-click a sketch in the FeatureManager or graphics window, and select Edit Sketch.

® Select a sketch from the FeatureManager or graphics window, and click the Sketch button
on the Sketch toolbar.

e [eft-click a sketch or feature and click the Edit Sketch icon from the context toolbar.

® Double-click a sketch with the Instant 3D tool active.

Identifying Sketch Entities

The first step in creating most SolidWorks patrts is a sketch. This will usually be a 2D sketch,
although you can also use 3D sketches. A 2D sketch is simply a collection of 2D lines, arcs, and
other elements that lie together on a plane; it usually also contains relations and/or dimensions
between the entities so that the sketch can automatically adjust to changes because each sketch
entity understands its function.
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Tip

SolidWorks sketch entities include many types, some of which you will use all the time, and some
of which you may not use, even if you spend years working with the software. Next, I identify each
entity type. This enables you to see it at least once and know that it is available if you need it at
some point.

The Sketch toolbar

In the following section, I first identify the default buttons on the Sketch toolbar, followed by the
rest of the entities that you can access by choosing Tools=> Customize & Commands=> Sketch.

Sketch opens and closes sketches. You may notice that the name of the button changes depending
on if the sketch is open or closed. If you preselect a plane or planar face and then click the Sketch
button, SolidWorks opens a new sketch on the plane or face. If you preselect a sketch before click-
ing the Sketch button, SolidWorks opens this sketch. If you preselect an edge or curve feature
before clicking the Sketch button, SolidWorks automatically makes a plane perpendicular to the
nearest end of the curve from the location you picked. If you do not use preselection, and only
click the Sketch tool with nothing selected, SolidWorks prompts you to select a plane or planar
face on which you want to put a new sketch, or an existing sketch to edit.

3D Sketch opens and closes 3D sketches with no preselection required. 3D sketch is covered in
more detail in Chapter 31.

Smart Dimension can create all types of dimensions used in SolidWorks, such as horizontal, verti-
cal, aligned, radial, diameter, angle, and arc length. You can create dimensions several ways, as
shown in Figure 3.1:

® By selecting a line and placing the dimension

® By selecting the endpoints of the line and placing the dimension

® By selecting a line and a point and placing the dimension

® By selecting a pair of parallel lines and placing the dimension
Selecting the line is the easiest and fastest method. Selecting parallel lines on the ends is not rec-

ommended because if you delete either of the selected lines, the dimension is also deleted; how-
ever, sometimes this method is necessary.

You can use the first and second techniques for the angled line shown in Figure 3.1 to create any
of the three dimensions shown. To accomplish this task, drag the cursor while placing the dimen-
sion until the witness lines snap to the orientation you want.

To lock the orientation of a dimension while moving the cursor to place the actual dimension value, click the
RMB. To unlock it, click the RMB again. The RMB cursor appears as a lock when the functionality is unavail-
able and an unlock icon when it is. m
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The third technique locks you into the horizontal orientation because of the orientation of the
selected lines.

FIGURE 3.1

Selection options for linear Smart Dimension

Dimension value Drop-down arrow
250 T o
!
v X 82
1.30 0K Spin wheel
Cancel Spin arrows
Rebuild/ Mark for import
No exit
3 Increment value
Change sense
Note

In some situations, you may run into lines that appear to be parallel but are not exactly so. This will result in an
angle dimension instead of a linear dimension. Here, you can select one of the lines and one endpoint.
SolidWorks requires parallelism be precise, and situations where lines aren’t exactly parallel happen if the
angular measurement is off in the second or third decimal place, measuring in degrees. Imported 2D drawings
and reverse engineered 3D models can be particularly susceptible to this type of error. m

Caution

When you select lines to establish a dimension instead of endpoints, both of the lines gain an implied parallel
relation that prevents them from moving as you might predict. In the example shown in Figure 3.1, neither of
the end lines can be angled unless you remove the dimension.

Another issue with adding dimensions to lines is that if you delete either line, the dimension is also deleted.
This is not true for the first and second techniques, where as long as the endpoints remain, the dimension
remains. m

You can change Smart Dimension values several ways. The most direct way is to simply key in a
value such as 4.052. The software assumes document units unless you key in something specific.
You could also key in an expression, even with mixed units, such as 8.5 mm/2+.125 or 25.4+.625
in. You can also key in negative dimensions, which function the same as the Change Sense button
in the Modify box.
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Another way to put a value into the Modify box is to click the down arrow to the right of the value
field, and select either to use an equation to calculate a value or a Link Value. A Link Value is like a
variable name to which you can assign a value. You can link multiple dimension values to that
Link Value. In sheet metal parts, the default Link Value of Thickness is used; if you change the
thickness in one feature, it changes for all the sheet metal features.

To the right of the drop-down arrow is a pair of up and down “spin” arrows that enable you to
change the value in the Modify box by a set increment amount. You set the increment in Tools=>

Options= System Options = Spin Box Increments. You can also store multiple increment values
within the Increment Value icon on the Modify box.

The final way to change the value in the Modify box is by using the wheel underneath the value
field. The wheel uses the default increment value. Pressing Ctrl while using the wheel multiplies
the increment by ten, and pressing Alt while using the wheel divides the increment by ten.

Here is a look at the Dimension Properties interface.

e Radial. You create the dimension by selecting an arc and placing the dimension. If you
want a radial dimension of a complete circle, you must right-click the dimension after you
create it, select Display Options, and select the Display as Radius/Display as Diameter tog-
gle, as shown in Figure 3.2. Alternatively, you could use the Radius or Diameter leader
display options on the Leaders tab of the Dimension PropertyManager.

FIGURE 3.2

The Dimension Properties interface
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® Diameter. You can create the dimension by selecting a complete circle and placing the
dimension. If you want a diameter dimension for an arc, use the RMB menu or Dimension
Properties dialog box and select the Diameter Dimension option.

Note

Along with the Radial and Diameter dimensions, you may also want to dimension between arcs or circles,
from tangent or nearest points. To do this, press the Shift key and select the Smart Dimension tool to select
the arcs near the tangent points. Alternatively, to change a dimension from a center-to-center dimension to
a max-to-max dimension, you can drag dimension attachment points to tangent points or use the dimension
properties. m

® Angle. You can create the angle dimension one of two ways. If the angle to be driven is
between two straight lines, simply select the two straight lines and place the dimension. If
you are creating an included angle dimension for an arc where there are not necessarily
any straight lines drawn, then with the Smart Dimension tool active, first select the vertex
of the angle, and then the two outlying points, as shown in Figure 3.3.

FIGURE 3.3

Creating an included angle dimension

Order

unimportant

e —Click first

® Arc Length. You can create the dimension by selecting an arc and its endpoints with the
Smart Dimension tool.

\ Line creates straight lines using one of two methods:

® Click+Click. Used for drawing multiple connected end-to-end lines. Click and release the
left-mouse button to start the line; each click and release ends the previous line and starts
a new one. Double-click, press Esc, or deselect the Line tool to end.

® C(lick and Drag. Used to draw individual or unconnected lines. Click, drag, and drop.
The first click initiates the line, and the drop ends it.
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Note

The click+click and click and drag methods have been treated equivalently by SolidWorks until recent releases.

Some new functions like Enable on-screen numeric input seem to function better with click+click than click
and drag. m

Alternate methods for drawing lines include horizontal, vertical, angle, and infinite lines. The inter-
face for these options appears in the PropertyManager, as shown in Figure 3.4.

® Horizontal, Vertical. These settings require you to select a starting point and an ending

vertical or horizontal position. There does not seem to be any compelling reason to use
this instead of the regular line command.

Angle. This setting enables you to specify an angle and drag a line at this angle. Again, I
can find no compelling reason to use this tool.

Infinite length. SolidWorks parts have a working space limited to 1000 meters on a side,
centered on the Origin. Infinite lines extend well beyond this, although you cannot draw

or dimension a regular line outside of this box. I have not come across a compelling use
for this feature.

FIGURE 3.4

The Insert Line PropertyManager interface
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Note

The Add Dimensions option exists in several sketch entity PropertyManagers and adds Smart Dimensions to

newly sketched entities. The option only appears in the sketch entity PropertyManager if the setting at Tools=>
Options= Sketch=>Enable on-screen numeric input on entity creation is selected.

The on-screen numeric input is not the same as the Input Dimension Value function, and, in fact, it overrides
that option. You cannot input dimension values when using the Add Dimensions in conjunction with click and

drag sketching. It appears to be intended for click+click drawing only, so that you can enter values between
clicks. m
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[j Corner Rectangle creates a rectangle by clicking one corner and dragging to the diagonal corner.
This action creates four lines with Horizontal and Vertical sketch relations, as appropriate. The
Corner Rectangle is also available as a flyout icon with a Corner Rectangle, Center Rectangle, 3
Point Corner Rectangle (rectangle at an angle), and 3 Point Center Rectangle, as well as a
Parallelogram. Figure 3.5 shows the flyout and flyout icons, and the PropertyManager for the
Rectangle, which also enables you to switch types of rectangle easily.

FIGURE 3.5

The Rectangle flyout with associated icons
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Notice the Add dimensions check box in the PropertyManager. Selecting this box while creating a
rectangle causes the software to add dimensions aligned with the sides of the rectangle. This option
is also available for lines, arcs, and circles.

Note that if you use this option in conjunction with the Enable on-screen numeric input on entity
creation setting, found at Tools= Options = Sketch, it makes creating sketch entities to the correct
size immediately much easier.

C) Circle creates a circle using one of two methods, which are available from either the flyout icon or
the Circle PropertyManager:

® Center Creation. Click the center of the circle and drag the radius. The Circle
PropertyManager calls this function center creation.

® Perimeter Creation. To create a circle using this technique, you must select the Perimeter
Creation option from the Circle PropertyManager window after clicking the Circle tool.
There is also a separate Perimeter Creation toolbar button and a menu selection for
Toolsw Sketch Entities = Perimeter Circle. This only creates tangent relations with other
entities in the current sketch; if you are building a circle from model edges or entities in
other sketches, you need to apply the relations manually. SolidWorks calls these functions
perimeter creation.
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Tangent to Two Entities. Start the circle with the cursor near one line in the sketch.
A Tangent symbol appears by the cursor with a yellow background. Click and drag
the diameter to the second tangent entity, where a similar cursor symbol should
appear. Release the mouse button and right-click the green check mark icon. This
process is shown in Figure 3.6.

Tangent to Three Entities. Use the same process for Tangent to two entities, but
omit the right-click of the green check mark icon. After dropping on the second tan-
gent, drag again to the third tangent entity.

FIGURE 3.6

Creating a perimeter creation circle
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nqwb Centerpoint Arc creates an arc by clicking the center, dragging the radius, and then clicking and

E

dragging the included angle of the arc. The first two steps are exactly like the Center-Radius circle.

Tangent Arc creates an arc tangent to an existing sketch entity. Depending on how you move the
cursor away {rom the end of the existing sketch entity, the arc can be tangent, reverse tangent, or
perpendicular, as shown in Figure 3.7.

Another way to create a tangent arc (called autotransitioning) is to start drawing a line from the
end of another sketch entity, and while holding the left mouse button, press the A key; or return
the cursor to the starting point and drag it out again. This second method can be difficult to mas-
ter, but it saves time compared to any of the techniques for switching sketch tools.
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FIGURE 3.7

Using the Tangent Arc feature
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e 3 Point Arc creates an arc by first establishing endpoints, and then establishing the included arc, as
shown in Figure 3.8. Again, this tool also works using the click+click or click and drag methods.

FIGURE 3.8

Creating a three point arc
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j Sketch Fillet creates a sketch fillet in one of two ways. Either you can select the endpoint where the
sketch entities intersect, or you can select the entities themselves, selecting the portion of the entity
that you want to keep. Figure 3.9 illustrates both techniques.

The Sketch Chamfer tool is on the same flyout as the Sketch Fillet by default. Sketch Chamfer does
not have a list selection box the way that fillet does, and does not use a preview like the fillet.
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Sketch fillets

While the Sketch Fillet tool is easy to use and may align with your way of working in a 2D program, it
is not considered best practice to use sketch fillets extensively. Some reasons for this include:

® Large changes in the size or shape of the rest of the sketch can make the fillets result in the
feature built from the sketch to fail.

® SolidWorks (and other parametric programs as well) often has difficulty solving tangent arcs
in some situations. You may see fillets flip tangency or go around 270° instead of just 90°.
Using many fillets in a sketch can often cause trouble.

o If you want to remove the fillets temporarily, there is no good way to do this if you have used
sketch fillets.

® Sometimes feature order requires that other features, such as draft, come before the fillet,
which is difficult to do if they are part of the sketch.

® Sometimes a 2D fillet simply cannot create the required 3D geometry.

Fillet features are the preferred method for creating rounds and fillets. The same can be said for cham-

fers. Still, sometimes you need to use tangent arcs in sketches. You will have to decide which way
works best for you.

FIGURE 3.9

Creating a sketch fillet
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! Centerline follows the same methods as regular lines and is called a construction line in some cases.
Other construction entities, such as construction circles, are not available directly, but you can cre-
ate them by selecting the For Construction option in the PropertyManager for any entity.

r\J Spline draws a freeform curve. Splines may form either a single closed loop or an open loop. In
either case, the spline is not allowed to cross itself. You can draw a spline by clicking each location
where you want to add a control point. Figure 3.10 identifies the elements of a spline. The detail
image shows the structure of a spline handle.
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The structure of a spline and spline handles
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Control polygon  Inflection point Combination (direction and magnitude)

Magnitude handle  Direction handle

Spline points Maximum radius

Splines are used mainly for freeform complex shapes in 2D and 3D sketches, although you can also
use them for anything in which you would use other sketch elements. If you need more informa-
tion on splines and complex shape modeling, refer to the SolidWorks Surfacing and Complex Shape
Modeling Bible (Wiley, 2008).

Point creates a sketch point. Aside from limited cases of lofting to a point or using a point as a con-
straint sketch in a Fill feature, sketch points are usually used for reference or for the location of the
centerpoint of Hole Wizard features.

You can also use the sketch point as a virtual sharp. If two sketch entities do not actually intersect
because of a fillet or chamfer, selecting the two entities and clicking the Point tool creates a point at
the location where they would intersect if they were extended. This is useful for dimensioning to
the sharp. Virtual sharp display is controlled by a Document Property setting.

3D Sketch Plane creates a plane in a 3D Sketch. I discuss 3D Sketches in more detail in Chapter
31. By sketching on planes within a 3D sketch, you get most of the benefits and usage of 2D
sketches, and you do not have to deal with history between sketches. Before committing too much
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©

AN

Note

work to this course, you should look into some of the shortcomings of 3D Planes. The planes are
treated just like another entity in the 3D sketch, which means you can assign sketch relations to
them, but it also means that they can move around within the sketch like sketch entities.

Add Relation displays a PropertyManager window that enables you to apply sketch relations. This
interface appears to be obsolete because it is easier to simply select sketch items and apply relations
via the context toolbar or in the PropertyManager window that appears automatically when you
select them; however, there are some subtle workflow-related reasons for using this tool.

Two advantages exist to using the Add Relations dialog box over simply selecting sketch entities
and adding relations. When the Add Relation PropertyManager is active, you do not need to use
the Ctrl key to select multiple entities. You also do not need to clear a selection before making a
new selection for the next relation. These two reasons sound minor, but if you have a large number
of sketch relations to apply, the workflow goes much more smoothly using this tool than the
default method.

Display/Delete Relations enables you to look through the relations in a sketch, and sort them
according to several categories. From this window, you can delete or suppress relations and replace
entities in relations.

Quick Snaps flyout enables you to quickly filter types of entities that sketch elements will snap to
when you move or create them. To access the tools, click the drop-down arrow to the right of the
toolbar button.

Mirror Entities mirrors selected sketch entities about a single selected centerline, and applies a
Symmetric sketch relation. In addition, a Dynamic Mirror function is described later in this chapter.

PropertyManagers for sketch tools such as Mirror, Convert, Fillet, and Intersection Curve now include a selec-
tion box for the entities to be used in the operation. The Offset PropertyManager is one that is conspicuously
missing this functionality. m

Q

Convert Entities convert edges, curves, and sketch elements from other sketches into entities in the
current sketch. When edges are not parallel to the sketch plane, the Convert Entities feature proj-
ects them into the sketch plane. Some elements may be impossible to convert, such as a helix,
which would produce a projection that overlaps itself. Sketch entities created using Convert
Entities get an On Edge sketch relation.

Offset Entities works like the Convert Entities feature, except that it offsets the sketch to one side
or the other of the projection of the original edge, sketch, or curve. Figure 3.11 shows the interface
for this command.
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FIGURE 3.1

The Offset Entities interface
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The options available in the Offset Entities interface are as follows:

® Add dimensions. Constrains offset sketch entities. Instead of the On Edge relations,
Offset Entities creates an Offset sketch relation that cannot be re-created manually.

® Reverse. Changes the direction of the offset.
® Select chain. Selects continuous end-to-end sketch entities.
e Bi-directional. Offsets to both sides simultaneously.

® Make base construction. If you are offsetting sketch entities within the active sketch, this
option converts the original sketch entities to construction sketch geometry.

e Cap ends. Is available only when you have selected the Bi-directional option. Capping the
ends with arcs is an easy way to create a slot from a sketch of the centerline. This function
works with all sketch entities; it is not limited to straight slots. Figure 3.12 shows exam-
ples of the Cap ends option.

Caution

The Offset Entities command may fail if the offset distance is greater than the smallest radius of curvature, and
you are attempting to offset to the inside of the arc. m

In addition to the bi-directional offset with capped ends, SolidWorks also has slot sketch entities
for straight and curved slots, which are covered later in this chapter. Composite slots (made of a
combination of straight and curved sections) still require the offset method.

3_.lr=_ Trim is actually several functions rolled into one, and it is an extremely powerful tool for editing
sketches. Trim Entities allows several methods for trimming, as well as extending and deleting
sketch entities. Figure 3.13 shows the PropertyManager interface for this function.
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FIGURE 3.12

The results of using offset entities cap ends

FIGURE 3.13

The Trim interface
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Power trim. Trims by dragging a cursor trail over multiple entities. The entities that you

drag the cursor over are trimmed back to the next intersecting sketch entity. Each time
you trim an entity, a red box remains until you trim the next entity. If you backtrack with
the cursor and touch the red box, this trim is undone. This option is best used when you
need to trim a large number of entities that are easy to hit with a moving cursor. Figure

3.14 shows the Power Trim feature in action.
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You can also use power trim to extend sketch entities along their paths by dragging the
endpoints. Regular dragging can also change the position or orientation of the rest of the
entity, but by using the Power trim feature, you affect only the length.

FIGURE 3.14

The Power trim feature in action

1

e Corner. Trims or extends two selected entities to their next intersection. When you use
the Corner option to trim, the selected portion of the sketch entities is kept, and anything
on the other side of the corner is discarded. Figure 3.15 shows two ways that the Corner
option can work.

FIGURE 3.15

Using the Corner option

A T

® Trim away inside. Trims away selected entities inside a selected boundary. The boundary
may consist of a pair of sketch entities or a model face (edges of the face are used as the
boundary). Only entities that cross both selected boundaries (or cross the closed loop of
the face boundary twice) can be trimmed. This option does not trim a closed loop such as
a circle, ellipse, or closed spline.
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® Trim away outside. Functions exactly like the Trim away inside option, except that
sketch entities outside of the boundary are discarded. The Trim away inside and Trim
away outside options are illustrated in Figure 3.16.

FIGURE 3.16

Using the Trim away inside and Trim away outside options

7%

® Trim to closest. This is the default setting. Clicking a sketch entity will:

e Trim it back to the next entity if there is only one crossing entity.
® Trim between two crossing entities if there is more than one.
® Delete the entity if there are no crossing entities.

In all cases, the selected section of the entity is removed. The Trim to closest option can
also extend when you drag one entity to another; if an intersection is possible, the first
entity is extended to the second entity. Figure 3.17 illustrates how the Trim to closest
option functions.

FIGURE 3.17

Using Trim to closest to extend
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|2; Construction Geometry toggles between regular sketch entities and construction entities.
Y Construction sketch entities are not used to create solid or surface faces directly; they are only used
for reference —for example, revolve centerlines, extrude and pattern directions, and so forth. Be

careful with the icon for this function, because it looks almost identical to the No Solve Move icon,
especially as printed here in gray scale.

Note

The icons for Hide/Show Edges, No Solve Move, and Construction Geometry look substantially similar, and in
this black and white book, they may be indistinguishable. m

D The Stretch sketch tool is intended for use in sketches where there are enough dimensions to make
= a particular change difficult by changing dimensions only. It is similar in purpose and use to the
AutoCAD Stretch function because it was loosely modeled after the AutoCAD functionality. Stretch

enables you to specify a change that will change several dimensions simultaneously. Figure 3.18
shows the initial, intermediate, and final states of the sketch being stretched.

FIGURE 3.18

Using the Stretch sketch tool
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Tip

The main ideas to remember with the Stretch tool are that it is used to stretch dimensioned lines, and that you
need to select the lines that will lengthen or shorten as well as the lines that will move. Because if this, select-
ing entities for Stretch is best done with the right-to-left window selection, which also selects any items that
the selection box crosses. (Left-to-right window selection only selects items that are completely within the
selection box.) m

Caution

Figure 3.18 shows the X/Y option being used, but if you use the From/To option, be aware that it may delete
some sketch relations along the way. m

The Move, Rotate, Copy, and Scale sketch tools operate on selections within a sketch. You can use
these tools with pre- or post-selection methods. These tools delete existing sketch relations when
necessary to accomplish the task. For example, if you want to move a rectangle connected to the
origin, the Move tool will delete the Coincident relation between the sketch endpoint and the ori-
gin. If you want to rotate a rectangle, the Rotate tool will delete all the horizontal and vertical rela-
tions on the entities being rotated. This operation may result in a completely underdefined sketch.
SolidWorks does not warn you that sketch relations are being deleted.

If you use the Scale tool on a fully defined sketch, SolidWorks will scale the position of the selected
entities, deleting sketch relations if necessary to do so, but no dimensions will be scaled or deleted.

Caution

Be careful when using these sketch tools. They can delete sketch relations without warning. m

N

These sketch tools were originally put in the software to avoid some of the complexities and limita-
tions of the Modify Sketch tool, which can also move, copy, rotate, and scale sketches. Figure 3.19
shows the simple interface for the Move Entities command. Select the entities to move in the upper
box and the method to move them below.

Select is usually used to turn off the previous command.

ﬁ Grid/Snap is used to open the Grid/Snap section of Tools= Options & Document Properties.

a

Parallelogram can be used in two different ways:

® To draw a rectangle at an angle, click one corner of the rectangle, and then drag a side
connected to that corner. Then click and drag the length of the second direction.

® To draw a parallelogram (adjacent sides are not perpendicular, but opposite sides are
parallel), draw the first side of the parallelogram in the same way as the first side of the
rectangle, but hold down the Ctrl key when dragging the second side; you can set the
angle as well as the length.
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FIGURE 3.19

The Move Entities interface
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G} Polygon creates a regular n-sided polygon in the same way as a circle. Click the center and drag the
radius. You need to set the number of sides in the PropertyManager before clicking in the graphics
window.

Ellipse is created by clicking the center, dragging one axis, and then dragging the other axis.

Partial Ellipse is created by clicking the center, dragging one axis, dragging the other axis, and then
clicking and dragging the included angle of the partial ellipse. The Partial Ellipse feature works like
the Centerpoint Arc command.

dQ

U Parabola is created by clicking the location for the Focus, and then dragging the position of the
Apex. You then click and drag the included angle of the parabola, as shown in Figure 3.20. This is
a rarely used sketch entity and is often difficult to control with sketch relations or dimensions.

Note

The Parabola is the closest thing SolidWorks has to the conic sketch type found in other popular CAD pack-
ages. Few people use the Parabola in SolidWorks. The next closest to the conic is the Partial Ellipse, then the
three-point spline. m

a Spline on Surface is used in 3D sketches to draw a freeform spline on any 3D surface. The Spline
on Surface feature can cross face boundaries as long as the faces are at least tangent (ideally curva-
ture continuous) across the edge. Spline on Surface can be used to trim surfaces or create split
lines.
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Drawing a parabola
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,ﬁ.‘% Sketch Text creates editable text in sketches using TrueType fonts installed in your Fonts folder.
Some fonts produce sketches that are unusable for solid features, due to violating sketch rules with
overlapping or zero thickness. You need to be careful which fonts you select, but I have had suc-
cess with a wide variety of fonts I have found on the Internet. Sketch Text may be dissolved into
lines and arcs so that you can edit them manually. Dissolve is available on the RMB menu. Figure
3.21 points out the key elements of the Sketch Text interface.

Note

Note that the Link To Property icon enables you to link sketch text to a custom property, or a configuration spe-
cific custom property. Using configurations and properties to drive sketch text can be a valuable function. m

% Intersection Curve, in 2D sketches, creates sketch entities where the sketch plane intersects
selected faces. In 3D sketches, the Intersection Curve sketch tool creates sketch entities where any
types of selected faces intersect. This can be an extremely useful tool in many situations.

@ Face Curves applies the underlying U-V isoparameter mesh to a selected face. It is most commonly
used as an evaluation tool for complex surfaces, but you can also use it to create curves to rebuild
faces. Accepting the results by clicking OK creates a separate 3D sketch for each spline. Figure
3.22 shows the original surface and the results of using face curves on a complex lofted surface.
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The Sketch Text interface
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FIGURE 3.22

Using face curves on a complex surface

~T  Extend extends a sketch entity up to its next intersection with another sketch entity. This is not to
""" be confused with the Extend for surface entities.
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A Split Entities splits a sketch entity into two segments. You can also delete it later to rejoin the
entity back into a single segment. Closed loop entities require at least two split points.

2 Dynamic Mirror can be used when you pre-select a centerline and Dynamic Mirror is turned on.
Any new sketch entity that you draw is automatically mirrored to the other side of the centerline.
The ends of the mirror line have hatch marks on them to remind you that you have mirroring
turned on.

Linear Pattern creates a one- or two-directional pattern of sketch entities. You can define spacing
and angles. Figure 3.23 shows the interface and the results of this function.

a%5 Circular Sketch Pattern creates a circular pattern of sketch entities.
2

FIGURE 3.23

The Linear Pattern interface
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Best Practice

You should use sketch patterns as little as possible. For many of the same reasons that fillet features are pre-
ferred over sketch fillets, pattern features are preferred over sketch patterns. Sketch patterns are not as edit-
able or as flexible as feature patterns. They solve slowly, especially when you pattern many entities. Best
practice is to avoid sketch patterns unless there is no alternative. m

a3 Make Path is intended to help create machine-design motion in sketches, in particular, cam type
motion. Although it is helpful, you do not need to make a block of the cam first. You can then
right-click the block and select Make Path. A tangent relation to a path enables a follower to roll
around the entire perimeter.

Modify Sketch is one of my favorite sketch tools, but it has been falling out of favor in more recent
versions of SolidWorks because of the improvements to tools such as Move Sketch. The Modify
Sketch feature is flexible and powerful, and enables you to move, rotate, and scale the sketch, as
well as mirror about a horizontal or vertical axis or about both axes simultaneously. Figure 3.24
shows the interface, which consists of a dialog box, a special Origin, and a context-sensitive cursor.

The Modify Sketch interface

- ]

Modify Sketch [
Scale About
@ Sketch origin Fadlor: I.
Moveable origin 1
Translate Rotate
X value ¥value
0.00deg
0.000in 0.000in I:z
Position selected point Llose

Both the left and right mouse buttons have special functions, which change when the cursor is
moved over the three knots on the special Modify Sketch Origin. The RMB enables you to mirror
or rotate the sketch, and the left mouse button (LMB), enables you to move the Origin or move the
sketch.

This function has some limitations when you use it with sketches that have external relations.
Certain functions may be disabled or a warning message may appear, saying that you need to
remove external relations to get a particular function to work correctly.

—i No Solve Move enables the moving of sketch entities without solving any relations in the sketch. If
you select this option and you move an entity with relations that would otherwise not allow it to
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move (such as a collinear relation), you are prompted with a choice to delete the existing relation
and continue or copy the entity without the relation. As mentioned earlier, be careful with the icon
for this function because it looks almost identical to the Construction Geometry icon, especially as
printed here in gray scale.

@ Sketch Picture is a picture that is placed in the sketch, lies on the sketch plane, and is listed in the
FeatureManager indented under the sketch. The Sketch Picture may be suppressed independently
from the rest of the sketch, and when the sketch is hidden, the picture is not visible. You can easily
move, resize, and rotate Sketch Pictures, as well as apply a transparent background color to them.
Sketch Pictures are usually used for tracing over or as a planar decal without the need for
PhotoWorks. Figure 3.25 shows the controls for manipulating the Sketch Picture feature.

FIGURE 3.25

The Sketch Picture interface
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r\i Equation Driven Curve is a sketch spline driven by either an explicit or parametric equation, as
shown in Figure 3.26. An explicit equation is in the form y = f(x), while a parametric equation uses
multiple equations driven by a common parameter value of the form, such as

x = cos(t)
y = sin(t)
0>t>pi

where t is a number in radians.
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The result is a proportional spline in a sketch, not a curve feature as the name suggests. New in
SolidWorks 2010 is the capability to drag the spline itself or its endpoints in 2D or 3D and
SolidWorks calculates the new transformation. Previous versions of this function required you to
key in deltas for positional and rotational transforms, but 2010 does not allow this, you can only
drag, apply sketch relations and dimensions.

FIGURE 3.26

The Equation Driven Curve PropertyManager
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If you start an Equation Driven Curve in a 2D sketch, you get the form for a 2D curve equation. If
you start in a 3D sketch, you get the form for a 3D curve. Once these splines are created, you can-

not remove the relation to the equation and manually edit the spline; they are tied to the equation
until you delete the entire spline.

One way to get around this limitation would be to create an equation driven curve in one sketch,
and then open another sketch and use convert entities to copy the spline, delete the On Edge rela-
tion, and use Simplify Spline to add control points to it. This is a technique commonly used with
other types of curves; it does not enable you to update the overall size or shape of the spline
through the equation, but you can manually adjust sections of a curve originally created from
equations. Examples of where this might be useful would be a lead in or lead out on a cut thread, a

special attachment loop in the middle of a spring, or a flare around the edge of a lens or reflector
dish for mounting.
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Straight Slot and Curved Slot draw slots of a given width and length with full rounds on the ends.
All the slot sketch entities can be seen in the PropertyManager shown in Figure 3.27. If you need
to draw a composite slot or a slot with multiple entities, you will need to use the bi-directional

sketch offset with capped ends mentioned earlier.

FIGURE 3.27

PropertyManager for the slot sketch entities
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The Dimensions/Relations toolbar

The Dimensions/Relations toolbar has a few tools that you have already seen, but as the name sug-
gests, it also contains tools that will either help you to create or investigate dimensions and sketch
relations. Figure 3.28 shows the default toolbar, but in the following pages, you look at all the
available tools you can see at Tools=> Customize &> Commands=> Dimensions/Relations.

FIGURE 3.28

The Dimensions/Relations toolbar

Dimensions/Relations
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0 ® Smart Dimension. Lets you dimension the sketch entity as you sketch.

[ ® Horizontal Dimension. Applies a dimension to a sketch entity that drives the horizontal

— distance between the endpoints.
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|:I ® Vertical Dimension. Works like a horizontal dimension but vertically.

I:;bl ® Baseline Dimensions. Creates dimensions only in drawing documents. Baseline

= Dimensions are different from most of the dimension tools that you find on the
Dimensions/Relations toolbar in that they can create driven dimensions on view geometry
or driving dimensions on sketch geometry in a drawing, but cannot be used on sketch
geometry in parts. Baseline Dimensions start from a single reference; then as you select
additional references, additional dimensions are stacked (see Figure 3.29).

FIGURE 3.29

Baseline Dimensions on a drawing
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\{&q} ® Ordinate Dimensions. Drives dimensions where a set of ordinate dimensions originate
from a common zero point. To use these dimensions, simply click a zero location, place
the zero dimension, and then click additional points. The dimensions are placed and are
automatically aligned to the rest of the dimensions.

Note

If a line is not selected as the zero reference entity, the Ordinate Dimension feature defaults to a Horizontal
Ordinate. m

You can remove Ordinate Dimensions from the common alignment by right-clicking the dimension
and selecting Break Alignment. Ordinate Dimensions will jog automatically if SolidWorks senses the
dimensions are getting too close to one another. You can also jog them manually. After you create
the Ordinate Dimension set, you can add to it by accessing the Add to Ordinate command through
the RMB menu. All the options for Ordinate Dimensions are shown in Figure 3.30.

Not all the listed options are available in the model sketch environment; some are available only in
drawings.
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FIGURE 3.30

Options for Ordinate Dimensions
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iij Horizontal and Vertical Ordinate Dimensions have the same function as the regular Ordinate
=

—, Dimensions, except that they only drive horizontal and vertical dimensions, respectively.

-{ Chamfer Dimension is another type of dimension that is only driven and only applied in drawing
documents. It works by first selecting the chamfered edge and then selecting the angle reference
edge. It produces dimensions like the one shown in Figure 3.31.

FIGURE 3.31

Applying a chamfer dimension

Select second
|
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Select first

ﬁ Automatic Relations toggles to enable or disable the automatic creation of sketch relations while
sketching. This toggle is also available through Tools=> Sketch Settings=> Automatic Relations.
Automatic relations help you to create intelligent sketches with less manual intervention. Although
using them takes a little practice, it is well worth the effort.

Caution

As with any automatic function, there are times when automatic relations will do things that you do not expect
or want. While you are sketching, it is recommended that you watch the cursor and the relations that it auto-

matically applies. m
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FIGURE 3.32

While sketching, symbols appear on the cursor to show that a relation will automatically be cre-
ated. These symbols have a yellow background and will apply horizontal, vertical, coincident, tan-
gent, parallel, and perpendicular relations. Figure 3.32 shows two situations where automatic
relations are applied — a horizontal and a tangent relation.

Some automatic relations that appear on the cursor

116

203, 1807 R

’%— %&

Inferencing in Sketch

Although SolidWorks users (even experienced ones) often confuse Inferencing and Automatic
Relations, these functions are not the same. Inferencing refers to the blue dotted lines that display in
Sketch mode when the cursor aligns with endpoints, centerpoints, or the Origin. Inferencing does
not create sketch relations, with one exception. If both ends of a line pick up the same inference to
the same point, SolidWorks will add that inference as an automatic relation.

When the cursor displays a small sketch relation symbol with a yellow background, this means
that an automatic relation is going to be applied. If the relation symbol has a white background,
the relation is inferenced, but not applied as an actual sketch relation. The symbols with the blue
(the color may also be green in SolidWorks 2008 or later) background are relations that have been
applied to existing sketch entities. The symbols look the same, regardless of background color. Be
aware that differences in versions and differences in color schemes can cause these colors to be dif-
ferent on your system.

Table 3.1 shows the symbols for the various inferences, automatic relation cursors, and applied
sketch relations. The difference between the three types is simply the background colors: white,
yellow, and blue, respectively.
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TABLE 3.1

Fully Define Sketch

Symbols
" Along X 4 Along Y 2 Along Z
— 4
. At Intersection of Two . Coincident . Collinear
Faces
. Concentric . Coradial . Equal
. Equal Curvature . Fix . Horizontal
. Intersection - Midpoint II“ Offset
. On Edge . On Surface . Parallel
Perpendicular . Pierce . Symmetric
=]
Tangent Vertical Display/Delete
.- . ﬁﬁ Relations

The Fully Define Sketch interface uses sketch relations and dimensions to fully define the active
sketch. It enables you to select which types of sketch relations and dimensions will be used to do
this. Figure 3.33 shows the Fully Define Sketch interface. Be careful of this icon because it looks

almost identical to the Sketch icon.

If you are familiar with older versions, the Fully Define Sketch function was formerly called Auto
Dimension and has absorbed the functionality of Scan Equal and Add Relations. This function is
very useful when used with imported sketch data. If you do not like the automatic dimensioning

scheme, you can at least take advantage of the automatic sketch relations.

Best Practice
While the Fully Define Sketch function can clearly save you many time dimensioning parts on a drawing, it
does not necessarily use the best dimensioning practice for manufacturing drawings or for design intent. This
tool is best used in situations when baseline and ordinate dimensions are appropriate. m
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FIGURE 3.33

The Fully Define Sketch interface

118

Dimensions &

Horizental Dimensions Scheme:

|1

Entitics to Fully Define A
(&) Al entities in sketch
(O Selected entitics Vertical Dimencions Scheme:
Caleulate Hassline V
1] Relations & GI g asilid
Selact Relations to Apply: Dimension placement:

() Above sketch

[pessiact Al (%) Below sketch
E| |’I [Z| @ E| () Right of sketch
— — (%) Left of sket
ZREOE e

Exploring Sketch Settings

In addition to sketch tools, another important aspect of controlling sketches is sketch settings.
Sketch settings are found in two different locations. The first location is at Tools= Options =
Sketch. In this chapter, I cover the settings found at the second location, Toolst Sketch Settings.
These settings mainly affect sketch relations.

Automatic Solve is turned on by default. As you make changes to a sketch by adding relations or
changing dimensions, SolidWorks automatically and immediately updates the sketch to reflect the
changes. When the Automatic Solve setting is turned off, these changes are deferred until you exit
the sketch or turn the Automatic Solve setting back on. The setting can be useful to prevent inter-
mediate solutions (for example, when half of the changes are made) that may cause problems with
the sketch, and when you are confident that the outcome will be correct. It is a rarely used option,
and you could probably exist just fine without even knowing this option was there at all.

If you import a large drawing from the DXF or DWG format, these drawings import as sketch enti-
ties into either a SolidWorks sketch or a drawing. SolidWorks may automatically turn off the
Automatic Solve setting for performance (speed) reasons on files of this type.

Enable Snapping is turned on by default. It enables the cursor to snap to the endpoints of existing
sketch entities to help you make cleaner sketches. When you turn this setting off, Automatic
Relations is also disabled (although the icon for the setting remains depressed, Automatic Relations
are not created). Holding down the Ctrl key while sketching disables snapping. Holding down the
Ctrl key while dragging sketch entities functions such as copying sketch geometry. The No Solve
Move is discussed in the Sketch toolbar section.
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Detach Segment on Drag is turned off by default. When you turn this setting on, the Detach
Segment on Drag feature enables you to pull a single sketch element away from a chain of ele-
ments. For example, if you had a rectangle and you wanted to detach one of the lines from the rest
of the rectangle without using this setting, you would have to draw extra geometry and then trim
and delete lines in order to release the endpoints.

Best Practice

It is recommended that you leave Detach Segment on Drag off. Turn it on only when you need it, and then
immediately turn it off again. This setting can be hazardous for everyday use, because it enables you to simply
drag sketch elements that may be otherwise fully defined.m

Override Dims on Drag is off by default. When you turn this setting on, it enables you to drag fully
defined sketch geometry, and the dimensions will update to match the dragged size. This is
another setting that you should use sparingly. It can be useful for doing concept work, but you
should leave it off when working with production data for obvious reasons.

Note

Combining Override Dims on Drag with Instant3D (formerly Move/Size Features) can be very handy for con-
cept work, enabling you to drag model faces and edge easily.m

Using Sketch Blocks

Sketch blocks are collections of sketch entities that can be treated as a single entity, and can be
reused within a single document or shared between documents. You can use sketch blocks in
parts, assemblies, and drawings. To create a sketch block, select a group of sketch entities and click
the Make Block button on the Blocks toolbar, or select Tools=> Blocks = Make. Pre-selection is not
necessary, you can also select the entities after you invoke the command.

Blocks may be internal to a particular document, or they may be saved as an external file. The
externally saved block may be linked to each document where it is used, so that if the block is
changed, it updates in the documents where it is used.

You can use blocks in conjunction with the Make Path function mentioned earlier in this chapter
to create functional layouts for mechanisms. You can also use blocks in an assembly to build parts
in-context. Refer to Chapter 12 for a more in-depth examination of the assemblies aspects of
blocks in SolidWorks.

The following is a description of the various tools that are available on the Blocks toolbar:

:- ® Make Block. Creates a sketch block from selected sketch entities. You can position a
manipulator to denote the insertion point for the block. Blocks may attach at any entity
endpoint, but the insertion point follows the cursor.
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R B

=

=

FIGURE 3.34

Edit Block. Enables you to edit an existing block as if it were a regular sketch.

Insert Block. Enables you to select from a list of open blocks or browse to a location
where blocks are stored. You can edit the insertion point by using the Edit Block function.

Add/Remove. Enables you to add or remove sketch entities from the block without delet-
ing them from the sketch while editing a block.

Rebuild Block. Allows changes to a block to be reflected in any external relations without
exiting the block. For example, if you have a block in a sketch and a sketch line is coinci-
dent to one of the endpoints in the block, you may edit the block such that the referenced
endpoint moves. As a result, the line in the sketch will not move until you exit the block
or use the Rebuild Block function.

Save Block/Save Sketch As Block. Saves a selected block to an external file (with the
* sldblk extension), or saves the selected sketch as a block.

Explode Block. Removes all the sketch entities from a block and brings them into the
current sketch.

Belt/Chain. Enables you to make a belt or chain around a set of pulleys. Each pulley must
be a block. After activating the command (by right-clicking on a sketch or block), you can
select each pulley and use the arrow on the pulley to switch the side of the pulley to
which the belt goes. You can also compensate for the thickness of the belt (this is impor-
tant when both sides of the belt are in contact with pulleys) and drive the pulley arrange-
ment using the length of the belt. Figure 3.34 shows the Belt/Chain dialog box.

The Belt/Chain dialog box

Beit/ Chain
v R
Message #

belt will pass

Delt Hembers
i)

o

Flip belt side

] =] (=]

o
[+
=1
-]
e
N 5

Driving

[CJuse beit thickness

[#]Engage beit

Select the orde o arc Lo defie
belt members around which the

B [arc1Biock 1-1

120



Chapter 3: Working with Sketches

Working with Reference Geometry

Reference geometry in SolidWorks is used to help establish locations for geometry that you can’t
physically touch, such as planes, axes, coordinate systems, and points. You often use reference
geometry to establish a characteristic of the finished solid model before the model is created or to
include an item that you may want to mate another part to in an assembly later. Mate References
are also classified as Reference Geometry, although I do not cover them until Chapter 19, in the
course of discussing library parts.

The importance of working with reference geometry becomes obvious in situations where you
need to create geometry that doesn’t line up with the standard planes. You might use planes to rep-
resent faces and axes to represent the centers of holes. Axes are often used to establish a direction,
such as in plastic parts where, because of draft, you never truly have any vertical edges; an axis is
frequently used to establish the direction of pull for the mold.

Coordinate systems come in handy, especially when translating a part from one system to another
for the purpose of machining or some type of analysis. SolidWorks users usually model in such a
way that the modeling work is made simpler by the choice of how the part origin is positioned rel-
ative to features of the part, but rapid prototyping, machining, mold building, and sheet metal
manufacturing applications may have different requirements. As a part modeler, you cannot
account for the needs of all downstream applications with your initial choice of origin placement,
but you can always create a reference coordinate system for those downstream applications to use.

Creating planes

Planes are the most commonly used type of reference geometry because they are used for sketching,
cutting, as extrude end conditions, and more. The Plane feature PropertyManager and functionality
has changed significantly in SolidWorks 2010. With the new interface, shown in Figure 3.35, you
start by selecting model items (faces, edges, points, vertices, or other sketch or reference geometry)
that you want to use to create the plane. The new plane uses constraints like sketch relations from
the selected references. For example, in Figure 3.35, the new plane is tangent to the selected First
Reference cylindrical face and at an angle to the selected Second Reference of a plane.

The good news about this method is that there are far more options for creating planes than in the
previous method, but the bad news is that going into the feature, you may not know all the avail-
able options. You have to make a selection before it shows you the available constraints. The older
interface presented the available options right up front, but there were fewer to choose from.
Hopefully this interface matures in the future. Meanwhile, you may need to experiment to see what
works best for the type of modeling you do.
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FIGURE 3.35

Creating a new plane from a set of selections and constraints
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Note

When you start using the new Plane functionality, it may be best to try to ignore the new interface and simply
make the same types of selections that you made in the past. The new Plane functionality will work perfectly
that way. As of this writing, there is not a lot of common user experience with the tool and its available func-
tionality is completely undocumented. m

Working with axes

., Axes are less popular than planes, but equally important. You can use axes to create pivot points in
a part where you do not have any hole type geometry for mating with other parts. Axes are used to
establish direction frequently. Figure 3.36 shows that the first three features in a plastic part are
axes established from the standard planes.

Consider using axes set up in this way as standard features in your template files. They can be

effective in assemblies for moving parts in orthogonal directions and in parts for pattern or draft
directions.
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Note

The interface for the Axis feature has not been changed to match the Plane interface as of pre-release
SolidWorks 2010. Notice that the methods for creating an axis are spelled out clearly in the interface itself. I
expect to see a change to Axis to make it match the Plane interface. m

FIGURE 3.36

Using axes to establish direction
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Using coordinate systems

J—t Coordinate Systems in SolidWorks are primarily used for import and export, but can also be used
for mating, mass properties, and other purposes. Coordinate Systems are usually located by a point
to determine location or a set of edges to determine direction. Figure 3.37 shows the
PropertyManager for assigning a coordinate system, along with the Export Options dialog box,
which you can access from the Save As dialog box when the Files of Type drop down is set to an
export format.

To use the coordinate system when saving as a translated file type such as IGES or Parasolid, click
the Options button, as shown in Figure 3.37; at the bottom of the Export Options dialog box, a
selection box for Output coordinate system appears.

To use the coordinate system with mass properties, choose Tools= Mass Properties from the
menu, and then select the Output coordinate system, as shown in Figure 3.38.
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FIGURE 3.37

Use Coordinate Systems to export parts and assemblies with a new origin location.
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Using points as reference geometry

The Point reference geometry feature is infrequently used; however for some uses there is nothing

else that does the job quite as well. Figure 3.39 shows the PropertyManager for reference geometry
Point feature.

FIGURE 3.39

The Point reference geometry feature has several modes of point creation you won’t find elsewhere.
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My favorite Point placement method is the Along Curve Distance option (the bottom one in
Figure 3.39). It enables you to create several regularly spaced points along a curve.

Tutorial: Learning to Use Sketch Relations

While it is useful to read through the definitions and functions of all the sketch entities, tools, and
relations, using your mouse to create is what this is all about. This tutorial makes sure that you get
to know all the major functions in SolidWorks sketches. Almost every part that you build will start
with a sketch, so this is a skill worth mastering. Follow these steps to learn about sketch relations:

On the CD-ROM

The BibleInchTemplate.prtdot template used in this tutorial is in the Chapter 3 folder on the CD-ROM. m

1. Open a new part using a template that you set up in the Template tutorial from
Chapter 1. If you do not have this template, there is one provided for you on the
CD-ROM named BibleInchTemplate.prtdot. Copy it to your templates folder and
use it to create a new part. You may also use a SolidWorks default template.

2.

Select the Front plane in the FeatureManager, and click the Sketch button on the
Sketch toolbar. Click the Line tool from the Sketch toolbar.
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Move the cursor near the Origin; the yellow Coincident symbol appears.

Draw a line horizontal from the Origin. Remember that there are two ways to sketch
the line: Click+click or click and drag. Make sure that the line snaps to the horizontal and
that there is a yellow Horizontal relation symbol. The PropertyManager for the line
should show that the line has a Horizontal relation. Also notice that the line is black, but
the free endpoint is blue (after you hit Esc twice to clear the tool, then clear the selec-
tion). This means that the line is fully defined except for its length. You can test this by
dragging the blue endpoint.

Click the Smart Dimension tool on the Sketch toolbar, use it to click the line that
you just drew, and place the dimension. If you are prompted for a dimension, type
1.000. If not, then double-click the dimension; the Modify dialog box appears, enabling
you to change the dimension. The setting to prompt for a dimension is found at Tools=>
Options=> General, Input Dimension Value.

Draw two more lines to create a right triangle to look like Figure 3.40. If the sketch
relations symbols do not show in the display, turn them on by clicking View &> Sketch
Relations. You may want to set up a hotkey for this, because having sketch relations is
useful, but often gets in the way. Note that the sketch relation symbols may also be green,
depending on how your software is installed.

FIGURE 3.40

Draw a right triangle.

1
L.

Drag the blue endpoint of the triangle. Dragging endpoints is the most direct way to
change the geometry. Dragging the line directly may also work, but this sometimes pro-
duces odd results. The sketch leaves a ghost when dragging so that you can see where
you started. Note that the setting for leaving a ghost when dragging a sketch is found at
Tools= Options &> Sketch, Ghost Image On Drag,

Click the Smart Dimension tool, and then click the horizontal line and the angled
line. This produces an angle dimension. Place the angle dimension and give it a value
of 30°.

Click the Sketch Fillet tool, set the radius value to 0.10 inches, and click each of the
three endpoints. Where the 1.000-inch dimension connects to the sketch, SolidWorks
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10.

11.

has created virtual sharps. Figure 3.41 shows the sketch at this point. You may now want
to turn off the Sketch Relations display because the screen is getting pretty busy. You can
find this setting at View = Sketch Relations.

FIGURE 3.41

The resulting sketch after you perform Step 9

20.0C¢

Draw a line starting from the midpoint of the angled line. The midpoint should high-
light when you move the cursor close to it. Draw the line perpendicular to the angled
line. A dotted yellow line appears, showing where the perpendicular lies. When you fol-
low this line, the yellow perpendicular symbol appears on the cursor. Make this line
approximately .25 inches long. Feedback on the cursor also shows the length of the line
as you draw it.

Draw two more lines ending at the endpoint of the sketch fillet, as shown in Figure
3.42. Use the Inferencing lines to line up the second angled line with the end of the arc.

The resulting sketch after you perform Step 11

1.000
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12. Click the Trim tool from the Sketch toolbar. Make sure that the Trim option is set to
Closest. Click the angled line of the triangle between the two lines sketched in Step 11.
This trims out that section and makes the sketch a single closed loop. A warning may
appear because you have a Midpoint relation to the line being trimmed; you no longer
want this relation, but you want the lines to intersect at their endpoints. Select Yes at the
prompt.

13. Click the Smart Dimension tool. Use it to create aligned dimensions on the short line
(.25 inches) and one of the long lines (.125 inches). You may now want to reorganize
some of the dimensions if the display is becoming crowded.

14. At this point, two of the lines should be blue, but it may not be clear why they are
not defined. Select one of the blue lines and drag it. Notice that what changes is the arc
nearest the Origin. This changes in a way that is not useful for this part. To lock this line
where it needs to be, select the blue line nearest the Origin and the centerpoint of the arc
nearest the Origin, and give them a Coincident relation in the PropertyManager. The
result is a fully defined sketch, as shown in Figure 3.43.

FIGURE 3.43

The resulting sketch after you perform Step 14

1.000

15. Save the part with the name Sketch Relations Tutorial.sldprt. Close the
part.

Tutorial: Using Blocks and Belts

Sometimes I am amazed at the things that can be done in SolidWorks, even with fairly simple
tools. This is one of those times. If you design machines, this tutorial will have some extra meaning
for you. If you do not design machines, Blocks and Belts are still valuable tools to have in your
toolbox ready to use in various situations. Follow these steps to learn about using Blocks and Belts.
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Open a new part with inches as the units.

Draw a sketch on the Front plane as shown in Figure 3.44, with four lines con-
nected to the Origin. Exit the sketch and rename it Layout Sketch, either by clicking
twice on the name of the feature in the FeatureManager or by selecting it and pressing F2.

FIGURE 3.44

The layout sketch

12.000
18,000

Open a second sketch on the Front plane, and draw a circle centered on the Origin
with a 6-inch diameter.

Inside the circle, draw a Centerpoint rectangle centered on the Origin.

Select two adjacent sides of the rectangle and make an Equal sketch relation
between them. (This makes the rectangle into a square.)

Click the Smart Dimension tool, and apply a 1.000-inch dimension to one side of
the square. Turn off the Smart Dimension tool by clicking it again on the toolbar or
pressing Esc.

If the Blocks toolbar is not active, activate it and then select Make Block. You can
also access this command through Tools=> Block=> Make.

Window select the circle and the square by clicking and dragging a box that
includes all the items in the sketch. The PropertyManager to the left displays a circle
and five lines that are to be made into a block.

Expand the Insertion Point panel in the PropertyManager. This causes a blue manipu-
lator Origin to appear in the graphics window. Click this Origin and drag it onto the cen-
ter of the circle. Then click the green check mark icon to exit the Make Block dialog box.

This is shown in Figure 3.45.
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15.

16.
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19.

FIGURE 3.45

Creating a block
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The items in the block now turn gray. Click anywhere on the block and drag it out of
the way. Then drag the center of the circle and drop it on the part Origin.

Click the Insert Block tool on the Blocks toolbar. Place the block on the opposite
sharp corner of the layout sketch.

Create another block that is identical to the first one, except that it has a diameter
of 3 inches instead of 6 inches. You can do this by selecting the first block, clicking
Edit Block from the toolbar, and copying (Window select and Ctrl+C). Then exit the Edit
Block and paste (Ctrl+V) in the regular sketch. Make sure to also change the insertion
point for this second block to the center of the circle.

Insert a second instance of this second block, and make sure that both of them have
the center of the circle at the two remaining intersection points of the four-sided
shape of the layout sketch. At this point, your sketch should look like Figure 3.46.

Click the Belt/Chain tool on the Blocks toolbar. Select the blocks in counterclockwise
order, starting at the Origin. On the last pulley, you will have to click the arrow to get the
belt to go the correct way around the pulley.

Make sure that the Engage Belt option is selected. This enables you to make the pul-
leys move in the same way that they would in a real belt-driven mechanism.

Click the Use Belt Thickness option and assign .25 inches for the thickness. The belt
should be offset from the pulleys.

Click the green check mark icon.

Click and drag one of the corners of the square in a pulley. All the pulleys should
turn as if this were a real mechanism. The ratios are also observed because the small
pulleys rotate faster than the large ones.

Save this part as Blocks and Belts Tutorial.sldprt. Exit the part.
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FIGURE 3.46

Block placement

Tutorial: Reference Geometry

This tutorial steps you through creating reference geometry on an existing part in preparation for
locating 3D features.

On the CD-ROM

The Chapter 3 Reference Geometry . SLDPRT file (or drawing) used in this tutorial is in the Chapter 3
folder on the CD-ROM. m

1. Open the file from the CD-ROM in the Chapter 3 folder called Chapter 3
Reference Geometry.sldprt.

2. In the FeatureManager filter, type planel. Double-click Planel in the FeatureManager,
= then double-click the 3.25-inch dimension on the screen and change it to 3.35 inches.
Click the rebuild symbol (traffic light) and watch the update. This plane locates the
mounting base of the part.

When you are done, click the X at the right end of the FeatureManager filter to clear the
result. Pressing Esc does the same thing.

., 3. Click the Axis toolbar button from the Reference Geometry flyout menu (on the
‘ Features tab of the CommandManager in a default install).
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2 [\

4. Select the inside face of a hole on the part, as shown in Figure 3.47. This creates an

axis on the centerline of the hole. You should note that a temporary axis already exists for
all cylindrical faces, but making a true axis feature helps this one stand out as different
from the other holes on the part.

FIGURE 3.47

Making one hole stand out by creating an axis feature
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The selection of the Cylindrical/Conical Face option should be automatically activated by
your selection of the cylindrical face of the hole. Accept the result with the green check
mark when the selections and settings are complete.

Click the Plane toolbar button from the Reference Geometry flyout on the Features
tab of the CommandManager.

Select the large cylindrical face of the part as the First Reference and the axis you
just created as the Second Reference. Make sure the First Reference uses the Tangent
constraint and the Second Reference uses the Coincident constraint. This makes a plane
tangent to the main cylinder in the part that goes through the patterned hole, as shown in
Figure 3.48.

Click the green check mark to accept the result.
Open a new sketch on the new plane.

Click the View menu and activate the Temporary Axes option. You should now see
blue axes (without names) appear along the centerlines of every conical or cylindrical face
on the model (except for faces created by fillet or chamfer features).
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FIGURE 3.48

Creating a plane from tangent and coincident constraints
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Note

If the view is already normal to the selected plane, and you double-click Normal To, the view switches to 180
degrees opposite. For this exercise, it doesn’t matter which way you view the part, but from the top is better
than from the bottom because the view is clearer. m

9. Select the sketch plane either from the graphics window or the FeatureManager.
Press the Spacebar on the keyboard and double-click Normal To. There are other
ways to access this command, but this is the method that will work regardless of your
interface setup. You can use whatever method you prefer.

= 10. Use the Centerpoint Rectangle to create a rectangle centered around the temporary
axis of the large cylindrical face. Make sure that the centerpoint, which is the first click
you make, picks up a coincident automatic relation with the temporary axis. Make sure the
second click to place the corner of the rectangle does not pick up any automatic relations.

| You can tell if any relations have been applied if you go to the View menu and activate
P Sketch Relations. Make sure the centerpoint has a coincident relation and that none of
the corners has any relations.

Note

The temporary axis is not on the same plane as the sketch plane, so if the view is not normal to the sketch

plane, picking up an automatic relation between the centerpoint of the rectangle and the temporary axis will
be difficult. m
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0 11. Use the Smart Dimension tool to apply dimensions, as shown in Figure 3.49. Note
that the 3.450-inch dimension goes to the part origin on the left. You can select this from
either the graphics window or the FeatureManager.

FIGURE 3.49

Dimensioning the new sketch

Best Practice

It is best practice to dimension or create sketch relations to items that have the fewest other relations. You
should try to use the part origin and standard planes when possible. Dimensioning to reference geometry is
better than dimensioning to model edges, although this is not always possible. Experienced users will immedi-
ately recognize the need for removing layers of references to prevent restrictive parent-child relations and bro-
ken or dangling relations. For beginning users, after you have some experience with making changes to models
where relations have been applied carelessly, being more selective with sketch and dimension references will
look more attractive to you. m

@ 12. Click the Extrude toolbar button on the Features tab of the CommandManager.
Rotate the model (by dragging with the mouse wheel depressed. Click the middle mouse
button and drag) slightly so you can see the side of the extrusion preview, as shown in
Figure 3.50.

|T| You may have to adjust the direction of the extrude using the icon with the arrows just
— below the Directionl heading in the Boss-Extrude PropertyManager.

13. Use the Up To Next end condition, which makes the sketch go up to the next solid
that it encounters.

14. Use the View menu to turn off the display of Axes, Temporary Axes and Planes.
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FIGURE 3.50

Creating the extrusion from the new sketch
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Summary

Sketching in SolidWorks is something that you will do almost every time you open the software. A
lot of automated functions are available that you can allow to do much of the work for you. You
also have a lot of control to make changes manually. Remember that the best way to create most
sketches is to use automatic relations when you can, sketch the approximate shape that you want
to make, and then either drag it to pick up automatic relations, add dimensions, or add relations
manually.

The options for creating intelligent relationships that establish your design intent, as well as
SolidWorks’s capabilities in laying out mechanisms, is only limited by your imagination. The more
familiar you become with the tools in your toolbox, the more of a craftsman you can become with
this software.

Reference geometry is an essential part of creating and controlling relationships in any parametric
model. Reference geometry is usually more stable than solid geometry, so sketch relations and
dimensions should use reference geometry as references when possible.
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Creating Simple
Parts, Assemblies,
and Drawings

means that you should try to build parts that can adapt easily to
changes. This section of the book begins with questions that you
need to ask to model effectively.

G ood modeling practice is based on robust design intent. This just

Beginning to create simple parts will help you understand techniques used in
more complex modeling projects. Learning on simple tools and then
expanding your skills helps you to understand best practice issues, which
makes you a better contributor to a team environment.

Discovering Design Intent

By asking questions about the part’s function before you start modeling or
designing, you can create a model that will be easier to edit, easier to prop-
erly place into an assembly, easier to detail in drawings, and easier for other
SolidWorks users to understand when someone else has to work on your
models. Whether you are doing the modeling for someone else or doing the
design and modeling for yourself may make a difference in how you
approach the modeling task.

The purpose of these questions is to help you establish design intent. The
term design intent is a statement of how the part functions and how the
model reacts to modeling changes.

It may help if you try to put the design intent into words to help you focus
on what is important in the design. An example of a statement of design
intent is “This part is symmetric about two planes, is used to support a
1.00" diameter shaft with a constant downward load of 150 pounds using
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a bronze bushing, and is bolted to a plate below it.” This does not give you enough information
to design the part, but it does give you information about two surfaces that are important (a hole
for the bushing and the bottom that touches the mounting plate), as well as some general size
and load requirements. The following questions can help you develop the design intent for your
Own projects.

Is the part symmetrical?

Symmetry is an important aspect of design intent. Taking advantage of symmetry can significantly
reduce the time needed to model the part. Symmetry can exist on several levels:

® Sketch symmetry

e [ndividual feature symmetry

® Whole-part symmetry

® Axial symmetry (a revolved part)

e “Almost” symmetry (the whole part is symmetrical, except for a few features)
® Left and right symmetrical versions of the part

® Assembly symmetry

What are the primary or functional features?

This is probably the most important question. Primary or functional features include how the part
mounts or connects to other parts, motion that it needs to accommodate, and additional structure
to support loads.

Often it is a good idea to create a special sketch as the first feature in the part that lays out the
functional features. This could be as simple as a straight line to denote the bottom and a circle to
represent the position and size of a mating part, or as complex as full outlines of parts and fea-
tures from all three standard planes. This technique is called a layout sketch, and it is an impor-
tant technique in both simple and complex parts. You can use layout sketches for anything from
simply drawing a size-reference bounding box to creating the one point of reference for all
sketched features in the part. You can use multiple layout sketches if a single sketch on one
plane is not sufficient.

In what ways is the part likely to change?

When the marketing department gets out of their meeting at 4:45 pm, what changes do you need
to be prepared for so that you can still be out the door by 5:00 pm? No one expects you to be able
to tell the future, but you do need to model in such a way that your model easily adapts to future
changes. As you gain experience with the software and keep this idea in mind, you will develop
some instincts for the type of modeling that you do.
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What is the manufacturing method?

Modeling for the casting process is very different from modeling for the machining process.
When possible, the process should be evident in your modeling. There are times when you will
not know which process will be used to create the part when you start to create a model. If you
are simply making an initial concept model, you may not need to be concerned about the pro-
cess. In these cases, it may or may not be possible to reuse your initial model data if you need to
make a detailed cast part from your non-process-specific model. Decisions like this are usually
based on available time, how many changes need to be made, and a determination of the risk of
making the changes versus not making the changes as well as which decision will cost you the
most time in the long run.

Sometimes it makes sense to allow someone else to add the manufacturing details. A decision like
this depends on your role in the organization and your experience with the process compared with
that of other people downstream in the manufacturing process. For example, if you are not familiar
with the Nitrogen Gas Assist process for molding polypropylene, and you are modeling a part to be
made in that process, you might consider soliciting the help of a tooling engineer or passing the
work on to someone else to add engineering detail.

Best Practice

As engineers, we are typically perfectionists. However, there always needs to be a balance between perfection
and economy. Achieving both simultaneously is truly a rare event. Still, you should be aware that problems left
by the designer for other downstream applications to solve (such as machining, mold making, and assembly)
also have an impact on the time and cost of the project.

The best practice in this case is a judgment call. When faced with assembling a model sloppily or remodeling it
perfectly, I usually choose to remodel because doing it the second time is always faster. In addition, if addi-
tional changes are required, you do not need to struggle with the sloppily assembled model. You can easily
copy sketches from one part to another, while keeping the old part open as you build the new part. As a result,
you may be surprised how quickly things go. m

Will there be secondary operations?

When working with any manufacturing process, some secondary processes are generally required.
For example, if you have a cast part, you may need to machine the rough surface to create a flat
face in some areas. You may also need to ream or tap holes. In plastic parts, you may need to press
in threaded inserts.

SolidWorks includes special tools you can use to document secondary operations:

® Configurations. This SolidWorks technique enables you to create different versions of a
part. For example, one configuration may have the features for the secondary operations
suppressed (turned off) and showing just the part as cast, while the other configuration
shows the part as machined.
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Cross-Reference

Chapter 10 discusses configurations and feature suppression in depth. m

FIGURE 4.1

® Insert Part. This SolidWorks technique enables you to use one SolidWorks part as the
starting point for a second part. For example, the as-cast part has all the features to make
the part, but it is inserted as the first feature in the as-machined part, which adds the cuts
required by the machining process.

Will there be other versions?

Sometimes size-based versions of parts have to be created or versions based on additional features.
If these are simple, they can also be handled with configurations, but you need to plan this flexibil-
ity in advance.

Creating a Simple Part

You need to practice some of the skills you will learn on simple parts. Chapter 2 introduced the
tools and features you will use, and this chapter teaches you how to string the simple features
together intelligently. In this section, I'll show you how to build the simple part shown in Figure
4.1. While the shape is simple, the techniques used and discussed here are applicable to a wide
variety of real-world parts. The discussion on how to model the part contains information on some
of the topics you need to understand in order to do the work.

A simple machined part
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Tip

Deciding where to start

The first feature that you create should be positioned relative to the Origin. Whether there is a cor-
ner of a rectangle that is coincident to the Origin, the rectangle is centered on the Origin, or
dimensions are used to stand the rectangle off from the Origin at some distance, you need to lock
the first feature to the Origin with every part you build.

When working with a simple part, the entire part can usually be described as rectangular or cylin-
drical. In cases like these, it is easy to know where to start: you simply draw a rectangle or a circle,
respectively. On complex parts, it may not be obvious where to start, and the overall part cannot
be said to have any simple shape. In cases like these, it may be best to select the (or a) prominent
feature, mounting location, functional shape, or focus of the mechanism. For example, if you were
to design an automobile, what would you designate as the 0,0,0 Origin? The ground might be a
reasonable location as would the plane of the centers of the wheels. As long as everyone working
on the project agrees, many different reference points could work. With that in mind, it seems log-
ical to start the rectangular part by sketching a rectangle. Select the Top plane and sketch a rectan-
gle centered on the part Origin.

Building in symmetry

Your next decision is about part symmetry. This part is not completely symmetrical: modeling a
quarter of it and mirroring the entire model twice is not going to be the most effective technique.
Instead, you should build the complete part around the Origin and mirror individual features as

appropriate. To start this type of symmetry, you need to sketch a rectangle centered on the Origin.
The centered rectangle is something that you will create frequently.

Figure 4.2 shows a centerpoint rectangle that has been sketched with the centerpoint at the part
Origin. This creates symmetry in both directions. You can use additional construction geometry
and sketch relations to make the rectangle only symmetrical side to side.

To make a rectangle work like a square, use an Equal sketch relation on two adjacent sides. This only requires a
single dimension to drive the size of the square. m

&

Beginning with the rectangle you sketched in the previous section, apply one horizontal dimension
by clicking the Smart Dimension tool on a single horizontal line, placing the horizontal dimension

(4.00 inches), by clicking a vertical line, placing the vertical dimension (6.00 inches). The sketch is
fully defined at this point because both the size and position of the rectangle have been established.

Best Practice

If you are dimensioning a horizontal line, the best way to do it is to simply select the line and place the dimen-
sion. Selecting the line endpoints can also work, but selecting the vertical lines on either side of the horizontal
lines is not as robust. The problem is that if you use this third method, deleting either of the vertical lines causes
the dimension to be deleted. In the first two dimensioning methods, dimensions are not deleted unless you
remove one of the endpoints, which requires deleting two lines: the horizontal line and one of the vertical lines. m
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FIGURE 4.2

Using a center point rectangle to build symmetry about the Origin
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Making it solid

@ Next, click Extrude in the Features toolbar or choose Insert = Boss/Base & Extruded. In the
Direction 1 panel, select Mid Plane as the end condition. SolidWorks takes the distance that you
entered and extrudes it symmetrically about the sketch plane. Enter 1.00 inch as the distance.

Extrude feature options

The Extrude feature is one of the staples of SolidWorks modeling. Depending on the type of modeling
that you do, the Extrude feature may be one of your main tools.
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The Extrude interface
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Extruding from a selection

The From panel establishes where the Extrude feature starts. By default, SolidWorks extrudes from the
sketch plane. Other available options include:

o Surface/Face/Plane. The extrude begins from a surface body, a face of a solid, or a reference
plane.

Extruding from a surface

Cross-Reference
Surface features are discussed in detail in Chapter 27. m

® Vertex. The distance from the sketch plane to the selected vertex is treated as an offset distance.

e Offset. You can enter an explicit offset distance, and you can change the direction of the offset.

Direction 1 and Direction 2

Direction 1 and Direction 2 are always opposite one another. Direction 2 becomes inactive if you
select Mid Plane for the end condition of Direction 1. The arrows that display in the graphics window
show a single arrow for Direction 1 and a double arrow for Direction 2. For the Blind end condition,
which is described next, dragging the arrows determines the distance of the extrude.

|7‘| Each of the end conditions is affected by the Reverse Direction toggle. This toggle simply

— changes the default direction by 180 degrees. You need to be careful when using this fea-
ture, particularly when using the Up to end conditions, because if the entity that you are
extruding up to is not in the selected direction, an error results.

Following is a brief description of each of the available end conditions for the Extrude feature:

® Blind. Blind in this case means an explicit distance. The term is usually used in conjunction
with holes of a specific depth, although here it is associated with a boss rather than a hole.

e Up to Vertex. In effect, Up to Vertex works just like the Blind end condition, except that the
distance is parametrically controlled by a model vertex or sketch point.

continued
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continued

® Up to Surface. Up to Surface could probably be better named Up to Face, because the end
does not necessarily have to be an actual surface feature. This end condition may display a
warning if the projection of the sketch onto the selected face extends beyond the boundary of
the face. In that case, it is advisable to knit several faces together into a surface body and to
use the Up to Body end condition.

e Offset from Surface. By default, Offset from Surface extrudes until it reaches a specified dis-
tance from a selected surface. There are two methods for determining the type of offset and
one to determine direction.
® The default offset method behaves as if the selected surface were offset radially, so that a

surface with a 4-inch radius and a 1-inch offset would give a curvature on the end of the
extrude of a 3-inch radius.
® The second method, called Translate Surface, behaves as if the surface were moved by the

offset distance.

=)
/4

—_—

.-

Offset from surface using the default and
Translate Surface options

® Reverse Offset refers to when the offset stops short of the selected face or when it goes past it.
e Up to Body. The Up to Body end condition is very useful in many situations, especially when
receiving the error message, “The end face cannot terminate the extrusion,” from the Up to

Face end condition.

® Mid Plane. The Mid Plane end condition eliminates the Direction 2 options and divides the
extrude distance equally in both directions; for example, if you specify a 1.00-inch Mid
Plane, SolidWorks extrudes .50 inches in one direction and .50 inches in the other direction.
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T —

The Reverse Offset option

® Through All. The Through All end condition is available only when there is already solid
geometry existing in the part. When used for an extruded boss (which adds material), it
extrudes to the distance of the farthest point of the solid model in a direction perpendicular to
the sketch plane. When used for a cut, it simply cuts through everything.

e Up to Next. Up to Next extrudes the feature until it runs into a solid face that completely
intercepts the entire sketch profile. If a portion of the sketch hangs over the edge of the face,
the extrude feature will keep going until it runs into a condition that matches that description,
which may be the outer face of the part in the direction of the extrusion.

The Up to Next end condition used with a Cut extrude

continued
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continued

(2] By default, the Direction of Extrusion is normal to the sketch plane, but you can also select a
— linear entity such as an edge or axis as the direction. All the end-condition options are still
available when you manually define the Direction of Extrusion as something other than the
default.

(| Youcan also assign a draft option to an extrusion as it is created, and you can control the
— draft separately for Direction 1 and Direction 2.

Best Practice

When dealing with molded or cast parts, certain types of features, such as draft, fillets, and shells, are
often the targets of users trying to assign best practices. This is partially because using draft, fillets, and
shells is very much like playing Rock, Paper, Scissors; the only way to win this game is by luck. Arranging
the features in the correct order so that the model is efficient and achieves the desired results is challeng-
ing. It is usually best to apply draft as a separate feature rather than using it in the definition of the
Extrude feature. It is also best to apply draft after most of the modeling is done, but before you apply the
cosmetic fillets and before you use the shell feature. m

Thin Feature panel

The Thin Feature panel is activated by default when you try to extrude an open loop sketch (a sketch
that does not fully enclose an area). The end-condition options remain the same. What changes is the
feature applies a thickness to the sketch elements in the manner of a sheet metal part, thin-walled plas-
tic part, or a rib. The Thin Feature panel of the Extrude PropertyManager, along with a representative
thin feature extrusion.
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The Thin Feature panel and a thin feature extrusion

The Cap Ends option is available only when you specify a Thin Feature to be created from a closed loop
sketch. This creates a hollow, solid body in a single step. You can also use Thin Features with cuts, and
they are very useful for creating slots or grooves.
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Contour selection

Contour selection enables you to select areas completely bounded by sketch entities for use with fea-
tures such as Extrude. For example, you could use a sketch like the number sign (#). Although it breaks
the rule and cannot be used with regular extrusion methods, you can use contour selection to select the
box in the center, which is completely bound by sketch elements.

SolidWorks works best when the sketches are neat and clean, when nothing overlaps, and when no
extra entities exist. However, when you need to use a sketch that does not meet these criteria, you can
use this alternative method.

Best Practice

I believe this feature was introduced into SolidWorks only to keep up with other CAD packages, not
because it is a great feature. | do not recommend using contour selection on production models. It is use-
ful for creating quick models, but the selection is too unstable for any data that you may want to rely on
in the future. The main problem is that if the sketch changes, the selected area may also change, or
SolidWorks may lose track of it entirely. m

Using Instant 3D

o Instant 3D enables you to pull handles to create extrusions and to drag model faces to change the

"= size and location of features. Several [eature types enable you to use arrows to adjust elements visu-
ally of parametric features and sketches. The function largely replaces and expands on the older
functionality called Move/Size Features. Figure 4.3 shows the arrows added by Instant 3D, which
are the handles that you pull on to create a solid from a sketch or edit an existing feature. Notice
also that you can make cut features with Instant 3D. In fact, you can change a boss feature into a
cut. 'm sure this is a neat sales demo trick, but I'm not aware of any practical application of chang-
ing a boss into a cut.

One of the attractive things about Instant 3D is that it allows you to make changes to parts quickly
without any consideration for how the part was made. For example, the cylindrical part was made
from a series of extrudes, with a hole cut through it with draft on the cut feature. The flat faces can
be moved, and the cylindrical faces offset. Behind the scenes, SolidWorks figures out which
sketches or feature parameters of which features have to be edited. This saves you time searching
the FeatureManager to figure out which features or sketches control a given face. As you work
through more complex parts, you will see how handy this can be at times. You can activate or
deactivate Instant 3D using the icon on the Features toolbar.

Note

When combined with the sketch setting Override Dims on Drag, Instant 3D can be a powerful concepting tool,
even on fully dimensioned sketches. m
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FIGURE 4.3

Using Instant 3D and Live Section
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Instant 3D also offers a tool called Live Section. Live Section enables you to section a part with a
plane, and you can drag the edges of the section regardless to which features the edges belong. To
activate Live Section, right-click a plane that intersects the part and select Live Section Plane.

Instant 3D can also be an effective tool when used in conjunction with the direct editing type of
tools such as Move Face. In fact, Instant 3D mimics some of the direct edit type of functionality
found in applications such as Sketchup and Spaceclaim.

Chapter 30 discusses the direct edit theme in more detail, and revisits the Instant 3D manipulators
in that light.
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Making the first extrude feature

Going back to the sketch in Figure 4.2, T will show you how to continue building the part using
the newly learned tools. By centering the sketch on the Origin and extruding by using a Mid Plane
end condition, the initial block is built symmetrically about all three standard planes, with the part
Origin at the center. In many parts, this is a desirable situation. It enables you to create mirrored
features using the standard planes, and helps you to assemble parts together in an assembly later,
when parts must be centered and do not have a hard face-to-face connection with other parts.
Figure 4.4 shows the initial feature with the standard planes.

FIGURE 4.4

An initial extruded feature centered on the standard planes
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When you create a feature from a sketch, SolidWorks hides and absorbs (consumes) the sketch under the fea-
ture in the FeatureManager, so you need to click the plus sign next to the feature to see the sketch in the tree.
You can right-click the sketch in the FeatureManager to show it in the graphics window. m

The next modeling step is to create a groove on the back of the part. How is this feature going to
be made? You can use several techniques to create this geometry. List as many techniques as you

can think of, whether or not you know how to use them. Later, I will go through several tech-
niques that work.

Tip
One of the secrets to success with SolidWorks, or indeed any tool-based process, is to know several ways to

accomplish any given task. By working through this process, you gain problem-solving skills as well as the abil-
ity to improvise when the textbook method fails. m

Figure 4.5 shows multiple methods for creating the groove. From the left to the right, the methods
are a thin feature cut, a swept cut, and a nested loop sketch.
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FIGURE 4.5

Methods for creating the groove

With a thin feature cut, you sketch the centerline, and in the Cut-Extrude feature, select the Thin
Feature option and assign a width and depth. The option on the right is what is called a “nested
loop,” because it has a loop around the outside of the slot and another around the inside. Only the
material between the loops is cut away. The method in the center is a sweep where the cross sec-
tion of the slot is swept around a path to make the cut.

Another potential option could include a large pocket being cut out, with a boss adding material
back in the middle. Each option is appropriate for a specific situation. The thin feature cut is prob-
ably the fastest to create, but also the least commonly used technique for a feature of this type.
Most users tend to use the nested loop option (one loop inside another).

Relative size or direct dimensions

You can control the size of the groove as an offset from the edges of the existing part or you can
drive them independently. Again, this depends on the type of changes you anticipate. If the groove
will always depend on the size of the part, the decision is easy. If the groove changes indepen-
dently from the part, you will need to re-create relations within the sketch to reflect different
design intent. To create a groove, you can create a rectangle by offsetting the block shape and use
sketch fillets to round the corners.

Creating the offset

You need to consider one more thing before you create the sketch. What should you use to create the
offset — the actual block edges or the original sketch? The answer to this is a Best Practice issue.

Best Practice

When creating relations that need to adapt to the biggest range of changes to the model, it is best to go as far
back in the model history as you can to pick up those relations. In most cases, this means creating relations to
sketches or reference geometry rather than to edges of the model. Model edges can be fickle, especially with
the use of fillets, chamfers, and drafts. The technique of relating features to driving layout sketches helps you
create models that do not fail through the widest range of changes. m
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To create the offset for your part, follow these steps:

Tip

Open a sketch on the face of the part. To create the offset, expand the Extrude feature
by clicking the plus icon next to it in the FeatureManager so that you can see the sketch.

Regardless of how it displays here, this sketch appears before the extrude in the part his-
tory. Right-click the sketch and select Show.

You can view individual sketches and reference geometry entities such as planes from the RMB menu. The

global settings for the visibility of these items are found in the View menu. You can access these items faster by
using the View toolbar, or by linking the commands to hotkeys. m

2. Right-click the sketch in the graphics window and click Select Chain. This selects any

non-construction, end-to-end sketch entities. Click Offset Entities on the Sketch toolbar.
Offset to the inside by .400 inches. Apply .500-inch sketch fillets to each of the corners.

Click Extruded Cut on the Feature toolbar. By default, the extruded cut will cut away
everything inside the closed profile of the sketch. Look down the FeatureManager win-
dow and select the check box on the top bar of the Thin Feature panel. Make the cut
Blind, .100 inch. The Thin Feature type should be set to Mid Plane with a width of .400
inches. The PropertyManager and graphics window should look like Figure 4.6.

Creating the groove with a thin feature cut
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Sketch techniques

Although you could create the next two features more easily and efficiently using a cut, I will show
you how to create them as two extrudes. The intent here is to show some useful sketch techniques
rather than optimum efficiency. Begin with the part from the previous section and follow these steps:

1. Open a new sketch on the large face opposite from the groove. Draw a corner rectan-
gle picking up the automatic coincident relation to one corner and then dragging across
the part and picking up another coincident to the edge on the opposite side. Figure 4.7
shows the rectangle before and after this edit.

Tip

If you want to continue using the recommended best practice mentioned earlier of making relations to
sketches rather than model edges, here are a few tips. In some situations (such as the current one), the sketch
plane is offset from the sketch that you want to make relations to, and the best bet is to use the Normal To
view. The next obstacle is making sure that automatic relations pick up the sketch rather than the edge, and so
you can use the Selection Filter to select sketch entities only. m

2. Delete the Horizontal relation on the line that is not lined up with an edge. This
enables you to drag it to an angle or apply the dimensions shown in Figure 4.7.

3. Extrude sketch to a depth of 0.25 inch.

FIGURE 4.7

Edits to a rectangle
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You can delete the Horizontal relation by selecting the icon on the screen and pressing
Delete on the keyboard. As a reminder, you can show and hide the sketch relation icons
from the View menu. You can check to ensure that the relations were created to the
sketch rather than the model edges by clicking the Display/Delete Relations button on the
Sketch toolbar, clicking the relation icon to check, and expanding the Entities panel in
the PropertyManager. The Entities box shows where the relation is attached to, as shown
in Figure 4.8. In this case, it is a point in Sketchl. Without custom programming, there is
no way to identify items in a sketch by name, but you already know which point it is;
you just needed to know whether it was in the sketch or on the model. The second
sketch trick involves the use of a setting.

FIGURE 4.8

The Display/Delete Relations dialog box
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Choose Tools=> Options = Sketch and ensure that Prompt to Close Sketch is turned
on; then click OK to close the dialog box.

Open another new sketch on the same face that was used by the last extrusion.
Draw an angled line across the left and bottom sides of the box with the dimensions
shown in Figure 4.9. In this case, for this technique to work, the endpoints of the line
have to be coincident with the model edges rather than the sketch entities.

This line by itself constitutes an open sketch profile, meaning that it does not enclose an
area and has unshared endpoints. Ordinarily, this results in a Thin Feature, as described
earlier, but when the endpoints are coincident with model edges that form a closed loop
and the setting mentioned previously is turned on, SolidWorks automatically gives you
the option of using the model edges to close the sketch. This saves several steps com-
pared to selecting, converting, and trimming manually.
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FIGURE 4.9

Using the prompt to close a sketch setting
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6. Click the Extrude tool on the Features toolbar. Answer yes to the prompt, and double-
click the face of the previous extrusion. SolidWorks automatically uses the face that you
double-clicked for an Up to Surface end condition. This is a sim